Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

WRED mix and match for IP-Precedence and DSCP

i was unable to locate a QoS section, so i figured someone from the SP world can provider a answer. Here is what i have.

2 policy-map let's call it A, and B

A policy-map has class-map A which is matching IP-Precedence x, but under the WRED it's actually matching DSCP value. WREd profile must be 3 or below. so if i create 4 profile, and apply the service-policy output to the interface i get the following error:

GSR(config-if)#service-policy output OC-3-test-BoA

% Only up to 3 different WRED profiles per queue are supported - class 'A' has 4 profiles

Now if i configure Policy-map B with class-map B which is matching dscp, i can apply more than 4 profile of WRED, with out no problem.

Did you guys ran into this.

I tried this on 7200 and the mixing of IP-Precedence/DSCP works fine and it gives more than 4 profiles. by the way this is only seen on GSR that is running 32SY0 code.



Re: WRED mix and match for IP-Precedence and DSCP

7200 implements QoS in software, whereas on GSR it's implemented in HW. Some differences are due to implementation. I haven't had need for several WRED profiles per queue, but for example number of queues is limited in GSR and scheduler is hardware MDRR instead of software WRR.

I've just tried in the lab and saw similar to what you've seen, although it didn't allow more than three WRED profiles regardless whether class matched on prec or dscp. The IOS was 12.0(32)SY4.

New Member

Re: WRED mix and match for IP-Precedence and DSCP

Thanks for the reply, i agree with your, after reading more, i found only 3 bits for redcos in E5 and 2 bits for E3 cards like Tetra in hardware. Cisco do not have more than 3 bits for redcos on any LC, since it should not work. So how was I able to configure when i had DSCP in the class-map and WRED? hmmm maybe bug?

Thanks for the respond, i just wanted to confirm .