Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

xconnect problem. cant ping from CE to CE

Hi Guys,

I'm having issues with my xconnect tunnel. i couldn't ping from CE to CE. is theres something that i missed in my config?

CE2#sh run int Gi0/0.1104
Building configuration...

Current configuration : 201 bytes
!
interface GigabitEthernet0/0.1104
encapsulation dot1Q 1104
ip vrf forwarding admin
ip address 10.210.64.193 255.255.255.252
ip router isis Admin
end

PE2#sh run int Gi0/0.1104
Building configuration...

Current configuration : 222 bytes
!
interface GigabitEthernet0/0.1104
description Admin:EoMPLS to PE1
encapsulation dot1Q 1104
xconnect 10.215.0.133 1104 encapsulation mpls
service-policy input police_1M
service-policy output shape_1M
end

PE2#sh xconnect all

Legend: XC ST=Xconnect State, S1=Segment1 State, S2=Segment2 State

UP=Up, DN=Down, AD=Admin Down, IA=Inactive, NH=No Hardware

XC ST Segment 1 S1 Segment 2 S2

------+---------------------------------+--+---------------------------------+--

UP ac Gi0/0.1105 1105(Eth VLAN) UP mpls 10.215.0.109:1105 UP

UP ac Gi0/0.1107 1107(Eth VLAN) UP mpls 10.215.0.109:1107 UP

UP ac Gi0/0.1104 1104(Eth VLAN) UP mpls 10.215.0.133:1104 UP

UP ac Gi0/0.1106 1106(Eth VLAN) UP mpls 10.215.0.133:1106 UP

PE2#ping 10.215.0.133

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.215.0.133, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms

===========================================================================

CE1#sh run int Fa0/1.1104
Building configuration...

Current configuration : 255 bytes
!
interface FastEthernet0/1.1104
description Admin:EoMPLS to CE2
encapsulation dot1Q 1104
ip address 10.210.64.194 255.255.255.252
ip router isis area_0054
clns mtu 1467
clns router isis area_0054
isis circuit-type level-2-only
end

PE1#sh run int Gi0/1.1104
Building configuration...

Current configuration : 224 bytes
!
interface GigabitEthernet0/1.1104
description Admin:EoMPLS to PE2
encapsulation dot1Q 1104
xconnect 10.214.254.107 1104 encapsulation mpls
service-policy input police_1M
service-policy output shape_1M
end

PE1#ping 10.214.254.107

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.214.254.107, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms

5 REPLIES
New Member

xconnect problem. cant ping from CE to CE

Try this on PE2.

ping mpls pseudowire 10.215.0.133 1104 source 10.214.254.107

New Member

xconnect problem. cant ping from CE to CE

I couldn't ping the PE1.. do you have any idea what could possibly wrong? thanks.

PE2#ping mpls pseudowire 10.215.0.133 1104 source 10.214.254.107
Sending 5, 100-byte MPLS Echos to 10.215.0.133,
     timeout is 2 seconds, send interval is 0 msec:

Codes: '!' - success, 'Q' - request not sent, '.' - timeout,
  'L' - labeled output interface, 'B' - unlabeled output interface,
  'D' - DS Map mismatch, 'F' - no FEC mapping, 'f' - FEC mismatch,
  'M' - malformed request, 'm' - unsupported tlvs, 'N' - no label entry,
  'P' - no rx intf label prot, 'p' - premature termination of LSP,
  'R' - transit router, 'I' - unknown upstream index,
  'X' - unknown return code, 'x' - return code 0

Type escape sequence to abort.
.....
Success rate is 0 percent (0/5)

xconnect problem. cant ping from CE to CE

Windell,

The problem could be that one of the interfaces in between doesnt have mpls ip enabled on its interface.

Also, if an LSP Ping is unsuccessful and times out  (resulting "....."), the failure might occur on the return path. In this  case, retry the router-alert reply  mode. This mode instructs all intermediate routers in the return path to  process the packet. This option is most useful for isolating MPLS  switching path problems.

If you do not get a reply to a ping mpls pseudowire  using the default IPv4 reply mode, but you do get a successful reply  using the RA reply mode, you can infer that a switching path problem  exists in the return path, most likely a CEF inconsistency between the  linecard and the RP card in an intermediate node. You can reach this  conclusion because with RA reply mode, all MPLS Echo Reply packets are  punted to the RP to be processed switched.

HTH

Kishore

New Member

xconnect problem. cant ping from CE to CE

I still couldnt reach it.. but i can see it on my ldp neighbor.

PE2#$ping mpls ipv4 10.215.0.133/32 source 10.214.254.107 reply mode ipv4
Sending 5, 100-byte MPLS Echos to 10.215.0.133/32,
     timeout is 2 seconds, send interval is 0 msec:

Codes: '!' - success, 'Q' - request not sent, '.' - timeout,
  'L' - labeled output interface, 'B' - unlabeled output interface,
  'D' - DS Map mismatch, 'F' - no FEC mapping, 'f' - FEC mismatch,
  'M' - malformed request, 'm' - unsupported tlvs, 'N' - no label entry,
  'P' - no rx intf label prot, 'p' - premature termination of LSP,
  'R' - transit router, 'I' - unknown upstream index,
  'X' - unknown return code, 'x' - return code 0

Type escape sequence to abort.
.....
Success rate is 0 percent (0/5)

PE2#sh mpls ldp neigh

Peer LDP Ident: 10.215.0.133:0; Local LDP Ident 10.214.254.107:0

        TCP connection: 10.215.0.133.13109 - 10.214.254.107.646

        State: Oper; Msgs sent/rcvd: 15109/15097; Downstream

        Up time: 18:11:49

        LDP discovery sources:

          Targeted Hello 10.214.254.107 -> 10.215.0.133, active, passive

        Addresses bound to peer LDP Ident:

          10.215.0.133    172.16.8.97     172.16.8.101    10.210.64.117

          10.210.64.253   10.210.64.105   10.210.64.193   10.210.64.189

          10.210.64.85    10.210.64.81

Cisco Employee

xconnect problem. cant ping from CE to CE

Hi, Windell

As Kishore mentioned, your problem is not necessary related to your PE device configuration - it could be problem of core network infrastructure.

For starting of troubleshooting of this issue following information required:

- simple network map

PE1 output:

- show mpls l2 vc 1104 det

- ping mpls pseudo 10.214.254.107 1104

- ping mpls pseudo 10.214.254.107 1104 reply mode router-alert

PE2 output:

- show mpls l2 vc 1104 det

- ping mpls pseudo 10.215.0.133 1104

- ping mpls pseudo 10.215.0.133 1104 reply mode router-alert

BTW, which devices are used as P and PE?

BR,

Nataliya.

1822
Views
0
Helpful
5
Replies