cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2444
Views
0
Helpful
0
Comments
roguep4cket
Community Member

Hi, I have a Cisco router that I want to run IPTV and Multicast on. My Service provider passes PPPoA over PVC 0,38.

TV is as such:


Unicast DHCP/VOD = PVC 0,65

Multicast = PVC 0,67

Set Top Box will be on a 10.x.x.x subnet. I aim to setup my PC (data) for 192.168.1.0/24...

Ok, so I know I need to run bridging here and maybe IRB so my config is as such:

bridge irb

!

!

!

!

interface FastEthernet0

no ip address

ip pim sparse-mode

ip igmp helper-address udl ATM0.2

ip igmp proxy-service

duplex half

bridge-group 1

!

interface Serial2/0

no ip address

shutdown

serial restart-delay 0

!

interface Serial2/1

no ip address

shutdown

serial restart-delay 0

!        

interface Serial2/2

no ip address

shutdown

serial restart-delay 0

!

interface Serial2/3

no ip address

shutdown

serial restart-delay 0

!

interface ATM0

no ip address

no atm ilmi-keepalive

!

interface ATM0.1 point-to-point

atm route-bridged ip

bridge-group 1

pvc 0/65

!

!

interface ATM0.2 point-to-point

ip pim sparse-mode

ip igmp unidirectional-link

atm route-bridged ip

bridge-group 1

pvc 0/67

!

!

ip forward-protocol nd

ip forward-protocol udp bootpc

no ip http server

no ip http secure-server

!

!

!

logging alarm informational

!

!

!

!

!

!

control-plane

!

bridge 1 protocol ieee

bridge 1 route ip

!

Can I bridge from one Ethernet port to two differnet ATM PVC's? Will this work ok? Also, how can I setup the Internet? Shall I set the BVI1 to an address in the normal "DHCP" subnet like 192.168.1.0/24 and setup and dialer etc for atm0.3 like:

bridge irb

!

!

!

!

interface FastEthernet0/0

no ip address

ip pim sparse-mode

ip igmp helper-address udl ATM3/0.2

ip igmp proxy-service

duplex half

bridge-group 1

!

interface Serial2/0

no ip address

shutdown

serial restart-delay 0

!

interface Serial2/1

no ip address

shutdown

serial restart-delay 0

!

interface Serial2/2

no ip address

shutdown

serial restart-delay 0

!

interface Serial2/3

no ip address

shutdown

serial restart-delay 0

!

interface ATM3/0

no ip address

no atm ilmi-keepalive

!

interface ATM3/0.1 point-to-point

atm route-bridged ip

bridge-group 1

pvc 0/65

!

!

interface ATM3/0.2 point-to-point

ip pim sparse-mode

ip igmp unidirectional-link

atm route-bridged ip

bridge-group 1

pvc 0/67

!

!

interface ATM3/0.3 point-to-point

pvc 0/38

  dialer pool-member 1

  protocol ppp dialer

!

!

interface Dialer0

ip address negotiated

encapsulation ppp

dialer pool 1

dialer idle-timeout 0

dialer persistent

dialer-group 1

no cdp enable

ppp authentication chap callin

ppp chap hostname <ADSL-Username>_<VPN>

ppp chap password 0 <Password>

ppp timeout idle 2147483

!

interface BVI1

ip address 192.168.1.254 255.255.255.0

!

ip forward-protocol nd

ip forward-protocol udp bootpc

no ip http server

no ip http secure-server

!

!

!

logging alarm informational

!

!

!

!

!        

!

control-plane

!

bridge 1 protocol ieee

bridge 1 route ip

SO therefore allowing DHCP for the stb and bridging it as well as bridging the Multicast to two different VC's and allowing for PPPoA out the same Ethernet...

Can this be done??

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: