cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
5043
Views
7
Helpful
0
Comments
SunilKhanna
Level 1
Level 1

     

    Introduction

    Telnet is a network protocol used on the Internet or LAN to provide bidirectional connection to remote hosts by using virtual terminal connection (VTY). Telnet provides access to a command-line interface on a remote machine.

    Requirements
    • Understanding of IPv6 Addressing Scheme
    • Telnet basics

    Background

     

    In this configuration example, we are trying to establish a TELNET connection with an IPV6 host (1033:ABC:33::3/64) residing at R3 from router R1. On line VTY interface and password are configured on router R3 to enable TELNET access. OSPFV3 is the routing protocol configured on the three routers (R1, R2 and R3) with all networks/prefixes participating in backbone area 0.

     

    Note: All configurations are tested in a lab environment on Cisco 7200 series router with IOS C7200-ADVIPSERVICESK9-M), Version 15.0(1).

     

    Topology Diagram

    IPv6_Telnet_Topo.jpg

     

    Configuration

     

    Router R1Router R2Router R3Router R4

    hostname R1

    ipv6 unicast-routing

    ipv6 cef

    !

    interface FastEthernet1/0

    no ip address

    duplex auto

    speed auto

    ipv6 address 1011:AB01:12::1/64

    ipv6 enable

    ipv6 ospf 10 area 0

    no sh

    !

    ip forward-protocol nd

    !

    ipv6 router ospf 10

    router-id 1.1.1.1

    log-adjacency-changes

    end

    hostname R2

    !

    ipv6 unicast-routing

    ipv6 cef

    !

    interface FastEthernet1/0

    no ip address

    duplex auto

    speed auto

    ipv6 address 1011:AB01:12::2/64

    ipv6 enable

    ipv6 ospf 10 area 0

    no sh

    !

    interface FastEthernet1/1

    no ip address

    duplex auto

    speed auto

    ipv6 address 1011:AB01:234::2/64

    ipv6 enable

    ipv6 ospf 10 area 0

    no sh

    !

    ipv6 router ospf 10

    router-id 2.2.2.2

    log-adjacency-changes

    !

    end

    hostname R3

    !

    enable password cisco

    !

    ipv6 unicast-routing

    !

    ipv6 cef

    interface Loopback0

    no ip address

    ipv6 address 1033:ABC:33::3/64

    ipv6 enable

    ipv6 ospf 10 area 0

    !

    interface FastEthernet1/0

    no ip address

    duplex auto

    speed auto

    ipv6 address 1011:AB01:234::3/64

    ipv6 enable

    ipv6 ospf 10 area 0

    no sh

    !

    ipv6 router ospf 10

    router-id 3.3.3.3

    log-adjacency-changes

    !

    line vty 0 4

    password cisco

    login

    line vty 5 15

    password cisco

    login

    !

    end

    hostname R4

    !

    ipv6 unicast-routing

    ipv6 cef

    !

    interface FastEthernet1/0

    no ip address

    duplex auto

    speed auto

    ipv6 address 1011:AB01:234::4/64

    ipv6 enable

    ipv6 ospf 10 area 0

    no sh

    !

    ipv6 router ospf 10

    router-id 4.4.4.4

    log-adjacency-changes

    !

    line vty 0 4

    login

    !

    end

     

    Telnet Demonstration

    Telnet.JPG

    Note: For IPv6 Host Telnet demonstration click anywhere on the above picture.

    Verify Commands

     

    R3#sh users

    Line User Host(s) Idle Location

    * 0 con 0 idle 00:00:00

    2 vty 0 idle 00:00:07 1011:AB01:12::1

    Interface User Mode Idle Peer Address

     

    Debugs as seen on Router R3

     

    *Oct 9 17:49:30.083: Telnet2: 1 1 251 1

    *Oct 9 17:49:30.083: TCP2: Telnet sent WILL ECHO (1)

    *Oct 9 17:49:30.087: Telnet2: 2 2 251 3

    *Oct 9 17:49:30.087: TCP2: Telnet sent WILL SUPPRESS-GA (3)

    *Oct 9 17:49:30.087: Telnet2: 80000 80000 253 24

    *Oct 9 17:49:30.087: TCP2: Telnet sent DO TTY-TYPE (24)

    *Oct 9 17:49:30.087: Telnet2: 10000000 10000000 253 31

    *Oct 9 17:49:30.091: TCP2: Telnet sent DO WINDOW-SIZE (31)

    *Oct 9 17:49:30.207: TCP2: Telnet received DO SUPPRESS-GA (3)

    *Oct 9 17:49:30.211: TCP2: Telnet received WILL WINDOW-SIZE (31)

    *Oct 9 17:49:30.211: TCP2: Telnet received WILL LOCAL-FLOW (33)

    *Oct 9 17:49:30.211: TCP2: Telnet sent DO LOCAL-FLOW (33)

    R3#

    *Oct 9 17:49:30.215: Telnet2: Sent SB 33 0

    *Oct 9 17:49:30.363: TCP2: Telnet received DO ECHO (1)

    *Oct 9 17:49:30.395: TCP2: Telnet received WONT TTY-TYPE (24)

    *Oct 9 17:49:30.395: TCP2: Telnet sent DONT TTY-TYPE (24)

    *Oct 9 17:49:30.399: Telnet2: recv SB NAWS 80 24

     

    References
    Getting Started

    Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: