Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

Configuring and Troubleshooting VWIC2-xCTE1-PRI Modules for Inbound ISDN Multilink PPP Data Calls

Configuring and Troubleshooting VWIC2-xCTE1-PRI Modules for Inbound ISDN Multilink PPP Data Calls

We have seen more and more customers are now moving away from traditional NM-xCTE1-PRI and HWIC-xCTE1-PRI modules which supports data and modem calls (not voice calls) to VWIC2-xMFT-T1/E1 modules which supports Data and Voice calls together on same PRI lines. We have seen increased deployment of VWIC2-xMFT-T1/E1 modules on Integrated Service Routers that supports voice and data calls on same PRI line.

This document describes how to configure ISDN PRI interfaces on VWIC2-xMFT-T1/E1 modules with PVDM2-xx to support data calls on multiservice access routers. This feature enables Multilink PPP data (dial-in, dial-on-demand routing [DDR], and DDR backup) and voice call traffic to occur simultaneously from the supported ISDN PRI interfaces.

Supported Modules

This feature supports the following modules:

–NM-HD

–NM-HDV2

–Onboard DSPs

•This feature is supported on the following voice cards:

–VWIC-XMFT-X interface modules

–VWIC2-XMFT-X interface modules


Note http://www.cisco.com/en/US/i/templates/blank.gifData calls are supported only on the NM-HDV2-2T1/E1 and NM-HD-2V-E network modules, and the VWIC-2MFT-E1, VWIC-2MFT-T1 and VWIC2-T1/E1 voice cards.


Use the isdn switch-type ? command in interface configuration mode or global configuration mode to view the list of supported ISDN switch types. See the following example:

Router(config)# isdn switch-type ?

  primary-4ess    Lucent 4ESS switch type for the U.S.

  primary-5ess    Lucent 5ESS switch type for the U.S.

  primary-dms100  Northern Telecom DMS-100 switch type for the U.S.

  primary-dpnss   DPNSS switch type for Europe

  primary-net5    NET5 switch type for UK, Europe, Asia and Australia

  primary-ni      National ISDN Switch type for the U.S.

  primary-ntt     NTT switch type for Japan

  primary-qsig    QSIG switch type

  primary-ts014   TS014 switch type for Australia (obsolete)

Restrictions for Integrating Data and Voice Services for ISDN PRI Interfaces

•This feature is supported only on C5510 DSP-based platforms.

ISDN backhaul is not supported.

This feature does not support modem calls.

For platforms that support HDLC resources on the motherboard, the available on board HDLC resources are limited to 31 if all resources are not enabled.

The Cisco 2801 platform does not support full channelized data or full integrated data and voice over T1/E1 PRI interfaces. However, data back up through one PRI channel, or one group of PRI channels for data backup, is supported on this platform.

Only PPP with multilink is supported for multiple channels. HDLC is not supported for multiple channels.

This feature is not supported from a BRI interface.

• following dialer commands are not supported with the integrated data and voice feature:

dialer aaa

dialer callback-secure

dialer callback-server

dialer dns

dialer order

dialer persistent

dialer redial

dialer vpdn

dialer watch-disable

dialer watch-group

dialer watch-list

dialer watch-list delay

Components Used

The information in this document is based on these software and hardware versions in the lab environment

·       Cisco 3845 with VWIC2-2MFT-T1/E1 and PVDM2-64 running IOS® Software Release 12.4(24)T1

·       Cisco 2811 with WIC-1B-U-V2 running IOS® Software Release 12.4(7h)

Note: The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Network Diagram

This document uses this network setup:

3845-VWIC2.GIF

In above network diagram, 2811 as a Branch router with BRI lines dialing in to 3845 ISR router with PRI lines using Multilink PPP calls. Detailed configuration of 2811 Branch router is not the intended purpose of this document.

Configurations

Cisco 2811 Branch router

2811-1#sh run

Building configuration...

Current configuration : 1165 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname 2811-1

!

boot-start-marker

boot system flash:c2800nm-advsecurityk9-mz.124-7h

boot-end-marker

!enable password cisco

!

no aaa new-model

!

resource policy

!

ip cef

!

isdn switch-type basic-5ess

!

username cisco password 0 cisco

archive

log config

  hidekeys

!

interface GigabitEthernet0/1

ip address 11.0.0.1 255.255.255.0

load-interval 30

duplex auto

speed auto

!

interface BRI0/0/0

ip address negotiated

encapsulation ppp

dialer idle-timeout 120 either

dialer string 914084283115

dialer load-threshold 2 either

dialer-group 1

isdn switch-type basic-5ess

isdn point-to-point-setup

ppp authentication chap callin

ppp chap hostname Param

ppp chap password 0 cisco

ppp multilink

!

ip route 0.0.0.0 255.255.255.255 BRI0/0/0

!

no ip http server

no ip http secure-server

!

dialer-list 1 protocol ip permit

!

!

control-plane

!

line con 0

line aux 0

line vty 0 4

password cisco

login

!

scheduler allocate 20000 1000

!

end

2811-1#

2811-1# sh diag

Slot 0:

            C2821 Motherboard with 2GE and integrated VPN Port adapter, 2 ports

            Port adapter is analyzed

            Port adapter insertion time unknown

            Onboard VPN                        : v2.2.0

            EEPROM contents at hardware discovery:

            PCB Serial Number        : FOC08212CQB

            Hardware Revision        : 0.9

            Top Assy. Part Number    : 800-23519-01

            Board Revision           : 13

            Deviation Number         : 0

            Fab Version              : 08

            RMA Test History         : 00

            RMA Number               : 0-0-0-0

            RMA History              : 00

            Processor type           : 87

            Hardware date code       : 20040524

            Chassis Serial Number    : FHK0829F048

            Chassis MAC Address      : 000f.352c.8bf1

            MAC Address block size   : 36

            CLEI Code                : CNMJ600BRA

            Product (FRU) Number     : CISCO2821     

            Part Number              : 73-8854-09

            Version Identifier       :   NA

            EEPROM format version 4

            EEPROM contents (hex):

              0x00: 04 FF C1 8B 46 4F 43 30 38 32 31 32 43 51 42 40

              0x10: 03 E8 41 00 09 C0 46 03 20 00 5B DF 01 42 31 33

              0x20: 88 00 00 00 00 02 08 03 00 81 00 00 00 00 04 00

              0x30: 09 87 83 01 31 CB 4C C2 8B 46 48 4B 30 38 32 39

              0x40: 46 30 34 38 C3 06 00 0F 35 2C 8B F1 43 00 24 C6

              0x50: 8A 43 4E 4D 4A 36 30 30 42 52 41 CB 8F 43 49 53

              0x60: 43 4F 32 38 32 31 20 20 20 20 20 20 82 49 22 96

              0x70: 09 89 20 20 4E 41 D9 02 40 C1 FF FF FF FF FF FF

            WIC Slot 0:

            BRI U - 2091, 3086 WAN daughter card

            Hardware revision 1.0                     Board revision H0

            Serial number     33000351              Part number    800-19400-01

            FRU Part Number     WIC-1B-U-V2=     

            Test history      0x0                     RMA number     00-00-00

            Connector type    Wan Module

            EEPROM format version 1

            EEPROM contents (hex):

              0x20: 01 45 01 00 01 F7 8B 9F 50 4B C8 01 00 00 00 00

              0x30: 88 00 00 00 05 01 13 01 FF FF FF FF FF FF FF FF

Note:

In order for 3845 with VWIC2-2MFT-T1/E1 card to accept the data calls, need to make sure that dial-peer for data calls are configured with incoming called-number matching the DNIS received.

If data dial-peer or “incoming called-number “ command is not configured, you will see ISR rejecting the call with following debugs

           

*Sep 10 21:02:54.389: ISDN Se0/0/1:23 Q931: RX <- SETUP pd = 8  callref = 0x14C9

            Bearer Capability i = 0x8890

                        Standard = CCITT

                        Transfer Capability = Unrestricted Digital

                        Transfer Mode = Circuit

                        Transfer Rate = 64 kbit/s

            Channel ID i = 0xA98381

                        Exclusive, Channel 1

            Calling Party Number i = 0x2180, '4087775100'

                        Plan:ISDN, Type:National

            Called Party Number i = 0x80, '83115'

                        Plan:Unknown, Type:Unknown

*Sep 10 21:02:54.393: ISDN Se0/0/1:23 Q931: Received SETUP  callref = 0x94C9 callID = 0x0008 switch = primary-5ess interface = User

*Sep 10 21:02:54.393: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

   Calling Number=4087775100, Called Number=83115, Voice-Interface=0x6A0DB574,

   Timeout=TRUE, Peer Encap Type=ENCAP_VOICE, Peer Search Type=PEER_TYPE_DATA,

   Peer Info Type=DIALPEER_INFO_SPEECH

*Sep 10 21:02:54.393: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

   Result=NO_MATCH(-1) after DP_MATCH_INCOMING_DNIS

*Sep 10 21:02:54.393: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

   Calling Number=4087775100, Called Number=83115, Voice-Interface=0x0,

   Timeout=TRUE, Peer Encap Type=ENCAP_VOICE, Peer Search Type=PEER_TYPE_DATA,

   Peer Info Type=DIALPEER_INFO_SPEECH

*Sep 10 21:02:54.393: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

  

Result=NO_MATCH(-1) after DP_MATCH_INCOMING_DNIS

*Sep 10 21:02:54.393: ISDN Se0/0/1:23 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x94C9

            Cause i = 0x809C - Invalid number format (incomplete number)

Cisco 3845 router :

3845-1#sh run

Building configuration...

Current configuration : 3877 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

service internal

!

hostname 3845-1

!

boot-start-marker

boot-end-marker

!

card type t1 0 0

!---Need to define a card type about the use of VWIC2-2MFT-T1/E1 card to be a

!--- T1 card or a E1 card. Here we are using it as a T1 card.

logging message-counter syslog

logging buffered 65535

enable secret 5 $1$clc3$GfelyWY1QQs6bCR4lxwl..

!

no aaa new-model

network-clock-participate wic 0

!--- Allow other WICs modules to drive the clock from the selected T1 line

network-clock-select 1 T1 0/0/1

!---Need to select proper T1 line to source the clock from.

!

dot11 syslog

ip source-route

ip cef

!

no ip domain lookup

no ipv6 cef

!

multilink bundle-name authenticated

!---Configure multilink bundle name based on the authenticated username

isdn switch-type primary-5ess

!--- Switch-type for the PRI circuit. Obtain this information from Telco.

!

voice-card 0

!

username 1811-1 password 0 cisco

username 1800-1 password 0 cisco

username 2811-1 password 0 cisco

username preet password 0 cisco

username Param password 0 cisco

!--- Usernames for local authentication of the call.  
!--- The client presents the username/password and the ISR
!--- authenticates the peer.

archive

log config

  hidekeys

!

controller T1 0/0/0

cablelength long 0db

pri-group timeslots 1-24

!

controller T1 0/0/1

cablelength long 0db

pri-group timeslots 1-24

!--- For T1 PRI scenarios, all 24 T1 timeslots are assigned as   
!--- ISDN PRI channels. The router now automatically creates the   
!--- corresponding D-channel: interface Serial 0/0/1:23.  
!--- Framing for this T1 is Extended Super Frame (ESF) and linecode is !--- B8ZS is default. Obtain these information from the Telco.  

interface Loopback0

ip address 1.1.1.1 255.255.255.0

!

interface Loopback1

ip address 100.1.1.1 255.255.255.0

!

interface GigabitEthernet0/0

ip address 200.1.1.1 255.255.255.0

duplex auto

speed auto

media-type rj45

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

media-type rj45

!

!

interface Serial0/0/0:23

ip unnumbered Loopback1

encapsulation ppp

dialer idle-timeout 600 either

dialer-group 1

isdn switch-type primary-5ess

isdn integrate calltype all

peer default ip address pool My-IP

ppp authentication chap callin

ppp chap hostname 3845-1

ppp chap password 0 cisco

ppp multilink

!

interface Serial0/0/1:23

!--- D-channel configuration for T1 0/2/0.

ip unnumbered Loopback1           

!--- A Loopback interface is always up/up. So, unnumber the Loopback 
!--- interface for stability.  

encapsulation ppp

dialer idle-timeout 600 either

!--- Idle Timeout is defined as 600 secs which is 10 mins.  

dialer-group 1

!--- Interesting traffic is defined in dialer-list 1.  
!--- Note: The specified dialer-group number must be the same as the   !--- dialer-list number. In this example, the number is defined as "1".  

isdn switch-type primary-5ess

isdn integrate calltype all

!--- Enables the serial interface for integrated mode, which allows

!--- data and voice call traffic to occur simultaneously.

peer default ip address pool My-IP

!--- Clients are assigned addresses from the IP address pool named My-IP which needs to be configured later in the config.

ppp authentication chap callin

!--- Use CHAP authentication.

ppp multilink

!--- Configure the interface to use multilink.
!--- Without this command multilink is NOT negotiated.
!--- This command is needed to bind more than one calls from the same
!--- user together.
 

ppp chap hostname 3845-1

ppp chap password 0 cisco

 

!

!

ip local pool My-IP 100.1.1.2 100.1.1.100

!--- IP address pools for dialin clients.

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 200.1.1.2

ip http server

no ip http secure-server

!

dialer-list 1 protocol ip permit

!

control-plane

!

voice-port 0/0/1:23

!

mgcp fax t38 ecm

mgcp behavior g729-variants static-pt

!

dial-peer data 1 pots

incoming called-number 83115

!--- For data dial-peer matching, only the called number of an incoming call is

!--- used to match the incoming called number of POTS dial peers. Wild cards

!--- are accepted. The string must match the number received in ISDN SETUP

!--- message for data call.

dial-peer search type data voice

!--- Configures the preference of voice or data dial-peer lookup during the

!--- calltype checking for incoming ISDN calls.

line con 0

exec-timeout 0 0

privilege level 15

logging synchronous

line aux 0

privilege level 15

password cisco

login

!

line vty 0 4

exec-timeout 60 0

privilege level 15

password cisco

logging synchronous

login

line vty 5 10

exec-timeout 60 0

privilege level 15

password cisco

logging synchronous

login

!

scheduler allocate 20000 1000

end

3845-1#show diag

Slot 0:

            C3845 Mother board 1GE(TX,SFP),1GE(TX), integrated VPN and 4W Port adapter, 13 ports

            <snip>

            PVDM Slot 0:

            64-channel (G.711) Voice/Fax PVDMII DSP SIMM PVDM daughter card

            Hardware Revision        : 4.0

            Part Number              : 73-8541-05

            Board Revision           : A0

            Deviation Number         : 0

            Fab Version              : 04

            PCB Serial Number        : FOC10202UFD

            RMA Test History         : 00

            RMA Number               : 0-0-0-0

            RMA History              : 00

            Processor type           : 00

            Product (FRU) Number     : PVDM2-64

            Version Identifier       : V01

            <snip>

            WIC Slot 0:

            VWIC2-2MFT-T1/E1 - 2-Port RJ-48 Multiflex Trunk - T1/E1

            Hardware Revision        : 0.0

            Top Assy. Part Number    : 800-22629-05

            Board Revision           : B0

            Deviation Number         : 0

            Fab Version              : 04

            PCB Serial Number        : FOC11240T31

            RMA Test History         : 00

            RMA Number               : 0-0-0-0

            RMA History              : 00

            Product (FRU) Number     : VWIC2-2MFT-T1/E1

           

3845-1#sh network-clocks

  Network Clock Configuration

  ---------------------------

  Priority      Clock Source    Clock State     Clock Type

     1          T1 0/0/1        GOOD            T1         

    11          Backplane       GOOD            PLL        

  Current Primary Clock Source

  ---------------------------

  Priority      Clock Source    Clock State     Clock Type

     1          T1 0/0/1        GOOD            T1         

Use the following commands to troubleshoot integrated data for ISDN interfaces:

debug dialer events—Used to display debugging information about the packets received on a dialer interface.

debug isdn q931—Used to check outgoing dial-peer matching for an ISDN incoming call. Enable this command on both sides of the call. The output indicates whether the messages are generated by the calling party router (indicated by TX ->) or by the called party router (indicated by RX <-).

debug voip ccapi inout—Used to show how a call flows through the system. From the output, you can see the call setup and teardown operations performed on both the telephony and network call legs.

show isdn active and show isdn status—Used to show the active data and voice calls.

debug ppp negotiation—displays information on the PPP traffic and exchanges, and negotiates Link Control Protocol (LCP), Authentication, and Network Control Protocol (NCP). A successful PPP negotiation first opens the LCP state, then authenticates, and finally negotiates NCP. Multilink Parameters such as Maximum Receive Reconstructed Unit (MRRU) are established during LCP negotiation.

debug ppp error—displays protocol errors and error statistics associated with PPP connection negotiation and operation.

debug ppp authentication—displays PPP authentication protocol messages, including CHAP packet exchanges and Password Authentication Protocol (PAP) exchanges.

debug voip dialpeer all—displays dialpeer selection based on the incoming digits

3845-1#debug isdn q931

debug isdn q931 is                        ON.

3845-1#debug ppp negotiation

PPP protocol negotiation debugging is on

3845-1#debug ppp authentication

PPP authentication debugging is on

3845-1#debug dialer

Dial on demand events debugging is on

3845-1#debug voip dialpeer

voip dialpeer default debugging is on

3845-1#debug voip ccapi inout

voip ccapi inout debugging is on

3845-1#sh debug

PPP:

  PPP authentication debugging is on

  PPP protocol errors debugging is on

PPP protocol negotiation debugging is on

The following ISDN debugs are enabled on all DSLs:

debug isdn error is                        ON.

debug isdn q931 is                        ON.   (filter is OFF)

DIALPEER:

  debug voip dialpeer error call is ON (filter is OFF)

  debug voip dialpeer error call informational is ON (filter is OFF)

  debug voip dialpeer error software is ON

  debug voip dialpeer error software informational is ON

  debug voip dialpeer function is ON (filter is OFF)

  debug voip dialpeer inout is ON (filter is OFF)

  debug voip dialpeer detail is ON (filter is OFF)

CCAPI:

  debug voip ccapi inout is ON (filter is OFF)

3845-1#

3845-1#

*Sep  9 17:14:40.368: ISDN Se0/0/1:23 Q931: RX <- SETUP pd = 8  callref = 0x1479

            Bearer Capability i = 0x8890

                        Standard = CCITT

                        Transfer Capability = Unrestricted Digital

                        Transfer Mode = Circuit

                        Transfer Rate = 64 kbit/s

            Channel ID i = 0xA98381

                        Exclusive, Channel 1

            Calling Party Number i = 0x2180, '4087775100'

                        Plan:ISDN, Type:National

            Called Party Number i = 0x80, '83115'

                        Plan:Unknown, Type:Unknown

*Sep  9 17:14:40.368: ISDN Se0/0/1:23 Q931: Received SETUP  callref = 0x9479 callID = 0x0016 switch = primary-5ess interface = User

*Sep  9 17:14:40.368: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

   Calling Number=4087775100, Called Number=83115, Voice-Interface=0x6A16A13C,

   Timeout=TRUE, Peer Encap Type=ENCAP_VOICE, Peer Search Type=PEER_TYPE_DATA,

   Peer Info Type=DIALPEER_INFO_SPEECH

*Sep  9 17:14:40.368: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

   Match Rule=DP_MATCH_INCOMING_DNIS; Called Number=83115

*Sep  9 17:14:40.368: //-1/xxxxxxxxxxxx/DPM/dpMatchPeertype:

   Is Incoming=TRUE, Number Expansion=FALSE

*Sep  9 17:14:40.372: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:

   Dial String=83115, Expanded String=83115, Calling Number=

   Timeout=TRUE, Is Incoming=TRUE, Peer Info Type=DIALPEER_INFO_SPEECH

*Sep  9 17:14:40.372: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:

   Result=Success(0); Incoming Dial-peer=1 Is Matched

*Sep  9 17:14:40.372: //-1/xxxxxxxxxxxx/DPM/dpMatchPeertype:exit@5615

*Sep  9 17:14:40.372: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

   Result=Success(0) after DP_MATCH_INCOMING_DNIS; Incoming Dial-peer=1

*Sep  9 17:14:40.372: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerSPI:exit@6169

*Sep  9 17:14:40.372: %LINK-3-UPDOWN: Interface Serial0/0/1:0, changed state to up

*Sep  9 17:14:40.372: %ISDN-6-CONNECT: Interface Serial0/0/1:0 is now connected to 4087775100 N/A

*Sep  9 17:14:40.372: ISDN Se0/0/1:23 Q931: TX -> CALL_PROC pd = 8  callref = 0x9479

            Channel ID i = 0xA98381

                        Exclusive, Channel 1

*Sep  9 17:14:40.372: ISDN Se0/0/1:23 Q931: TX -> CONNECT pd = 8  callref = 0x9479

            Channel ID i = 0xA98381

                        Exclusive, Channel 1

*Sep  9 17:14:40.372: Se0/0/1:0 PPP: Using dialer call direction

*Sep  9 17:14:40.372: Se0/0/1:0 PPP: Treating connection as a callin

*Sep  9 17:14:40.372: Se0/0/1:0 PPP: Session handle[1200007E] Session id[29]

*Sep  9 17:14:40.372: Se0/0/1:0 PPP: Phase is ESTABLISHING, Passive Open

*Sep  9 17:14:40.372: Se0/0/1:0 LCP: State is Listen

*Sep  9 17:14:40.384: ISDN Se0/0/1:23 Q931: RX <- CONNECT_ACK pd = 8  callref = 0x1479

*Sep  9 17:14:40.616: Se0/0/1:0 LCP: I CONFREQ [Listen] id 10 len 22

*Sep  9 17:14:40.616: Se0/0/1:0 LCP:    MagicNumber 0x36F9583B (0x050636F9583B)

*Sep  9 17:14:40.616: Se0/0/1:0 LCP:    MRRU 1524 (0x110405F4)

*Sep  9 17:14:40.616: Se0/0/1:0 LCP:    EndpointDisc 1 Param (0x130801506172616D)

*Sep  9 17:14:40.616: Se0/0/1:0 PPP: Authorization required

*Sep  9 17:14:40.616: Se0/0/1:0 LCP: O CONFREQ [Listen] id 3 len 28

*Sep  9 17:14:40.616: Se0/0/1:0 LCP:    AuthProto CHAP (0x0305C22305)

*Sep  9 17:14:40.616: Se0/0/1:0 LCP:    MagicNumber 0x4817A467 (0x05064817A467)

*Sep  9 17:14:40.616: Se0/0/1:0 LCP:    MRRU 1524 (0x110405F4)

*Sep  9 17:14:40.616: Se0/0/1:0 LCP:    EndpointDisc 1 3845-1 (0x130901333834352D31)

*Sep  9 17:14:40.616: Se0/0/1:0 LCP: O CONFACK [Listen] id 10 len 22

*Sep  9 17:14:40.616: Se0/0/1:0 LCP:    MagicNumber 0x36F9583B (0x050636F9583B)

*Sep  9 17:14:40.616: Se0/0/1:0 LCP:    MRRU 1524 (0x110405F4)

*Sep  9 17:14:40.616: Se0/0/1:0 LCP:    EndpointDisc 1 Param (0x130801506172616D)

*Sep  9 17:14:40.632: Se0/0/1:0 LCP: I CONFACK [ACKsent] id 3 len 28

*Sep  9 17:14:40.632: Se0/0/1:0 LCP:    AuthProto CHAP (0x0305C22305)

*Sep  9 17:14:40.632: Se0/0/1:0 LCP:    MagicNumber 0x4817A467 (0x05064817A467)

*Sep  9 17:14:40.632: Se0/0/1:0 LCP:    MRRU 1524 (0x110405F4)

*Sep  9 17:14:40.632: Se0/0/1:0 LCP:    EndpointDisc 1 3845-1 (0x130901333834352D31)

*Sep  9 17:14:40.632: Se0/0/1:0 LCP: State is Open

*Sep  9 17:14:40.632: Se0/0/1:0 PPP: Phase is AUTHENTICATING, by this end

*Sep  9 17:14:40.632: Se0/0/1:0 CHAP: O CHALLENGE id 3 len 27 from "3845-1"

*Sep  9 17:14:40.648: Se0/0/1:0 CHAP: I RESPONSE id 3 len 26 from "Param"

*Sep  9 17:14:40.648: Se0/0/1:0 PPP: Phase is FORWARDING, Attempting Forward

*Sep  9 17:14:40.652: Se0/0/1:0 PPP: Phase is AUTHENTICATING, Unauthenticated User

*Sep  9 17:14:40.652: Se0/0/1:0 PPP: Sent CHAP LOGIN Request

*Sep  9 17:14:40.652: Se0/0/1:0 PPP: Received LOGIN Response PASS

*Sep  9 17:14:40.652: Se0/0/1:0 PPP: Phase is FORWARDING, Attempting Forward

*Sep  9 17:14:40.652: Se0/0/1:0 PPP: Phase is AUTHENTICATING, Authenticated User

*Sep  9 17:14:40.652: Se0/0/1:0 PPP: Sent LCP AUTHOR Request

*Sep  9 17:14:40.652: Se0/0/1:0 PPP: Sent MLP AUTHOR Request

*Sep  9 17:14:40.652: Se0/0/1:0 PPP: Sent IPCP AUTHOR Request

*Sep  9 17:14:40.652: Se0/0/1:0 LCP: Received AAA AUTHOR Response PASS

*Sep  9 17:14:40.652: Se0/0/1:0 MLP: Received AAA AUTHOR Response PASS

*Sep  9 17:14:40.652: Se0/0/1:0 IPCP: Received AAA AUTHOR Response PASS

*Sep  9 17:14:40.652: Se0/0/1:0 CHAP: O SUCCESS id 3 len 4

*Sep  9 17:14:40.652: Se0/0/1:0 PPP: Phase is VIRTUALIZED

*Sep  9 17:14:40.656: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up

*Sep  9 17:14:40.656: Vi1 MLP: Added first link Se0/0/1:0 to bundle Param

*Sep  9 17:14:40.656: Vi1 PPP: Phase is DOWN, Setup

*Sep  9 17:14:40.656: Vi1 PPP: Phase is UP

*Sep  9 17:14:40.656: Vi1 IPCP: O CONFREQ [Closed] id 1 len 10

*Sep  9 17:14:40.656: Vi1 IPCP:    Address 100.1.1.1 (0x030664010101)

*Sep  9 17:14:40.656: Vi1 PPP: Sent CDPCP AUTHOR Request

*Sep  9 17:14:40.656: Vi1 PPP: Process pending ncp packets

*Sep  9 17:14:40.656: Se0/0/1:0 PPP: Process pending ncp packets

*Sep  9 17:14:40.656: Se0/0/1:0 PPP: Process pending ncp packets

*Sep  9 17:14:40.656: Vi1 CDPCP: Received AAA AUTHOR Response PASS

*Sep  9 17:14:40.656: Vi1 CDPCP: O CONFREQ [Closed] id 1 len 4

*Sep  9 17:14:40.672: Vi1 IPCP: I CONFREQ [REQsent] id 1 len 10

*Sep  9 17:14:40.672: Vi1 IPCP:    Address 0.0.0.0 (0x030600000000)

*Sep  9 17:14:40.672: Vi1 AAA/AUTHOR/IPCP: Start.  Her address 0.0.0.0, we want 0.0.0.0

*Sep  9 17:14:40.672: Vi1 AAA/AUTHOR/IPCP: Done.  Her address 0.0.0.0, we want 0.0.0.0

*Sep  9 17:14:40.672: Vi1 IPCP: Pool returned 100.1.1.7

*Sep  9 17:14:40.672: Vi1 IPCP: O CONFNAK [REQsent] id 1 len 10

*Sep  9 17:14:40.672: Vi1 IPCP:    Address 100.1.1.7 (0x030664010107)

*Sep  9 17:14:40.672: Vi1 CDPCP: I CONFREQ [REQsent] id 1 len 4

*Sep  9 17:14:40.672: Vi1 CDPCP: O CONFACK [REQsent] id 1 len 4

3845-1#

*Sep  9 17:14:40.672: Vi1 IPCP: I CONFACK [REQsent] id 1 len 10

*Sep  9 17:14:40.672: Vi1 IPCP:    Address 100.1.1.1 (0x030664010101)

*Sep  9 17:14:40.684: Vi1 IPCP: I CONFREQ [ACKrcvd] id 2 len 10

*Sep  9 17:14:40.684: Vi1 IPCP:    Address 100.1.1.7 (0x030664010107)

*Sep  9 17:14:40.684: Vi1 IPCP: O CONFACK [ACKrcvd] id 2 len 10

*Sep  9 17:14:40.684: Vi1 IPCP:    Address 100.1.1.7 (0x030664010107)

*Sep  9 17:14:40.684: Vi1 IPCP: State is Open

*Sep  9 17:14:40.684: Se0/0/1:23 IPCP: Install route to 100.1.1.7

*Sep  9 17:14:40.684: Vi1 IPCP: Add link info for cef entry 100.1.1.7

3845-1#

*Sep  9 17:14:41.652: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1:0, changed state to up

*Sep  9 17:14:41.656: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up

3845-1#sh users

    Line       User       Host(s)              Idle       Location

   0 con 0                1.1.1.1                  1w1d

  tty 0/514               idle                     1w1d 1.1.1.1

*706 vty 0                idle                 00:00:00 171.69.89.61

  Interface    User               Mode         Idle     Peer Address

  Vi1          Param              MLP Bundle   00:00:20 100.1.1.7

  Se0/0/1:0    Param              Sync PPP     -        Bundle: Vi1

3845-1#sh caller timeouts

  Line           User               Limit     Remaining Timer Type

  con 0          -                  -         -         -        

  tty 0/514      -                  -         -         -        

  vty 706        -                  01:00:00  00:59:59  Idle Exec

  Se0/0/1:0      Param              -         -         -        

  Vi1            Param              00:10:00  00:09:34  Dialer idle

3845-1#

3845-1#sh dialer map

Dynamic dialer map ip 100.1.1.7   name Param     () on Se0/0/1:23

3845-1#sh ppp multilink

Virtual-Access1

  Bundle name: Param

  Remote Username: Param

  Remote Endpoint Discriminator: [1] Param

  Local Username: 3845-1

  Local Endpoint Discriminator: [1] 3845-1

  Bundle up for 00:00:55, total bandwidth 64, load 1/255

  Receive buffer limit 12192 bytes, frag timeout 1524 ms

  Dialer interface is Serial0/0/1:23

    0/0 fragments/bytes in reassembly list

    0 lost fragments, 0 reordered

    0/0 discarded fragments/bytes, 0 lost received

    0x0 received sequence, 0x0 sent sequence

  Member links: 1 (max not set, min not set)

    Se0/0/1:0, since 00:00:55

No inactive multilink interfaces

3845-1#

2nd call from the branch router come in

*Sep  9 17:15:47.128: ISDN Se0/0/1:23 Q931: RX <- SETUP pd = 8  callref = 0x147A

            Bearer Capability i = 0x8890

                        Standard = CCITT

                        Transfer Capability = Unrestricted Digital

                        Transfer Mode = Circuit

                        Transfer Rate = 64 kbit/s

            Channel ID i = 0xA98382

                        Exclusive, Channel 2

            Calling Party Number i = 0x2180, '4087775100'

                        Plan:ISDN, Type:National

            Called Party Number i = 0x80, '83115'

                        Plan:Unknown, Type:Unknown

*Sep  9 17:15:47.132: ISDN Se0/0/1:23 Q931: Received SETUP  callref = 0x947A callID = 0x0017 switch = primary-5ess interface = User

*Sep  9 17:15:47.132: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

   Calling Number=4087775100, Called Number=83115, Voice-Interface=0x6A16A13C,

   Timeout=TRUE, Peer Encap Type=ENCAP_VOICE, Peer Search Type=PEER_TYPE_DATA,

   Peer Info Type=DIALPEER_INFO_SPEECH

*Sep  9 17:15:47.132: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

   Match Rule=DP_MATCH_INCOMING_DNIS; Called Number=83115

*Sep  9 17:15:47.132: //-1/xxxxxxxxxxxx/DPM/dpMatchPeertype:

   Is Incoming=TRUE, Number Expansion=FALSE

*Sep  9 17:15:47.132: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:

   Dial String=83115, Expanded String=83115, Calling Number=

   Timeout=TRUE, Is Incoming=TRUE, Peer Info Type=DIALPEER_INFO_SPEECH

*Sep  9 17:15:47.132: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:

   Result=Success(0); Incoming Dial-peer=1 Is Matched

*Sep  9 17:15:47.132: //-1/xxxxxxxxxxxx/DPM/dpMatchPeertype:exit@5615

*Sep  9 17:15:47.132: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

   Result=Success(0) after DP_MATCH_INCOMING_DNIS; Incoming Dial-peer=1

*Sep  9 17:15:47.132: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerSPI:exit@6169

*Sep  9 17:15:47.132: %LINK-3-UPDOWN: Interface Serial0/0/1:1, changed state to up

*Sep  9 17:15:47.132: %ISDN-6-CONNECT: Interface Serial0/0/1:1 is now connected to 4087775100 N/A

*Sep  9 17:15:47.136: ISDN Se0/0/1:23 Q931: TX -> CALL_PROC pd = 8  callref = 0x947A

            Channel ID i = 0xA98382

                        Exclusive, Channel 2

*Sep  9 17:15:47.136: ISDN Se0/0/1:23 Q931: TX -> CONNECT pd = 8  callref = 0x947A

            Channel ID i = 0xA98382

                        Exclusive, Channel 2

*Sep  9 17:15:47.136: Se0/0/1:1 PPP: Using dialer call direction

*Sep  9 17:15:47.136: Se0/0/1:1 PPP: Treating connection as a callin

*Sep  9 17:15:47.136: Se0/0/1:1 PPP: Session handle[4B00007D] Session id[31]

*Sep  9 17:15:47.136: Se0/0/1:1 PPP: Phase is ESTABLISHING, Passive Open

*Sep  9 17:15:47.136: Se0/0/1:1 LCP: State is Listen

3845-1#

*Sep  9 17:15:47.144: ISDN Se0/0/1:23 Q931: RX <- CONNECT_ACK pd = 8  callref = 0x147A

*Sep  9 17:15:47.320: Se0/0/1:1 LCP: I CONFREQ [Listen] id 8 len 22

*Sep  9 17:15:47.320: Se0/0/1:1 LCP:    MagicNumber 0x36FA5CCC (0x050636FA5CCC)

*Sep  9 17:15:47.320: Se0/0/1:1 LCP:    MRRU 1524 (0x110405F4)

*Sep  9 17:15:47.320: Se0/0/1:1 LCP:    EndpointDisc 1 Param (0x130801506172616D)

*Sep  9 17:15:47.320: Se0/0/1:1 PPP: Authorization required

*Sep  9 17:15:47.320: Se0/0/1:1 LCP: O CONFREQ [Listen] id 2 len 28

*Sep  9 17:15:47.320: Se0/0/1:1 LCP:    AuthProto CHAP (0x0305C22305)

*Sep  9 17:15:47.320: Se0/0/1:1 LCP:    MagicNumber 0x4818A8F9 (0x05064818A8F9)

*Sep  9 17:15:47.320: Se0/0/1:1 LCP:    MRRU 1524 (0x110405F4)

*Sep  9 17:15:47.320: Se0/0/1:1 LCP:    EndpointDisc 1 3845-1 (0x130901333834352D31)

*Sep  9 17:15:47.320: Se0/0/1:1 LCP: O CONFACK [Listen] id 8 len 22

*Sep  9 17:15:47.320: Se0/0/1:1 LCP:    MagicNumber 0x36FA5CCC (0x050636FA5CCC)

*Sep  9 17:15:47.320: Se0/0/1:1 LCP:    MRRU 1524 (0x110405F4)

*Sep  9 17:15:47.320: Se0/0/1:1 LCP:    EndpointDisc 1 Param (0x130801506172616D)

*Sep  9 17:15:47.336: Se0/0/1:1 LCP: I CONFACK [ACKsent] id 2 len 28

*Sep  9 17:15:47.336: Se0/0/1:1 LCP:    AuthProto CHAP (0x0305C22305)

*Sep  9 17:15:47.336: Se0/0/1:1 LCP:    MagicNumber 0x4818A8F9 (0x05064818A8F9)

*Sep  9 17:15:47.336: Se0/0/1:1 LCP:    MRRU 1524 (0x110405F4)

*Sep  9 17:15:47.336: Se0/0/1:1 LCP:    EndpointDisc 1 3845-1 (0x130901333834352D31)

*Sep  9 17:15:47.336: Se0/0/1:1 LCP: State is Open

*Sep  9 17:15:47.336: Se0/0/1:1 PPP: Phase is AUTHENTICATING, by this end

*Sep  9 17:15:47.336: Se0/0/1:1 CHAP: O CHALLENGE id 2 len 27 from "3845-1"

*Sep  9 17:15:47.356: Se0/0/1:1 CHAP: I RESPONSE id 2 len 26 from "Param"

*Sep  9 17:15:47.356: Se0/0/1:1 PPP: Phase is FORWARDING, Attempting Forward

*Sep  9 17:15:47.356: Se0/0/1:1 PPP: Phase is AUTHENTICATING, Unauthenticated User

*Sep  9 17:15:47.356: Se0/0/1:1 PPP: Sent CHAP LOGIN Request

3845-1#

*Sep  9 17:15:47.356: Se0/0/1:1 PPP: Received LOGIN Response PASS

*Sep  9 17:15:47.356: Se0/0/1:1 PPP: Phase is FORWARDING, Attempting Forward

*Sep  9 17:15:47.356: Se0/0/1:1 PPP: Phase is AUTHENTICATING, Authenticated User

*Sep  9 17:15:47.356: Se0/0/1:1 PPP: Sent LCP AUTHOR Request

*Sep  9 17:15:47.356: Se0/0/1:1 LCP: Received AAA AUTHOR Response PASS

*Sep  9 17:15:47.356: Se0/0/1:1 CHAP: O SUCCESS id 2 len 4

*Sep  9 17:15:47.356: Se0/0/1:1 PPP: Phase is VIRTUALIZED

*Sep  9 17:15:47.356: Vi1 MLP: Added link Se0/0/1:1 to bundle Param

*Sep  9 17:15:47.356: Se0/0/1:1 PPP: Process pending ncp packets

*Sep  9 17:15:48.356: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1:1, changed state to up

3845-1#

3845-1#sh users

    Line       User       Host(s)              Idle       Location

   0 con 0                1.1.1.1                  1w1d

  tty 0/514               idle                     1w1d 1.1.1.1

*706 vty 0                idle                 00:00:00 171.69.89.61

  Interface    User               Mode         Idle     Peer Address

  Vi1          Param              MLP Bundle   00:00:16 100.1.1.7

  Se0/0/1:0    Param              Sync PPP     -        Bundle: Vi1

  Se0/0/1:1    Param              Sync PPP     -        Bundle: Vi1

3845-1#sh caller timeout

  Line           User               Limit     Remaining Timer Type

  con 0          -                  -         -         -        

  tty 0/514      -                  -         -         -        

  vty 706        -                  01:00:00  00:59:59  Idle Exec

  Se0/0/1:0      Param              -         -         -        

  Se0/0/1:1      Param              -         -         -        

  Vi1            Param              00:10:00  00:09:40  Dialer idle

3845-1#sh ppp multilink

Virtual-Access1

  Bundle name: Param

  Remote Username: Param

  Remote Endpoint Discriminator: [1] Param

  Local Username: 3845-1

  Local Endpoint Discriminator: [1] 3845-1

  Bundle up for 00:01:32, total bandwidth 128, load 1/255

  Receive buffer limit 24384 bytes, frag timeout 1524 ms

  Dialer interface is Serial0/0/1:23

    0/0 fragments/bytes in reassembly list

    0 lost fragments, 1 reordered

    0/0 discarded fragments/bytes, 0 lost received

    0x2 received sequence, 0x0 sent sequence

  Member links: 2 (max not set, min not set)

    Se0/0/1:0, since 00:01:32

    Se0/0/1:1, since 00:00:26

No inactive multilink interfaces

3845-1#sh int virtual-access 1

Virtual-Access1 is up, line protocol is up

  Hardware is Virtual Access interface

  MTU 1500 bytes, BW 128 Kbit/sec, DLY 20000 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation PPP, LCP Open, multilink Open

  Open: IPCP, CDPCP

  MLP Bundle vaccess, cloned from Serial0/0/1:23

  Vaccess status 0x40, loopback not set

  Keepalive set (10 sec)

  DTR is pulsed for 5 seconds on reset

  Time to interface disconnect: idle 00:09:26

  Last input 00:00:31, output never, output hang never

  Last clearing of "show interface" counters 5d18h

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: weighted fair

  Output queue: 0/1000/64/0 (size/max total/threshold/drops)

     Conversations  0/1/256 (active/max active/max total)

     Reserved Conversations 0/0 (allocated/max allocated)

     Available Bandwidth 96 kilobits/sec

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     117 packets input, 12384 bytes, 0 no buffer

     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

     116 packets output, 11752 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 unknown protocol drops

     0 output buffer failures, 0 output buffers swapped out

     0 carrier transitions

3845-1#sh dialer map

Dynamic dialer map ip 100.1.1.7   name Param     () on Se0/0/1:23

3845-1#sh caller user Param detail

  User: Param, line Se0/0/1:0, service PPP

        Connected for 00:02:06, Idle for 00:00:58

  Timeouts:    Limit     Remaining Timer Type

               -         -         -        

  PPP: LCP Open, multilink Open, CHAP (<-)

  LCP: -> peer, AuthProto, MagicNumber, MRRU, EndpointDisc

       <- peer, MagicNumber, MRRU, EndpointDisc

  NCP: Closed IPCP, CDPCP

  Dialer: Connected to 4087775100, inbound

          Type is ISDN, group Se0/0/1:23

  IP: Local 100.1.1.1

  Bundle: Member of Param

  Counts: 209 packets input, 18576 bytes, 0 no buffer

          1 input errors, 1 CRC, 0 frame, 0 overrun

          210 packets output, 17789 bytes, 0 underruns

          0 output errors, 0 collisions, 0 interface resets

  User: Param, line Se0/0/1:1, service PPP

        Connected for 00:00:59, Idle for 00:00:58

  Timeouts:    Limit     Remaining Timer Type

               -         -         -        

  PPP: LCP Open, multilink Open, CHAP (<-)

  LCP: -> peer, AuthProto, MagicNumber, MRRU, EndpointDisc

       <- peer, MagicNumber, MRRU, EndpointDisc

  Dialer: Connected to 4087775100, inbound

          Type is ISDN, group Se0/0/1:23

  IP: Local 100.1.1.1

  Bundle: Member of Param

  Counts: 28 packets input, 1932 bytes, 0 no buffer

          0 input errors, 0 CRC, 0 frame, 0 overrun

          30 packets output, 1687 bytes, 0 underruns

          0 output errors, 0 collisions, 0 interface resets

  User: Param, line Vi1, service MLP Bundle

        Connected for 00:02:06, Idle for 00:01:00

  Timeouts:    Limit     Remaining Timer Type

               00:10:00  00:08:59  Dialer idle

  PPP: LCP Open, multilink Open, IPCP, CDPCP

  LCP: -> peer

       <- peer

  NCP: Open IPCP, CDPCP

  IPCP: <- peer, Address

        -> peer, Address

  Dialer: Connected to 4087775100, inbound

          Type is IN-BAND SYNC, group Se0/0/1:23

  IP: Local 100.1.1.1, remote 100.1.1.7

  Bundle: Bundle Param, 2 links

  Counts: 117 packets input, 12384 bytes, 0 no buffer

          0 input errors, 0 CRC, 0 frame, 0 overrun

          117 packets output, 12116 bytes, 0 underruns

          0 output errors, 0 collisions, 0 interface resets

3845-1#show isdn status

<snip>

ISDN Serial0/1/0:23 interface

        dsl 1, interface ISDN Switchtype = primary-5ess

    Layer 1 Status:

        DEACTIVATED

    Layer 2 Status:

        TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED

    Layer 3 Status:

        0 Active Layer 3 Call(s)

    Active dsl 1 CCBs = 0

    The Free Channel Mask:  0x00000000

    Number of L2 Discards = 0, L2 Session ID = 0

ISDN Serial0/0/1:23 interface

        dsl 2, interface ISDN Switchtype = primary-5ess

    Layer 1 Status:

        ACTIVE

    Layer 2 Status:

        TEI = 0, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED

    Layer 3 Status:

        2 Active Layer 3 Call(s)

        CCB:callid=16, sapi=0, ces=0, B-chan=1, calltype=DATA, hdlctype=HDLC-TRUNK

        CCB:callid=17, sapi=0, ces=0, B-chan=2, calltype=DATA, hdlctype=HDLC-TRUNK

    Active dsl 2 CCBs = 2

    The Free Channel Mask:  0x807FFFFC

    Number of L2 Discards = 0, L2 Session ID = 3

    Total Allocated ISDN CCBs = 2

Comments
New Member

This document is called:

Configuring and Troubleshooting VWIC2-xCTE1-PRI Modules for Inbound ISDN Multilink PPP Data Calls

Components Used

The information in this document is based on these software and hardware versions in the lab environment

·Cisco 3845 with VWIC2-2MFT-T1/E1 and PVDM2-64 running IOS® Software Release 12.4(24)T1

·Cisco 2811 with WIC-1B-U-V2 running IOS® Software Release 12.4(7h)

My question now is:  Is a PVDM2 module actually needed to support ISDN data-only calls???

10383
Views
0
Helpful
1
Comments