Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

DFM 3.1.0 on LMS 3.1

Hi clarke,

Unable to pull devices from DCR CS 3.2.0 to DFM 3.1.0,In process always DFMServer is down and it is showing me 2 instance of DFMServer process i.e example DFMServer & DFMServer1 though when i restart it still get shutdown automatically.attaching the pdshow

Reply waiting for the solution.

Hi clarke

Awaiting for ur reply.

This pdshow is truncated.  Post the complete pdshow output along with the NMSROOT/objects/smarts/local/logs/DFM.log and DFM1.log.

when i execute a pdshow all outputs goes up in a window.Attached is the file.

there are many files in NMSROOT/objects/smarts/local/logs/ folder for DFM attached many pls refer which u need.

How can i send the full output of pdshow,what adjustment i have to do in command prompt window

You should be redirecting the output of pdshow to a file.  For example:

pdshow > pdshow.txt

The problem here appears to be corrupt DFM.rps files.  Shutdown Daemon Manager, and remove the DFM.rps and DFM1.rps files under NMSROOT/objects/smarts/local/repos/icf.  then restart Daemon Manager.

Joe

After removing those files i stopped and restarted the daemon but still there r no devices in DFM,

Do i have to do some extra job to pull from DCR.

LMS all processes takes 7 to 8 min to come up.

Thanks,

DFM server is still down.  Post the new DFM logs.

from which locations clarke can u confirm

The same DFM logs as before.  The DFM.log and DFM1.log from NMSROOT/objects/smarts/local/logs.

Attached are the logs for DFM from the above mail location

This is fine.  You posted an old pdshow.  DFM doesn't automatically manage devices by default.  So, go to DFM > Device Management > Device Import, and make sure you have selected devices or groups to manage.

Clarke

Nil devices are present in DFM to import i have cheked by auto as well as manual it says me there no devices to import.

What do you see under DFM > Device Management > Discovery Status?

Please find the screen shots from the DFM

Do you have any devices in DCR?  Is this server integrated with ACS?

I have devices in DCR,RME pulled all the devices from the DCR but DFM is Not pulling  i dont know what is problem.

Is the server integrated with ACS?

Screen shots fo r DCR and RME

forgot to write it is not integrated with ACS

Shutdown Daemon Manager, then do the following:

NMSROOT/bin/perl NMSROOT/bin/dbRestoreOrig.pl dsn=dfmInv dmprefix=INV

NMSROOT/bin/perl NMSROOT/bin/dbRestoreOrig.pl dsn=dfmEpm dmprefix=EPM

NMSROOT/bin/perl NMSROOT/bin/dbRestoreOrig.pl dsn=dfmFh dmprefix=FH

Then delete the NMSROOT/objects/smarts/local/repos/icf/DFM.rps and DFM1.rps files again.  Restart Daemon Manager, and see if you can re-enable DCR auto-import by going to DFM > Device Management > Device Import > Auto Allocation, selecting "Enable AutoMode" and Manage All Devices, then click Apply.

It is gives me error it is not internal or external command.

LMS is in c:program files\cscopx

what i m doing is:

c:/program files/CSCOpx/bin/perl c:program files/CSCOpx/bin/dbRestoreOrig.pl dsn=dfmInv dmprefix=INV

c:/program files/CSCOpx/bin/perl c:/program files/CSCOpx/bin/dbRestoreOrig.pl dsn=dfmEpm dmprefix=EPM

c:/program files/CSCOpx/bin/perl c:/program files/CSCOpx/bin/dbRestoreOrig.pl dsn=dfmFh dmprefix=FH

Is it correct or any mistake.

You must use DOS 8.3 file names with LMS.  The commands will therefore be C:\\PROGRA~1\\CSCOpx\\bin\\perl C:\\PROGRA~1\\CSCOpx\\bin\\dbRestoreOrig.pl ...

C:\>cd program files/CSCOpx/bin/perl c:/program files/CSCOpx/bin/dbRestoreOrig.p

l dsn=dfmEpm dmprefix=EPM

The filename, directory name, or volume label syntax is incorrect.

AM getting this error can u guide me clarke where the mistake is

I already provided you the correct command, and you are still using the long name.  Again, the commands must start with:

C:\PROGRA~1\CSCOpx\bin\perl C:\PROGRA~1\CSCOpx\bin\dbRestoreOrig.pl

Clarke

The same error there no devices to import

Then I suggest you open a TAC service request at this point so live troubleshooting can be done.

Thanks clarke for back to back reply

appreciate ur immediate reply being cool and calm to explain,

But still i wanna ask when DCR discovers devices it should automatically discovered by DFM if auto allocation is enabled.And in manual allocation we have to import manually??? write

Then why it says no devices are selected to import.

1 question is when DFM is empty so we r importing it,,if devices are already present then what is the reason to import.

Still if u can find any solution it will good for me.

Once again thanks clarke.

Yes, if auto-allocation is enabled in DFM, then any new device added to DCR should be automatically managed by DFM.  Something is clearly broken on your server.  More troubleshooting will be required to figure out where the problem lies.  therefore, you should open a TAC service request so that debugging can be enabled, and log files can be analyzed.

Hey Clarke,

I wanna ask 1 question Which book i have to refer for deep troubleshooting LMS as such yesterday we perform

For example :delete DFM and DFM1 and reinitializing Database command,i was unaware of yesterday command where can i find deep troubleshooting documents for cisco LMS as am ahead of GMT +4,and you are located in US i have to wait for cisco experts response  to login in netpro community.

Alternatively Wanna be like u a deep expert.

Thanks,

There are no in depth troubleshooting documents for CiscoWorks which are externally available.  All documents on log file analysis, and detailed architecture are generally not needed for customer use.  The basic troubleshooting steps are posted in the various applications' user guides.  For example, http://www.cisco.com/en/US/docs/net_mgmt/ciscoworks_device_fault_manager/3.1/user/guide/dfmfaq.html for DFM.

This document was generated from the following thread: DFM 3.1.0 on LMS 3.1

Version history
Revision #:
1 of 1
Last update:
‎02-14-2010 02:06 AM
Updated by:
 
Labels (1)
Attachments