Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

How to deploy two ISP connections in a single Layer3 switch?

Dear All,

     We having two ISP connections in organisation. Now we want to deploy two ISP connections in a Layer3 switch. and have to create policies like that one ISP to certain VLAN in a L3 switch. Another one ISP to a other VLAN.

     Is it possible? How to deploy? Please help me to do? wat are all the procedures used to deploy?

     Please do the needs.

     Thanks in advance. Expecting a reply soon.

With Regards,

Chandhuru.M

Hi,

I think the feature that might be useful in this case is called Policy-based routing (PBR). Take a look here:

http://www.cisco.com/en/US/docs/switches/lan/catalyst3550/software/release/12.1_19_ea1/configuration/guide/swiprout.html#wp1260543

But be aware that PBR can lead to assymetric routing - a response to packet from, let's say, vlan 100 sent via ISP1 could come back via ISP2. This could cause problems so plase, bear it in mind when designing such network.

One more link, just an example of PBR dual ISP connection with NAT:

https://supportforums.cisco.com/docs/DOC-8313

Best regards,

Jan

Dear Jan Hrnko,

     Really thanks for your kind reply.

     Could you able to describe abt PBR in detail with some example networks which is related to my scenario.

     If u can explain through any small network using Packet Tracer.

     Advance in thanks. Hope will get reply soon.

With regards,

Chandhuru.M

Hi,

Picture1.jpg

an example configuration for this simple scenario:

interface Ethernet 0

ip address 192.168.1.1 255.255.255.0

ip policy route-map ISP1

interface Ethernet 1

ip address 172.16.1.1 255.255.255.0

ip policy route-map ISP2

route-map ISP1 permit 10

match ip address 1

set interface Serial0

route-map ISP2 permit 10

match ip address 2

set interface Serial1

access-list 1 permit 192.168.1.0 0.0.0.255

access-list 2 permit 172.16.1.0 0.0.0.255

Some additional notes regarding the configuration and PBR itself:

PBR is routing with additional criteria such as the sender address.

Match command defines which packets are selected and routed based on policy routing.

The non selected packets are routed based on routing table.

Set command specifies the way how the packet is forwarded, e.g. next-hop ip or interface.

Best regards,

Jan

Dear Jan Hrnko,

     Really it was very useful.

     Thanks a lot. Thanks.

     Hope will meet soon later on.

     Takecare.

With regards,

Chandhuru.M

This document was generated from the following discussion: How to deploy two ISP connections in a single Layer3 switch?

2981
Views
0
Helpful
0
Comments