Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

Inter-Domain Multicast with MSDP

Introduction:

In this document we will discuss how to send and receive multicast traffic between two different multicast domains reside in two different BGP ASs

using Multicast Source Discovery Protocol (MSDP) to achieve what is known as inter-domain multicasting.

Normally every RP aware about the multicast sources and receivers within the same domain where that RP configured with regard to the multicast groups that Router is RP for. MSDP Peers use TCP sessions and they send Source Active Messages (SA) to inform other peers about any active source within the local domain, Consequently all the MSDP Peers (RPs) will be aware about all sources within the local domain and other domains as well.

Configurations:

The bellow network diagram represents two differnt Multicast domains each domain utilize the multicast range 232.0.0.0/5 locally and they don't send it outside the local domain. each domain has its own RP R10 for AS 100 and R1 for AS 1 and the link between R 10 and R 1 configured as BSR boundary to avoid leaking any RP/BRP information between the two domains. Also MSDP filtering  has been applied to both MSDP peers to avoid leak these domain local groups in our example ( 232.0.0.0/5) between the two domains

for more information about the filtering between MSDP peers see the belllow link:

Multicast Source Discovery Protocol SA Filter Recommendations

http://www.cisco.com/en/US/tech/tk828/technologies_tech_note09186a0080093fda.shtml

MSDP.jpg

R3#show ip pim rp mapping
PIM Group-to-RP Mappings

Group(s) 224.0.0.0/7
  RP 1.1.1.1 (?), v2
    Info source: 1.1.1.1 (?), via bootstrap, priority 0, holdtime 150
         Uptime: 00:33:35, expires: 00:01:39
Group(s) 232.0.0.0/5
  RP 1.1.1.1 (?), v2
    Info source: 1.1.1.1 (?), via bootstrap, priority 0, holdtime 150
         Uptime: 00:44:16, expires: 00:02:22

as it shown above from the show command in R3,  R1 is the RP and the mapping agent (BSR) in AS 200

R3 configured to be receiver for the following groups:

225.1.1.1

239.1.1.1

239.3.3.3

the goal is to have the groups 239.1.1.1 and 239.3.3.3 receive multicast feed from local senders only in AS 200

while group 225.1.1.1.1 can recieve multicast traffic from other Domains in our Example AS 100

R2#show ip pim rp mapping
PIM Group-to-RP Mappings

Group(s) 224.0.0.0/7
  RP 10.10.10.10 (?), v2
    Info source: 10.10.10.10 (?), via bootstrap, priority 0, holdtime 150
         Uptime: 00:37:45, expires: 00:01:45
Group(s) 232.0.0.0/5
  RP 10.10.10.10 (?), v2
    Info source: 10.10.10.10 (?), via bootstrap, priority 0, holdtime 150
         Uptime: 00:54:35, expires: 00:02:24

R10 is the RP/BSR for AS 100,  bellow is the configuration of R10 ( R1 same configurations)

ip multicast-routing
!
interface Loopback0
ip address 10.10.10.10 255.255.255.0
ip pim sparse-mode
ip ospf 1 area 0
!
interface FastEthernet1/0
ip address 10.1.1.1 255.255.255.0
ip pim sparse-mode


interface FastEthernet1/1
ip address 192.168.1.10 255.255.255.0
ip pim bsr-border
ip pim sparse-mode
!
router ospf 1
log-adjacency-changes
network 10.1.1.1 0.0.0.0 area 0
default-information originate always
!
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 192.168.1.1 remote-as 200
neighbor 192.168.1.1 default-originate
no auto-summary
!
ip pim bsr-candidate Loopback0 0
ip pim rp-candidate Loopback0 group-list 10
ip msdp peer 192.168.1.1 remote-as 200
ip msdp sa-filter in 192.168.1.1 list 100
ip msdp sa-filter out 192.168.1.1 list 100
ip msdp redistribute list 100
!
access-list 10 permit 232.0.0.0 7.255.255.255 
access-list 10 permit 224.0.0.0 1.255.255.255
access-list 100 deny   ip any 232.0.0.0 7.255.255.255
access-list 100 permit ip any any


!

as we can see from the above configurations

R10 and R1 are BGP peers and MSDP peers as well

ACL 10 is for multicast groups

ACL 100 for MSDP SA filtering  to make sure 232.0.0.0 rang will not be propagated out side the local domain

lets do some verifcations and pings to simulate a multicast sender from R2 to R3

R10#show ip msdp peer
MSDP Peer 192.168.1.1 (?), AS 200 (configured AS)
  Connection status:
    State: Up, Resets: 1, Connection source: none configured
    Uptime(Downtime): 00:00:28, Messages sent/received: 1/1
    Output messages discarded: 0
    Connection and counters cleared 00:18:49 ago
  SA Filtering:
   Input (S,G) filter: 100, route-map: none
    Input RP filter: none, route-map: none
    Output (S,G) filter: 100, route-map: none
    Output RP filter: none, route-map: none
  SA-Requests:
    Input filter: none
  Peer ttl threshold: 0
  SAs learned from this peer: 0
  Input queue size: 0, Output queue size: 0

R2:

R2#ping 239.3.3.3

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 239.3.3.3, timeout is 2 seconds:
.

this is because of the filtering we put in R10

R2#ping 225.1.1.1

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 225.1.1.1, timeout is 2 seconds:

Reply to request 0 from 20.1.1.3, 504 ms
Reply to request 0 from 20.1.1.3, 552 ms

this time we recieved the replay from R3 as this group not part of the filtering and now we have seder in AS 100 and the receiver in AS 200

R10#show ip mroute

(*, 225.1.1.1), 00:01:47/stopped, RP 10.10.10.10, flags: SP
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list: Null

(2.2.2.2, 225.1.1.1), 00:01:47/00:01:12, flags: A
  Incoming interface: FastEthernet1/0, RPF nbr 10.1.1.2
  Outgoing interface list:
    FastEthernet1/1, Forward/Sparse, 00:02:10/00:03:18

(10.1.1.2, 225.1.1.1), 00:02:12/00:01:22, flags: TA
  Incoming interface: FastEthernet1/0, RPF nbr 0.0.0.0
  Outgoing interface list:
    FastEthernet1/1, Forward/Sparse, 00:02:11/00:03:16

bellow is the SA cache entry in R1 about the source from AS 100 which is R2

R1#show ip msdp sa-cache
MSDP Source-Active Cache - 2 entries
(2.2.2.2, 225.1.1.1), RP 10.10.10.10, BGP/AS 100, 00:02:31/00:05:34, Peer 192.168.1.10
(10.1.1.2, 225.1.1.1), RP 10.10.10.10, BGP/AS 100, 00:02:31/00:05:34, Peer 192.168.1.10

Thank you and I wish this will be helpful

Marwan Alshawi

Version history
Revision #:
1 of 1
Last update:
‎12-19-2009 02:57 PM
Updated by:
 
Labels (1)
Comments
New Member

Hi Marwan,

Again a nice article which helps us. Indeed I was searching of this kind. thanks

sairam    

New Member

Hello Marwan,

Great article and very clear and nice description of the multicast concepts. Thanks for sharing!

Shivani

New Member

I seem to recall that there are limitations on what match commands can be used when using a route-map to control SA messages. I think I have see that this is limited to matching on tag only but I cannot find that.

I also cannot find any details in the config guides and command referecnes I have looked in or general seaches.

Are there any such limitations?

Thanks for any replies