Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

OSPFv3 Route Summarization Part-1 (Inter-area route summarization )

     

    Introduction:

    As we know OSPF is link state routing protocol that works on the concept of areas. All routers in area must have same LSDB (link state database); hence OSPF summarization can do only on the border routers. There are two types of summarization you can do in OSPFv3:

    •Inter-area route summarization

    •External route summarization:

    You configure inter-area route summarization on ABRs, summarizing routes between areas in the autonomous system. To take advantage of summarization, assign network numbers in areas in a contiguous way to be able to lump these addresses into one range.

    External route summarization is specific to external routes that are injected into OSPFv3 using route redistribution. You should make sure that external ranges that are being summarized are contiguous. Summarizing overlapping ranges from two different routers could cause packets to be sent to the wrong destination. Configure external route summarization on ASBRs that are redistributing routes into OSPF.

    In this document we will discussed on OSPFv3 inter-area route summarization. Summarization concepts are same for OSPV3 as for OSPFv2, even commands remain the same.

    Please also go through IPv4 OSPF inter-area summarization document to get more knowledge.

    Background:

    In following example router ABR is directly connected to R1 in area 1 and to R2 in backbone area0.On R1 there are three Vlans interfaces configured with the following IPv6 addresses:

     

        VLAN 1: FC00:1:1:2001::1/64

        VLAN 2: FC00:1:1:2011::1/64

        VLAN 3: FC00:1:1:2021::1/64

    Topology Diagram:

    OSPFv3 Route Summarization Part-1 (Inter-area route summarization ).jpg

    Initial configuration:

     

    R1

    ABR

    R2

    ipv6 unicast-routing

    !

    interface Loopback0

    ip address 1.1.1.1 255.255.255.255

    !

    interface FastEthernet0/0

    no ip address

    speed 100

    full-duplex

    ipv6 address 2001::1/64

    ipv6 ospf 100 area 1

    !

    interface FastEthernet1/0

    !

    interface FastEthernet1/1

    switchport access vlan 2

    !

    interface FastEthernet1/2

    switchport access vlan 3

    !

    interface Vlan1

    no ip address

    ipv6 address FC00:1:1:2001::1/64

    !

    interface Vlan2

    no ip address

    ipv6 address FC00:1:1:2011::1/64

    !

    interface Vlan3

    no ip address

    ipv6 address FC00:1:1:2021::1/64

    !

    ipv6 router ospf 100

    log-adjacency-changes

    ipv6 unicast-routing

    ipv6 cef

    !

    interface Loopback0

    ip address 10.10.10.10 255.255.255.255

    !

    interface FastEthernet1/0

    no ip address

    duplex full

    speed 100

    ipv6 address 2001::1/64

    ipv6 ospf 100 area 1

    !

    interface FastEthernet1/1

    no ip address

    duplex full

    speed 100

    ipv6 address 2002::1/64

    ipv6 ospf 100 area 0

    !

    ipv6 router ospf 100

    log-adjacency-changes

    !

     

     

     

     

     

     

     

    ipv6 unicast-routing

    !

    interface Loopback0

    ip address 2.2.2.2 255.255.255.255

    !

    interface FastEthernet0/0

    no ip address

    speed 100

    full-duplex

    ipv6 address 2002::2/64

    ipv6 ospf 100 area 0

    !

    ipv6 router ospf 100

    log-adjacency-changes

    !

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

    R2 in area 0 learns Type3 LSA for above mention VLANs via ABR and installed them into routing table as shown in below output:

     

    R2#sh ipv6 route ospf | sec O

           O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2

           ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2

    OI 2001::/64 [110/11]

         via FE80::C803:72FF:FE88:1D, FastEthernet0/0

    OI FC00:1:1:2001::/64 [110/12]

         via FE80::C803:72FF:FE88:1D, FastEthernet0/0

    OI FC00:1:1:2011::/64 [110/12]

         via FE80::C803:72FF:FE88:1D, FastEthernet0/0

    OI FC00:1:1:2021::/64 [110/12]

         via FE80::C803:72FF:FE88:1D, FastEthernet0/0

     

    R2#sh ipv6 ospf database | beg Inter Area Prefix Link States

                   Inter Area Prefix Link States (Area 0)

     

    ADV Router     Age         Seq#       Prefix

    10.10.10.10     411         0x80000003 2001::/64

    10.10.10.10     88         0x80000001 FC00:1:1:2001::/64

    10.10.10.10     78         0x80000001 FC00:1:1:2021::/64

    10.10.10.10     78         0x80000001 FC00:1:1:2011::/64

     

                   Link (Type-8) Link States (Area 0)

     

    ADV Router     Age         Seq#       Link ID   Interface

    2.2.2.2         1536       0x80000006 4         Fa0/0

    10.10.10.10     411         0x80000008 5         Fa0/0

     

                   Intra Area Prefix Link States (Area 0)

     

    ADV Router     Age         Seq#       Link ID   Ref-lstype Ref-LSID

    2.2.2.2         1536       0x80000006 4096       0x2002     4

     

    To summarized prefix there are two steps:

    A) You need to find Summary prefix

    B) Configure the "area [area-id] range [IPv6 prefix] [mask] [advertise | not-advertise |cost {cost}]" command under OSPFv3 process:

    A) Calculation of Summery prefix:

    We have to summarize the following routes:

    VLAN 1: FC00:1:1:2001::1/64

    VLAN 2: FC00:1:1:2011::1/64

    VLAN 3: FC00:1:1:2021::1/64

     

    1) Identify where you can do the summarization. In our example 1st three hexadecimal places are same hence summarization can be done in the 4th hexadecimal place. So we know our subnet will be somewhere between /48 and /64.

    2) You need to break it down in binary:

    2001= 0010 0000 0000 0001

    2011= 0010 0000 0001 0001

    2021= 0010 0000 0010 0001

     

    3) Find the common bits then Set the rest bits to 0 and calculate the summary by converting into hex.

    2001= 0010 0000 0000 0001

    2011= 0010 0000 0001 0001

    2021= 0010 0000 0010 0001

    Common bits=0010 0000 00

    Summary = 0010 0000 0000 0000 = 2000 (In Hex)

     

    4)  Calculate subnet mask by adding the common bits to the lower of our subnet range. This means we need to add 10 to /48 which makes /58.

    So our summary address is FC00:1:1:2000::/58

     

    B) Configure the area range command On ABR under OSPFv3 process:

    ABR#conf t

    Enter configuration commands, one per line. End with CNTL/Z.

    ABR(config-rtr)#area 1 range FC00:1:1:2000::/58

    ABR(config-rtr)#end

    ABR#

     

    After configuring summarization on ABR, R2 is receiving only summary route FC00:1:1:2000::/58 not individual type 3 LSA for each VLAN from ABR shown below:

    R2#sh ipv6 route ospf

    IPv6 Routing Table - 5 entries

    Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP

           U - Per-user Static route, M - MIPv6

           I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary

           O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2

         ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2

           D - EIGRP, EX - EIGRP external

    OI 2001::/64 [110/11]

         via FE80::C803:72FF:FE88:1D, FastEthernet0/0

    OI FC00:1:1:2000::/58 [110/12]

         via FE80::C803:72FF:FE88:1D, FastEthernet0/0

     

    R2#sh ipv6 ospf database | beg Inter Area Prefix Link States

                   Inter Area Prefix Link States (Area 0)

     

    ADV Router     Age         Seq#       Prefix

    10.10.10.10     578         0x80000004 2001::/64

    10.10.10.10     161         0x80000001 FC00:1:1:2000::/58

     

                   Link (Type-8) Link States (Area 0)

     

    ADV Router     Age         Seq#       Link ID   Interface

    2.2.2.2         1707       0x80000007 4         Fa0/0

    10.10.10.10     578         0x80000009 5         Fa0/0

     

                   Intra Area Prefix Link States (Area 0)

     

    ADV Router     Age         Seq#       Link ID   Ref-lstype Ref-LSID

    2.2.2.2         1707       0x80000007 4096       0x2002     4

     

    Verifying reachability after summarization from R2:

    R2#ping fc00:1:1:2001::1

     

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to FC00:1:1:2001::1, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 32/126/192 ms

    R2#ping fc00:1:1:2011::1

     

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to FC00:1:1:2011::1, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 16/28/44 ms

    R2#ping fc00:1:1:2021::1

     

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to FC00:1:1:2021::1, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 12/24/52 ms

    R2#

     

    Discard Route:

    During route summarization, routing loops may occur when data is sent to a non-existing network that appears to be a part of the summary, and the router that is performing the summarization has a less specific route (pointing back to the sending router) for this network in its routing table. To prevent the routing loop, a discard route entry is installed in the routing table of the ABR.

    Like in ipv4 after summarization by default ABR generated Discard route pointing towards null0 interface in its routing.

    ABR# sh ipv6 route ospf

    IPv6 Routing Table - default - 8 entries

    Codes: C - Connected, L - Local, S - Static, U - Per-user Static route

           B - BGP, M - MIPv6, R - RIP, I1 - ISIS L1

           I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP

           EX - EIGRP external, ND - Neighbor Discovery

           O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2

           ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2

    O   FC00:1:1:2000::/58 [110/0]

         via Null0, directly connected

    O   FC00:1:1:2001::/64 [110/2]

         via FE80::C204:5EFF:FE60:0, FastEthernet1/0

    O   FC00:1:1:2011::/64 [110/2]

         via FE80::C204:5EFF:FE60:0, FastEthernet1/0

    O   FC00:1:1:2021::/64 [110/2]

         via FE80::C204:5EFF:FE60:0, FastEthernet1/0

     

    If you want to disable creation of the discard route, you can use the no discard-route command as follows:

    ABR#conf t

    Enter configuration commands, one per line. End with CNTL/Z.

    ABR(config)#ipv6 router ospf 100

    ABR(config-rtr)#no discard-route internal

    ABR(config-rtr)#end

    ABR# sh ipv6 route ospf

    IPv6 Routing Table - default - 7 entries

    Codes: C - Connected, L - Local, S - Static, U - Per-user Static route

           B - BGP, M - MIPv6, R - RIP, I1 - ISIS L1

           I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP

           EX - EIGRP external, ND - Neighbor Discovery

           O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2

           ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2

    O   FC00:1:1:2001::/64 [110/2]

         via FE80::C204:5EFF:FE60:0, FastEthernet1/0

    O   FC00:1:1:2011::/64 [110/2]

         via FE80::C204:5EFF:FE60:0, FastEthernet1/0

    O   FC00:1:1:2021::/64 [110/2]

         via FE80::C204:5EFF:FE60:0, FastEthernet1/0

    Related Information:

    Configuring OSPFv3

    Version history
    Revision #:
    2 of 2
    Last update:
    4 weeks ago
    Updated by:
     
    Contributors
    Comments
    New Member

    Is this CCNA, CCNP, or other level knowledge?