Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

PBR issue in cisco 2901 router

Hi,

I have configured PBR on my 1800 series router, it is working perfect. Now I am changing my router from 1800 to 2901 router with the same config, so the PBR stop working and I am not getting hits in the second WAN interface. The config is quite simple, Kindly help:

Configuration:

===========

interface FastEthernet0/0

description INTERNET # 2

ip address 203.xx.x.xx 255.255.255.248

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 172.16.1.1 255.255.255.240

ip nat inside

ip virtual-reassembly

ip policy route-map zee

duplex auto

speed auto

!

interface Serial0/0/0:0

description INTERNET #1 Internet

ip address 221.xx.xx.xx 255.255.255.252

ip nat outside

ip virtual-reassembly

!

!

ip nat inside source list PTLink interface Serial0/0/0:0 overload
ip nat inside source list Superlink interface GigaEthernet0/0 overload
ip nat inside source static 172.16.1.11 203.xx.xx.xx
ip nat inside source static 172.16.1.14 203.xx.xx.xx

!

!

!

ip access-list extended PTLink
permit ip host 172.16.1.13 host 221.xx.xx.xx
permit ip host 172.16.1.6 any

!

ip access-list extended Superlink
permit ip host 172.16.1.13 host 203.xx.xx.xx
permit ip host 172.16.1.13 host 203.xx.yy.xx
permit ip host 172.16.1.13 host 203.xx.zz.xx
!

!

!
ip access-list extended test_PT
permit ip host 172.16.1.2 any
permit ip host 172.16.1.14 any
permit ip host 172.16.1.7 any
permit tcp host 172.16.1.1 eq 7778 any
permit ip host 172.16.1.10 any
permit ip host 172.16.1.6 any
ip access-list extended test_SUPER
permit ip host 172.16.1.8 any
permit tcp host 172.16.1.11 eq smtp any
permit tcp host 172.16.1.11 any eq smtp
permit tcp host 172.16.1.11 any eq domain
permit ip host 172.16.1.11 any
permit tcp host 172.16.1.5 eq 7778 any
permit tcp host 172.16.1.12 eq ftp-data any
permit tcp host 172.16.1.12 eq ftp any
permit tcp host 172.16.1.12 eq www any
permit tcp host 172.16.1.12 eq domain any
permit ip host 172.16.1.12 any
permit icmp host 172.16.1.13 host 203.xx.yy.xx
permit icmp host 172.16.1.13 host 203.xx.xx.xx
permit ip host 172.16.1.4 any
route-map zee permit 10
match ip address test_PT
set ip next-hop 221.xx.xx.xx
!
route-map zee permit 20
match ip address test_SUPER
set ip next-hop 203.xx.xx.xx
!
route-map zee deny 30

Which exact IOS are you using ?

Hi Shaikh,

    I have checked the configuration and it looks correct and can you please send the output of show route-map zee ?

This document was generated from the following thread: PBR issue in cisco 2901 router

10
Views
0
Helpful
0
Comments