Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

RME PSIRT/EoX Report Updates

This is just a brief update on the current state of the PSIRT and EoX reporting features of Resource Manager Essentials.  Recently, there were problems with the Cisco.com backend which led to the inability to run the reports.  A workaround was in place where one could download the report data manually, and run a local report.  However, this only worked for RME 4.2 and 4.3.x.  RME 4.1.1 did not have the ability to do an offline local report.

The bug which describes the problems with these reports is CSCte71764.  It is now fixed via patches provided on Cisco.com.  The following are the links to the various versions of the patch.

Version of RME
WindowsSolaris
4.1.1DownloadDownload
4.2DownloadDownload
4.3.1DownloadDownload

When the patches are applied, the online help will be updated with the new URLs to use to download the offline data files.  If you can't wait, though, the offline files can be downloaded from here.

Once the patch is applied, the reports will work as before.

UPDATE: The patch has been updated to include fixes for the following bugs:

CSCtc36563 : Unable to get the PSIRT report via Proxy server

CSCta76147 : Unable to get the EoS/EoL report via Proxy server

This means that full functionality of the PSIRT/EoX reports will be restored by applying the patch, even if a proxy is involved.

Version history
Revision #:
1 of 1
Last update:
‎04-26-2010 11:20 AM
Updated by:
 
Labels (1)
Everyone's tags (5)
Comments

Joe,

I tested the patch and found it indeed resolves both the issues in my lab.

At the customer site however the PSIRT works fine, but not the EOx reports.

Difference between lab and customer site is a proxyserver.

.

Just to be 100% sure.

"Once the patch is applied, the reports will work as before unless a  proxy server is involved.  If you are using a proxy to connect to  Cisco.com, PSIRT reports will still fail due to CSCtc36563, and EoX  reports will fail due to CSCta76147.  These bugs are planned to be fixed  in LMS 4.0 due out summer 2010."

I'm I reading here that if my customer uses a proxy, the problems will simply not be fixed in LMS version 3 ?

I'm not sure how I will explain this to my customer......

Cheers,

Michel

Cisco Employee

We actually have a patch very close to release which will fix the proxy problem.  I have held off updating this doc until that patch is ready.

Thanks Joe,

I'm glad to hear this  

Cheers,

Michel

I monitor the bug ID's but I'm not confident I get notified when the patch is there.

Is it out yet? Any ETA?

Cheers,

Michel

Cisco Employee

There is currently an RME 4.3.x patch available by contacting TAC.  We're still waiting for ETA on 4.2 and 4.1.1.

New Member

I have installed the patch and it worked great for a while connecting to cisco to get the psirt.  But now it has stopped working again.  Are there any problems reported with the  psirt at cisco ?

Greetings from Stig

Cisco Employee

The fetch job ran successfully last night, but now there appears to be a problem with Cisco.com.  This may just be a transient issue given the holidays.  The offline file downloads are working, though.

New Member

Thank you for your reply, i will try again some day to run the psirt and look into it more, if it does not work I will post.

Cisco Employee

I tested again today, and the reports are working.

New Member

Still not working, I am starting to wonder if something is wrong with our connection.  But it worked great a couple of weeks ago after i installed the patch.  Maybe I will have to go back to using the offline one instead..

Do you know how to check Cisco.com connectivity ?

Unable to get data from Cisco.com. Check Cisco.com connectivity. Try again later

Greetings from Stig

Cisco Employee

Make sure your fetch time is set appropriately under RME > Admin > Inventory > Cisco.com Fetch Interval.  You should also try reinstalling the patch.

Hi Joe,

Same problem here. Issue was first seen on the Dec 20 weekly reports..3 reports run with 5 minutes between them

05:00 EoS/EoL Hardware  fail

05:05 EoS/EoL Software   success

05:10 PSIRT                      fail

Browsing the logs I see that the 3 jobs try to download the same file 3 times. Fetch interval however is 1 hour !


[ Mon Jan 03  05:10:04 GMT 2011 ],INFO ,[main],com.cisco.nm.rmeng.inventory.reports.util.PSIRTXMLParser,GetDownloadUrl,245,_psirturl       http://www.cisco.com/cgi-bin/Software/WLAN/cwselectfile.cgi?bp=1&SEARCH=rme||4.3.0||Patch&FORMAT=TEXT
[ Mon Jan 03  05:05:07 GMT 2011 ],INFO ,[main],com.cisco.nm.rmeng.inventory.reports.util.EOXSoftwareXMLParser,GetDownloadUrl,380,_psirturl http://www.cisco.com/cgi-bin/Software/WLAN/cwselectfile.cgi?bp=1&SEARCH=rme||4.3.0||Patch&FORMAT=TEXT
[ Mon Jan 03  05:00:05 GMT 2011 ],INFO ,[main],com.cisco.nm.rmeng.inventory.reports.util.EosEolXmlParser,GetDownloadUrl,228,_psirturl      http://www.cisco.com/cgi-bin/Software/WLAN/cwselectfile.cgi?bp=1&SEARCH=rme||4.3.0||Patch&FORMAT=TEXT

And so it works once out of three times, consistently for the job in the middle.

Are you aware of any changes made the week before the 20th December?

Cheers,

Michel

Cisco Employee

There was a hiccup in Cisco.com around 12/27, but I know of no permanent changes.  I can confirm the download is working for me now.  I would say that anyone that is still experiencing problems should open a TAC service request so development can take a look.

That what I did. SR 616440341 PSIRT EOX reports failing. Fadi is taking a look for now.

I also reinstalled the patch as you suggested. The manual download of the files involved goes fine.

New Member

I am trying to download the psirt_eox_offline file for windows from the link above.  I've tried a few times and I keep getting a corrupt file.

I know this is an old post but I keep getting a lot of links back to this page.

Is the file corrupt or am I doing something wrong.  I have also installed the latest patches and tried to download the files from LMS 3.2.1, but this also fails.  EOX_Software is working fine.

Thanks

Mark