Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

Steps for Creating an Etherchannel Between Catalyst Switches Running IOS

This document provides simplified steps for creating a layer two port channel between two Catalyst switches running IOS.  In this example we're creating a portchannel between a Catalyst 4500 and Catalyst 6500 using LACP.

When creating a port channel, it is very important that it be done in the proper order.

1) Determine the port channel numbers you want to use on both ends and make sure they are not already in use

2) Configure all interface attributes prior to assigning them to the port channel

3) Assign the interfaces to the port channel

4) Verify the port channel is up and the interfaces are properly bundled

1) Determine the port channel numbers you want to use on both ends and make sure they are not already in use with the "show etherchannel summ" command.

4500#sh etherc summ

Flags:  D - down        P - bundled in port-channel

        I - stand-alone s - suspended

        R - Layer3      S - Layer2

        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met

        u - unsuitable for bundling

        w - waiting to be aggregated

        d - default port

Number of channel-groups in use: 1

Number of aggregators:           1

Group  Port-channel  Protocol    Ports

------+-------------+-----------+-----------------------------------------------

20     Po20(RD)         -      

!! As port-channel 20 already exists I want to make sure I do NOT use this port-channel number for my new port-channel.

2) Configure all interface attributes PRIOR to assigning them to the port-channel.

4500(config)#int range g1/2-3

4500(config-if-range)#switchport

4500(config-if-range)#switchport trunk enc dot1q

4500(config-if-range)#switchport mode trunk

4500(config-if-range)#switchport trunk allowed vlan 2-3

3)  Assign the interfaces to the port-channel.  Let the switch dynamically create the port-channel interface.

4500(config-if-range)#channel-group 10 mode active

Creating a port-channel interface Port-channel 10

At this point the port-channel will be down and in a "waiting to be aggregated" state as you must now create the port-channel on the other end.

Note in the below output the interfaces have (I) after them, indicating they are waiting to receive LACP packets form their peer switch.

4500#sh etherchannel summary

Flags:  D - down        P - bundled in port-channel

        I - stand-alone s - suspended

        R - Layer3      S - Layer2

        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met

        u - unsuitable for bundling

        w - waiting to be aggregated

        d - default port

Number of channel-groups in use: 2

Number of aggregators:           2

Group  Port-channel  Protocol    Ports

------+-------------+-----------+-----------------------------------------------

10     Po10(SD)        LACP      Gi1/2(I)    Gi1/3(I)

Connect to the peer switch and perform the same steps 1-3.

6500(config)#int range g5/1-2

6500(config-if-range)#switchport

6500(config-if-range)#switchport trunk enc dot

6500(config-if-range)#switchport mode trunk

6500(config-if-range)#switchport trunk allowed vlan 2,3

6500(config-if-range)#channel-group 10 mode active

On the 6500, after adding the ports to the channel you will see this message:

%EC-SP-5-PORTDOWN: Shutting down Gi5/1 as its port-channel is admin-down
%EC-SP-5-PORTDOWN: Shutting down Gi5/2 as its port-channel is admin-down

To bring the port channel up you must no-shut the port channel interface:

6500(config)#int port-channel 10
6500(config-if)#no shut

4) Verification:

Check to see that the etherchannel is now properly bundled on each end.  You want to see the P-Flag (P) after the interfaces, indicating they are bundled.

4500#sh etherc summ

Flags:  D - down        P - bundled in port-channel

        I - stand-alone s - suspended

        R - Layer3      S - Layer2

        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met

        u - unsuitable for bundling

        w - waiting to be aggregated

        d - default port

Number of channel-groups in use: 2

Number of aggregators:           2

Group  Port-channel  Protocol    Port

------+-------------+-----------+-----------------------------------------------

10     Po10(SU)        LACP      Gi1/2(P)    Gi1/3(P)


6500#sh etherc summ
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
10     Po10(SU)        LACP      Gi5/1(P)    Gi5/2(P)  

You will now see the port-channel interface with the same conifg as the physical interfaces:

4500#sh run int po10

Building configuration...

Current configuration : 140 bytes

!

interface Port-channel10

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 2,3

switchport mode trunk

end


6500#sh run int port-channel 10
Building configuration...

Current configuration : 140 bytes
!
interface Port-channel10
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2,3
switchport mode trunk
end

All future changes (such as adding or removing vlans) should be done on the port-channel interface:

Note, on the Catalyst 4500, Sup6-E you cannot apply auto-qos directly on a port channel.  See CSCsq67430 for details and the proper config steps.

Version history
Revision #:
1 of 1
Last update:
‎12-24-2010 07:58 AM
Updated by:
 
Labels (1)