Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

UK BT ADSL2+ Annex A - Cisco 877

UK is currently going through a nationwide migration from ADSL, ADSL2 and ADSL2max to ADSL2+.

Most British Telecom (BT) MSANs are configured for Annex A, though we know that some LLU suppliers are using Annex M (with UK mask) which Cisco currently doesn't support.

Our issues are that all out Cisco 877s and there are 100s deployed that are subject to a line upgrade, or a new installs on ADSL2+ fail.

We have used the latest IOS that will runn on the older 128M DRAM units 12.4(15)T11 I think, and 12.4(24)T1 on newer units.  We have also played with DSL Modem firmware 3.0.33 and more recently 4.0.015 (which incidently works very well on UK ADSL2 Annex A).  None have helped.

The connectivity in UK is PPPoA

Symptoms:

It appears to be dependent on the amount of data through the DSL interface.

So a 24Mb/s connection will fail in hours, whereas a 9Mb/s will fail in days.

'sh int atm0' will show drops

'sh buffers' will show the middle and big buffers failing in particular.

Small packets such as ICMP and SSH will continue to work, so we can log on to the router(s) remotely.

But large packets such as those used for normal data will not pass the router reliably if at all.

Replace the router with a $100 item and the connection speed is normally better and there are no issues.

All these routers are similarly configured, have CBAC inspect code and a single IPSEC VPN.

MTU and MSS sizes are reduced to support IPSEC.

(though I hear the same problem from other UK deployments)

I have placed some info on the NetPro forum, seach for ADSL2+ and you should find it.

I have calls out to BT, large UK distributors and ISPs without any resolution or identification of the problem.

I think this is a significant issue given the value of Cisco DSL real estate in UK.

HELP!!!!

Ian Cowley

Version history
Revision #:
1 of 1
Last update:
‎10-10-2009 05:33 AM
Updated by:
 
Labels (1)
Everyone's tags (5)
Comments
New Member

Ian , not clear how to reply to your original document re issues of interoperability of Cisco ADSL with UK DSL, so I hope this gets to you.

We are experiencing very similar symptoms, except perhaps we have get longer periods of stability with the ADSL2 but only after significant tuning with the ISP. - However still by no means the required level of stability.

I am sorry i can't be of any specific help in this matter, but perhaps we can use this as an opportunity to keep some sort of open dialog on this to share what is obviously a very painful experience !

New Member

ADSL2 works reasonably well especially with latest DSL firmware. but a fully loaded 877 (with IPSEC VPNs, CBAC/inspect/audit, NAT, etc) is completely unstable.

Cheap resendential class units work fine

New Member

Hello Ian

We have a DMVPN network where each 877 spoke uses BT ADSL to come in. The ADSL2+ rollout has so far hit a small number of our remote sites. One of those sites was having problems which may or may not be related to the ones you're having: even though the traffic is quite low, the ATM interface was flapping constantly and the router even crashed a few times. All the 877s had identical software and configuration, and if I recall correctly the only commonality amongst the ones that worked was that Noise values (from a show dsl int atm0) were in the same ballpark, where the failing router had higher values.

At first we managed to make the line usable by having BT throttle the line back to ~2Mb/s, which is perfectly sufficient for our normal throughput requirements, but of course is not a viable long-term solution.

On October 23rd Cisco released a new firmware which I recently loaded onto the affected router along with the latest IOS, then got BT to remove the cap. We see the Reed-Solomon errors immediately ramp up to quite high values the moment the ATM line is connected, but the connection quickly goes stable and subsequent disturbances to the line produce only modest increases in error rates across the board.

We are still monitoring this router but the early signs are good. The line has shown pretty much no outages* since the new software was installed two days ago; on the old IOS/firmware the line would have been unusable long before now.

Hope this helps!

* there was an outage overnight on the first evening, but this also occurred on another test line we had installed at the same site, so we put it down to some tomfoolery at the exchange.

New Member

Brian

Many thanks for your update and your scenario(s) correpond directly with ours.  We had ADSL2+ knocked back to ADSL2 and though there were errors its was E-11 so not an issue and from client perspective stable.

I am waiting for my own line to be upgraded this month to play with my own 877 as suprisingly 21CN doesn't come to our part of the City(London) til next year.  The clients are less than for us to use them as guinea pigs!

I have spoken to a number of ISPs who use Cisco kit for Business connections; typically DSL to private MPLS.

They have seen no problems, but they don't run inspect or IPSEC.

When you mention software are you talking IOS and/or  dsl firmware.

Have seen that dsl 4.0.18 has been released for the 877 and was going to try this.

Regards

New Member

Ian

We did both the IOS update to 12.4 (24) T1 and the new 4.0.018 firmware. I'm quite certain that it was the firmware that did the trick, although the IOS update didn't hurt the site either.

Regards

New Member

Hopefully it is the firmware that's sorted it as 12.4(15) and onwards need lots of flash and DRAM, that isn't available on the earlier boxes.

New Member

I hope it sorts your problem out Ian. I'd be interested to know if it does work, and what IOS you're using.

Regards

New Member

Hi Ian

Did it work?

Regards

Brian

New Member

I am please to let you know that firmware 4.0.018 appears to sort out the issues.

Unfortunately my line only goes to 4M even with ADSL2+, but it is stable.

Next report will be on a geater than 12M line

IanC

New Member

Hi,

I work for a managed services partner and we too are seeing this issue with Cisco kit on ADSL2+ connections, we have applied this 877 fix and it seems to be working so far but we have many routers out there which dont have this fix.

EG:

Cisco 1801

Cisco 1841 with WIC-1ADSL cards

I've been looking and there doesnt seem to be a fix issued for the 1801 or ADSL WIC card, are Cisco going to release a patch for these models as the issued patch only seems to be for the 877 and 857 models.

Regards

Chris

New Member

Further Update re BT ADSL2+

I have 2 877Ws connected to different exchanges in London; my own in SW and a clients in Docklands, both areas of which have some copper cabling issues due to minor disturbances in 1944.

Both run ADSL firmware 4.0.018, mine runs 12.4(24)T2 and the other 12.4(15)T10 (there's method in my madness!).  Both are attached to BT Exchanges with  IFTN, Infineon (Huawei) MANs.  I have no experience with other MANs at this time.

Mine runs as described before at 3.8M and is reasonably reliable though perhaps as expected with DSL on overhead lines drops out occasionally, but is far better than with earlier firmware.

The clients syncs up to 11Mb but collapses randomly, continually.  However the standard BT router, probably a 2Wire, connects at 12Mb and running continuously without problem.

We know knocking the line back to 9M will solve the problem, but Cisco should have an answer.  Unlesss its a hardware defect across their DSL processor.

Since posting here last year I've had feedback from numerous sources claiming the same problem with the DSL WICs too.

Cisco???

New Member

I have a customer on an LLU connection over Tiscali network and apparantly the 877 is not compatible with their hardware. It did sync at 16Mb for a while but now will not connect.

Other routers still seem to work but I cannot make the 877 work. We are moving it to a Cable and Wireless c onnection to try that.

New Member

I'm having a somewhat similar issue with my 1841 and HWIC-1ADSL over here in Canada. The connection is unstable, where with a cheap D-Link ADSL modem, the connection is rock stable and won't go down for MONTHS.

I've tried firmware versions 4.0.018 and currently trying 3.0.33.....

New Member

Y'all

We are still having problems with ADSL2+ lines in UK even with the 4.0.018 firmware.

The routers not only barely achieve 12M, while cheap domestic routers exceed 15M, the routers remain unstable with line drops or no traffic passing until reboot.

The lack of apparent attention by Cisco is an ongoing concern.

New Member

Since installing the 4.0.018 firmware and 12.4.24(T1) IOS on the router that was affected we've had no worrisome issues. We upgraded all our routers thus and BT have now upgraded the lines to ~80 of our routers up to ADSL2+ with no complaints so far.

I know that Ian couldn't upgrade his 877s to a later IOS because of a lack of flash. How about your 1841 Chris?

Regards

Brian Gillespie

#sh dsl int atm0
ATM0
Alcatel 20190 chipset information
           ATU-R (DS)               ATU-C (US)
Modem Status:      Showtime (DMTDSL_SHOWTIME)
DSL Mode:      ITU G.992.5 (ADSL2+) Annex A
ITU STD NUM:       0x03                     0x3 
Chip Vendor ID:      'STMI'                     'TSTC'
Chip Vendor Specific:  0x0000                0x0510
Chip Vendor Country:   0x0F                0xB5
Modem Vendor ID: 'CSCO'                     'TSTC'
Modem Vendor Specific: 0x0000                0x5100
Modem Vendor Country:  0xB5                0xB5
Serial Number Near:    FHK121225Z2
Serial Number Far:     0000000000Chip ID:       C196 (0)
DFE BOM:      DFE3.0 Annex A (1)
Capacity Used:      73%                     41%
Noise Margin:      14.5 dB                20.0 dB
Output Power:      18.5 dBm                11.5 dBm
Attenuation:      23.5 dB                11.0 dB
FEC ES Errors:       0                      0
ES Errors:       0                     705
SES Errors:       0                     18
LOSES Errors:       0                     140
UES Errors:       0                     140
Defect Status:      None                            None                        
Last Fail Code:      None
Watchdog Counter: 0x5D
Watchdog Resets: 0
Selftest Result: 0x00
Subfunction:      0x00 
Interrupts:      8292 (0 spurious)
PHY Access Err:      0
Activations:      1
LED Status:      ON
LED On Time:      100
LED Off Time:      100
Init FW:      init_AMR_4.0.018.bin
Operation FW:      AMR-E-4.0.018.bin
FW Source:      external
FW Version:      4.0.18

            DS Channel1       DS Channel0     US Channel1       US Channel0
Speed (kbps):               0            15346              0              448
Cells:                    0           988375              0        109124567
Reed-Solomon EC:          0              179              0                0
CRC Errors:               0                0              0             1167
Header Errors:               0                0              0              351
Total BER:            0E-0           0E-0
Leakage Average BER:       0E-0           0E-0
Interleave Delay:         0                0              0               28
               ATU-R (DS)     ATU-C (US)
Bitswap:            enabled            enabled
Bitswap success:          0                   0
Bitswap failure:          0                   0
New Member

I'm running 12.4.24(T2) on my 1841, didn't find any improvement with 4.0.018 or 3.0.33, so I'm running 4.0.015 right now.

Interesting note:

"show dsl int" gives me:

ATM0/0/0
Alcatel 20190 chipset information
                ATU-R (DS)                      ATU-C (US)
Modem Status:    Showtime (DMTDSL_SHOWTIME)
DSL Mode:        ITU G.992.5 (ADSL2+) Annex A
ITU STD NUM:     0x03                            0x2
Chip Vendor ID:  'STMI'                          'BDCM'
Chip Vendor Specific:  0x0000                    0x93B2
Chip Vendor Country:   0x0F                      0xB5
Modem Vendor ID: 'CSCO'                          'BDCM'
Modem Vendor Specific: 0x0000                    0x0000
Modem Vendor Country:  0xB5                      0xB5
Serial Number Near:    FOC12052QJQCISCO73993206
Serial Number Far:  Chip ID:     C196 (0)
DFE BOM:         DFE3.0 Annex A (1)
Capacity Used:   100%                            86%
Noise Margin:     9.0 dB                         13.5 dB
Output Power:    18.0 dBm                        12.5 dBm
Attenuation:     23.5 dB                         11.0 dB
FEC ES Errors:    1                              12368
ES Errors:        1                              28168
SES Errors:       1                              22366
LOSES Errors:     1                              22294
UES Errors:       0                              22324
Defect Status:   None                            None
Last Fail Code:  None
Watchdog Counter: 0x75
Watchdog Resets: 0
Selftest Result: 0x00
Subfunction:     0x00
Interrupts:      12445 (0 spurious)
PHY Access Err:  0
Activations:     2
LED Status:      OFF
LED On Time:     0
LED Off Time:    0
Init FW:         init_AMR-4.0.015.bin
Operation FW:    AMR-4.0.015.bin
FW Source:       external
FW Version:      4.0.15

                 DS Channel1      DS Channel0   US Channel1       US Channel0
Speed (kbps):             0            19130             0              1020
Cells:                    0          7672982             0         149488887
Reed-Solomon EC:          0            24490             0             39629
CRC Errors:               0            40643             0              6164
Header Errors:            0            61346             0              7276
Total BER:                0E-0           5152E-9
Leakage Average BER:      0E-0           4008E-9
Interleave Delay:         0               29             0                 0
                        ATU-R (DS)      ATU-C (US)
Bitswap:               enabled            enabled
Bitswap success:          0                   0
Bitswap failure:          0                   0

Whilst show int atm0/0/0 yields:

#show int atm0/0/0
ATM0/0/0 is up, line protocol is up
  Hardware is HWIC-DSLSAR (with Alcatel ADSL Module)
  MTU 4470 bytes, sub MTU 4470, BW 1020 Kbit/sec, DLY 500 usec,
     reliability 255/255, txload 88/255, rxload 8/255
  Encapsulation ATM, loopback not set
  Encapsulation(s): AAL5  AAL2, PVC mode
  23 maximum active VCs, 256 VCs per VP, 1 current VCCs
  VC Auto Creation Disabled.
  VC idle disconnect time: 300 seconds
  Last input 18:53:06, output 00:00:00, output hang never
  Last clearing of "show interface" counters 13:45:04
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 1113
  Queueing strategy: Per VC Queueing
  5 minute input rate 35000 bits/sec, 42 packets/sec
  5 minute output rate 353000 bits/sec, 70 packets/sec
     1651870 packets input, 264031407 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 356 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     2189990 packets output, 1968256989 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out

And show atm pvc 0/35 yields:

#show atm pvc 0/35
Description: N/A
ATM0/0/0.1: VCD: 1, VPI: 0, VCI: 35
UBR, PeakRate: 1020 (2406 cps)
AAL5-LLC/SNAP, etype:0x0, Flags: 0xC20, VCmode: 0x0, Encapsize: 12
OAM frequency: 0 second(s), OAM retry frequency: 1 second(s)
OAM up retry count: 3, OAM down retry count: 5
OAM END CC Activate retry count: 3, OAM END CC Deactivate retry count: 3
OAM END CC retry frequency: 30 second(s),
OAM SEGMENT CC Activate retry count: 3, OAM SEGMENT CC Deactivate retry count: 3
OAM SEGMENT CC retry frequency: 30 second(s),
OAM Loopback status: OAM Disabled
OAM VC Status: Not Managed
ILMI VC status: Not Managed
InARP frequency: 15 minutes(s)
InPkts: 1659167, OutPkts: 2199852, InBytes: 266316494, OutBytes: 1975095601
InPRoc: 10588, OutPRoc: 37105, Broadcasts: 0
InFast: 1648579, OutFast: 2147154, InAS: 0, OutAS: 0
InPktDrops: 0, OutPktDrops: 0
CrcErrors: 0, SarTimeOuts: 0, OverSizedSDUs: 0, LengthViolation: 0, CPIErrors: 0
Out CLP=1 Pkts: 0
OAM cells received: 0
F5 InEndloop: 0, F5 InSegloop: 0,
F5 InEndcc: 0, F5 InSegcc: 0, F5 InAIS: 0, F5 InRDI: 0
F4 InEndloop: 0, F4 InSegloop: 0, F4 InAIS: 0, F4 InRDI: 0
OAM cells sent: 0
F5 OutEndloop: 0, F5 OutSegloop: 0,
F5 OutEndcc: 0, F5 OutSegcc: 0, F5 OutAIS: 0, F5 OutRDI: 0
F4 OutEndloop: 0, F4 OutSegloop: 0, F4 OutRDI: 0
OAM cell drops: 0
Status: UP
PPPOE enabled. Current number of pppoe sessions: 1

Notice the MARKED difference in the # of CRC errors shown between the initial command, and the subsequent ones for each interface.....????

New Member

Brian

You're correct in that I can't generally go beyond 12.4(15)T10.

Upgrading the Flash and DRAM is just too expensive and it may be simpler/cheap to replace boxes with latest

Ianc

New Member

Also I've noted that all my issues todate have been on IFTN = Infineon (Huawei) Multi-Service Access Network equipment.

I notice Brian's is on TSTC  = Texas Instruments

and Chris BDCM = Broadcom

IanC

New Member

I've heard that Cisco may be producing a new (v3?) 877.

Does anyonelse know more?

New Member

Ian:

I would like to note that since I posted the above, and my switch to the 4.0.015 firmware, I have not had a single disconnect. So it appears to have fixed my issue.

New Member

Hi Ian

I have been having been having pretty poor performance and stability issues with an 877 router on adsl2+. I am also connected to an Infineon msan.

I have a TAC call open regarding these issues which has resulted in the following bug

CSCtg20300 Bug Details
Performance and Stability issues with adsl2+ CISCO877-K9

I presume this bug is publically available to view and hopefully will result in a new firmware release.

I am on my third beta firmware which is looking promising so far.

James

New Member

Good to hear that things are being worked on James. My issue was definitely resolved with 4.0.015.

-Chris

New Member

Chris

It's worth noting you are on Broadcom MSAN equipment, whereas myself, some of our clients and James are connecting to Infineon kit.  For whatever reason this is where the incompatbility lies.

New Member

Indeed. Which is what I thought 4.0.018 was supposed to resolve? But apparently isn't for you guys. Given that James has tried a few beta firmwares though, it does sound as though Cisco is actively working on the problem, which lends promise to the idea that it might actually be fixed sooner rather than later

New Member

likewise I though 4.0.018 would help and it is stable for me, though my line runs at 56dB attentuation so I only get 4Mb.  Anyone on low attenuation lines and able to get in excess of 10Mb has problems.

Thankfully James has the ability to raise a TAC case.

Fingers X'd.   If D-Link, Netgear and 2Wire can do it.....................

New Member

Yes indeed...... I imagine Efficient and a few others have it working fine as well. It wasn't until 4.0.015 that my $500.00 frickin' HWIC was able to match the line speed and reliability of the $30.00 D-Link DSL-2320B it replaced. So I feel your pain.

New Member

The TAC call CSCtg20300 has now been closed.

After much debugging via the dsl training log outputs and about 7 firmware revisions later I am now using ver 4.0.195.
This has stabilised the noise margin, reduced the large number of errors, and fixed the state where the link would not train up after a flap.

I am occasionally still seeing the atm0 int going down/up but this is generally from 23:00 through till 04:00 in the morning. I suspect it is caused by BT making changes in the exchange, though I have no proof of this.

The TAC guys also could not see any reason from the routers point of view why this was happening. i.e. After the new firmware there was no evidence that this was the routers fault

The firmware has been tweaked to work well with the MSAN I am connected to which I am told (via Zen ISP) is a Huwawei HWE/HM/CMSAN/2625. These tweaks are cummulative so the next public firmware release should have these changes.

I have just checked the Cisco site and the latest firmware for the 877 is 4.0.17. The TAC said they generally release new firmware either after a major problem or after they accumulate a number of smaller issues. So I guess if you want to try the new firmware you will need to contact Cisco TAC and request it. Whether that requires a support contract I am not sure.

The speed is also now as good as other cheaper routers that did not have these issues (Broadcom based) such as a Thomson 585 v7 and a 3com officeconnect adsl wireless 11g (3CRWDR200A-75)

Many thanks to Cisco Support

sh dsl int atm0
ATM0
Alcatel 20190 chipset information
                ATU-R (DS)                      ATU-C (US)
Modem Status:    Showtime (DMTDSL_SHOWTIME)
DSL Mode:        ITU G.992.5 (ADSL2+) Annex A
ITU STD NUM:     0x03                            0x2
Chip Vendor ID:  'STMI'                          'IFTN'
Chip Vendor Specific:  0x0000                    0x71B9
Chip Vendor Country:   0x0F                      0xB5
Modem Vendor ID: 'CSCO'                          '    '
Modem Vendor Specific: 0x0000                    0x0000
Modem Vendor Country:  0xB5                      0x00
Serial Number Near:    FCZ111820BS
Serial Number Far:
Modem VerChip ID:        C196 (0)
DFE BOM:         DFE3.0 Annex A (1)
Capacity Used:   98%                             99%
Noise Margin:    10.5 dB                          6.5 dB
Output Power:    20.0 dBm                        13.0 dBm
Attenuation:     25.5 dB                         11.0 dB
FEC ES Errors:   1512                             0
ES Errors:       62                               0
SES Errors:      61                               0
LOSES Errors:    61                               0
UES Errors:      58                              13
Defect Status:   None                            None
Last Fail Code:  None
Watchdog Counter: 0x0B
Watchdog Resets: 0
Selftest Result: 0x00
Subfunction:     0x00
Interrupts:      42184 (0 spurious)
PHY Access Err:  0
Activations:     72
LED Status:      ON
LED On Time:     100
LED Off Time:    100
Init FW:         init_AMR_4.0.195.bin
Operation FW:    AMR-E-4.0.195.bin
FW Source:       external
FW Version:      4.0.195

                 DS Channel1      DS Channel0   US Channel1       US Channel0
Speed (kbps):             0            12952             0              1266
Cells:                    0         86854626             0         369594520
Reed-Solomon EC:          0                0             0                 0
CRC Errors:               0                4             0                 0
Header Errors:            0                4             0                 0
Total BER:                0E-0           1114E-12
Leakage Average BER:      0E-0           1384E-12
Interleave Delay:         0               42             0                18
                        ATU-R (DS)      ATU-C (US)
Bitswap:               enabled            enabled
Bitswap success:          0                   0
Bitswap failure:          0                   0

LOM Monitoring : Disabled


DMT Bits Per Bin
000: 0 0 0 0 0 0 4 7 9 A C C D D E F
010: F F F F F F F F F F F F F F E E
020: 0 2 3 3 5 7 5 7 8 9 9 9 A B B B
030: C C C D D D D D D D E E E E E E
040: E E 0 0 0 0 0 E E E E E E E E E
050: E D D D D D D D D 2 D D D D D D
060: D D D D D D D D D D C D D D 0 D
070: D D D C C D D C C C C C C 2 2 0
080: 2 2 C C C C C C C C C C C C C C
090: C C C C B C C C C C C C C C B C
0A0: B B C B B B C C B B B B B B B B
0B0: B B B B B B B B B B B B 0 B B 0
0C0: 5 A B B B B B B B B B B B B B B
0D0: B A A 7 A A B B B B B B B B B B
0E0: A B B B B B B A B A A A A A A A
0F0: A A 9 0 2 7 9 A A A A A A 9 A B
100: A A A A A A A 9 A A A A A A A A
110: A 9 9 9 8 5 4 5 8 9 9 A A A A A
120: A A 9 0 A A 9 A A A A A A A A A
130: A A A A A A A 8 A A 9 4 9 9 9 8
140: 9 9 A 9 9 9 9 9 9 9 7 9 9 9 5 9
150: 9 8 6 7 2 6 8 8 8 8 7 8 0 9 9 9
160: 8 8 9 8 9 9 8 5 8 8 8 8 8 8 8 8
170: 8 8 8 8 8 8 8 8 8 8 8 8 8 8 8 8
180: 8 8 8 8 8 8 8 8 8 8 8 8 8 7 7 7
190: 7 7 7 7 7 7 7 7 7 7 7 7 7 7 0 0
1A0: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
1B0: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
1C0: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
1D0: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
1E0: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
1F0: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

DSL: Training log buffer capability is not enabled

New Member

Well done James and Cisco Support.

This has taken a very long time to resolve (posted Oct 2009)

Lets hope Cisco reallise its in their interest to post this file for public access!

IanC

New Member

Wonderful to hear this is finally fixed!

New Member

All, thanks for the further updates on this.

From our view we are experiencing greater stability with .018 firmware on a number of 857's and 877's connected across the county.

We are to start evaluation of an Annex-M service using a Cisco 1841 with HWIC-1ADSL-M interface.

The initial observation is one of good (but variable) sync speed from 2300 to 2447 on the upstream. Less interesting is the 17Mbps downstream sync.

More relevant it would seem is the number of CRC errors on the upstream (virtually NIL) as compared to the disproportionately high number on the downstream. This is indicative of a connection that will prove to be unstable.

We have learned that the Dslam profile can be tuned siginficantly by a suitably supportive service provider.

One qu. is whether (and mileage may again vary between service provider) we can have the upstream characteristics unchanged, but perhaps have the downstream tuned such that CRC error count is reduced even at the expense of downstream bandwidth.

Thanks. Graham

New Member

Graham

Please note included in the trail above that when connecting to INFN Infineon MSAN equipment 018 doesn't behave above about 9Mb download speed.

As others have noted that if you connecting to other MSAN kit there's no problem, but its a lottery as to which MSAN you get.

IanC

New Member

James

Recent update

In the last few weeks it would appear BT have done something to the Infineon MSAN on my local exchange (BALham).  I guess there's been a firmware update.  The result is 4.0.195 is no longer stable.

Regards

IanC

New Member

Hi Ian,

I have given up on the cisco 877, the disconnects were becoming more and more regular.
In the meantime I have reverted back to using a thomson speedtouch 585v7 which has been very stable.

In the last fortnight I have moved from Zen (BT) to AAISP (BE LLU). I gave the 877 another chance as I am now connected to a broadcom MSAN, but it soon started disconnecting and I have stopped using it since.

The new 877 replacement model 887VA look promising as cisco seem to be moving away from the st micro to a broadcom based chipset.

http://www.cisco.com/en/US/prod/collateral/routers/ps380/data_sheet_c78-613481.html


James

New Member

James:

Mine randomly behaves sketchily as well as of late, and seemingly right out of the blue. I ended up switching back to using the ISP provided Comtrend modem (OCCAM), which is the same brand as their DSLAM.

New Member

We are also having similar problems and not getting anywhere fast - Cisco don't seem interested, our ISP aren't much good and BT just blame the Cisco routers and land us with call-out charges for their site visits!

As per previous discussions on this thread, we have alleviated the issues by installing the 4.0.195 firmware and "fixing" the DSL mode to "adsl2+" rather than "auto" and while this does seem to help greatly, it certainly hasn't eradicated the problems completely. 

It's becoming very frustrating - if you look at when this thread started, it was back in 2009 yet still problems are being experienced.

Does anyone have any further suggestions on how to make inroads into this issue?

New Member

Guys

We just had an update from our Cisco SE who confirmed that the 887VA has indeed ditched the STMicro chipset due to firmware issues.  Also note there is a new firmware update for 877 to be used with AnnexM in the UK.

New Member

Well i have been reading this with interest im in Perth Australia and am having the same issues you guys are. i was using it before with big issues one it wouldnt even connect at adsl2+ speeds always adsl1 and unstable and now with firware upgrades it finally connected higher speed then the crappy billion modem but then bombed out over night again im going to try the 4.10.9 firmware for some reason i ddint see there before its not in latest releases but is in the 4 folder see if this helps here but seems its not just the UK having all these issues as mentioned before it seems amazing that a expensive (well cheap model) Cisco router cant deal with something a 20 dollar special can.

ill keep u posted on the new firmware

New Member

Ian any idea where can I get the AMR-E-4.0.195.bin? I'd like to test it on a customer site.

Does anyone know if there is a later  more stable release?  My Customer is using Cisco 1841 with a HWIC-1ADSL-M on Infineon DSLAM in the UK.

Regards,

Andy

New Member

WE are having th same issue as above.

Tried AMR-E-4.0.18.bin firmware...as suggested by BT.

Can anyone send me the link for AMR-E-4.0.195.bin or a later versions.

Will try anything at the moment.

Really need an answer from Cisco if a fix is available, I would log this with TAC but dont have an account

Rgds

Garry

New Member

Garry

4.0.195 is relatively stable, though slow, and still not perfect.

I suspect that Cisco have an issue with the ADSL hardware that cannot be truly fixed with firmware.

I think that the later routers (eg 887) and WICs have new hardware that overcomes the problem,

But I haven't used any of these in the wild.

IanC

New Member

Ian.

Thanks for the reply...can you point me in the right direction for the firmware.

Rgds

Garry

New Member

I'll pull it off one of the 877 routers email me; yelwoci-at-yahoo.....co.uk

New Member

Hello All,

I'm seeing the same issue on a number of 877 installs we've made here in the UK and there is a version 223 update available.  There is a marginal improvement on stability and speed but I stress marginal as BT's DSL migration and Cisco is still a concerning combination.

DFE BOM:         DFE3.0 Annex A (1)

Capacity Used:   85%                             99%

Noise Margin:    17.5 dB                         12.0 dB

Output Power:    17.0 dBm                        12.0 dBm

Attenuation:     31.0 dB                         16.0 dB

FEC ES Errors:   358798                           0

ES Errors:       64163                           42482

SES Errors:      1670                            3474

LOSES Errors:    26                               1

UES Errors:      58                              200987

Defect Status:   None                            None

Last Fail Code:  None

Watchdog Counter: 0xF4

Watchdog Resets: 0

Selftest Result: 0x00

Subfunction:     0x00

Interrupts:      8350 (0 spurious)

PHY Access Err:  0

Activations:     4

LED Status:      ON

LED On Time:     100

LED Off Time:    100

Init FW:         init_AMR_4.0.223.bin

Operation FW:    AMR-E-4.0.223.bin

FW Source:       external

FW Version:      4.0.223

New Member

Thanks for the info on the new 4.0.223 firmware release - have managed to obtain it through our Cisco partner so will give it a go to see if it leads to any improvement!

New Member

I had similar problem.

I added

TX-RING-LIMIT 3

under th PVC section.

Worked for me..

http://www.problutions.com/?auther=1

scroll to the bottom.....

New Member

Is this one of the longest-running threads on the forums?

I have an 877W with the same problems. It was rock solid for 18 months when used with ADSL Max ("up to 8Mb") service. I'm lucky to live in a newly built street not far from the BT exchange with shiny new cabling all the way, and was reliably getting a perfect 8Mb down/832Kb up all the time.

But then I asked my ISP (PlusNet) to upgrade me to ADSL2+ Annex M.

Initially it connected at 12M down, 3M up. Nice. Then within hours the frequent disconnects had BT knocking the speed down, and down, and down, so I was on 4Mb down/512k up,

I'm on firmware 3.0.33, I tried 4.0.18 but it was no better (possibly worse). I just bought a SmartNet contract for this router to get TAC access to obtain the more exotic releases mentioned in this thread to see if they help.

Copying the .bin file to flash (renamed appropriately) and rebooting doesn't always seem to cause the firmware to be loaded though - sometimes it loads, sometimes a "sho dsl int atm0" says it's using the 3.0.33 included in the IOS.

As others have mentioned, it's highly frustrating that a high end router (as home routers go) has such problems when a £30 Linksys device seems to cope better!

New Member

I had the same issue over a year ago.  I managed to fix this by changing the TX-Ring-Limit.

I did this under the ATM0 interface. It has never failed since.

interface ATM0

no ip address

no ip mroute-cache

logging event atm pvc state

logging event atm pvc autoppp

atm vc-per-vp 64

no atm ilmi-keepalive

pvc 0/38

  tx-ring-limit 3

  encapsulation aal5mux ppp dialer

  dialer pool-member 1