Cisco Support Community

User is unable to upgrade CatOS to version 5.4 or later releases on Supervisor Engine I or IA due to an unsupported boot ROM version

Core issue

A hardware boot ROM upgrade might be required to upgrade the Catalyst OS (CatOS) on a Supervisor Engine I or IA.


The Supervisor Engine I or IA requires a minimum boot ROM of 5.2(1) for software release 5.4(1) and later 5.x(x) releases. The minimum boot ROM required for software releases 6.x(x) and later is 5.2(1).

To verify the current boot ROM version, issue the show version command.

This is the sample command output:

Console> (enable) show version
WS-C6009 Software, Version NmpSW:5.3(1)CSX
Copyright (c) 1995-1999 by Cisco Systems
NMP S/W compiled on Apr 8 1999, 11:35:52
System Bootstrap Version:5.1(1)
Hardware Version:0.215 Model:WS-C6000 Serial #:001905894

Mod Port Model               Serial        Versions
--- ---- ------------------- -----------   ------------------
1    2   WS-X6K-SUP1-2GE      SAD03040546   Hw :1.4

Fw :5.1(1)
Sw :5.3(1)CSXSw1:5.3(1)CSX
Console> (enable)

In this example, the boot ROM version is 5.1(1).

To upgrade the boot ROM on a Catalyst 6000 Supervisor Engine I or IA, choose from one of these options:

  • For supervisor engines with a Multilayer Switch Feature Card (MSFC), due to the location of the boot ROM, upgrading the boot ROM could damage your supervisor engine. This hardware configuration is not field upgradeable.
  • For supervisor engines with an MSFC2 or no Policy Feature Card (PFC), the boot ROM upgrade can be done in the field.

    The boot ROM upgrade kit part number is WS-X6K-BOOT=.

    For additional information on how to obtain an upgraded boot ROM and replacement procedures, refer toCatalyst 6000 Family Supervisor Engine 1 and 1A NMP Boot ROM Upgrade Installation Note.