Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

X2-10GB-LRM vs X2-10GB-SR compatability

Hi all,

We have 6509E switches & we have used WS-X6708-10GE module in 9th slots of the switch. We are trying to connect the Fiber link between two ports.

When we trying to connect the link between two ports haveing same transceiver X2-10GB-LRM the link came up.

But when we connect the link between different transceiver X2-10GB-LRM & X2-10GB-SR the link didn't came up.

If I see 10gb module compatabiltiy where both are supported.

Please reply why the link is not came up between transceiver X2-10GB-LRM & X2-10GB-SR.??

Also the laser light is not seen in the trasceiver X2-10GB-LRM. where on the same module the laser light is able seen on transceiver X2-10GB-SR.

Please reply why this happen??

why the link is not came up between transceiver X2-10GB-LRM & X2-10GB-SR.?? &

Why the laser light is not seen in the transceiver X2-10GB-LRM..???


Version history
Revision #:
1 of 1
Last update:
‎06-05-2013 03:14 AM
Updated by:
 
Labels (1)
Everyone's tags (1)
Comments
New Member

Hello,

The problem you are experiencing is a compatiability issue.

The optical fiber modules must be the same part, you are using in both ends different modules and this is not good, this is why the links doesnt come up.

These are some tech specs I have found for each module:

The Cisco 10GBASE-SR Module supports a link length of 26m on standard FDDI grade MMF. Using 2000 MHz*km MMF (OM3), up to 300m link lengths are possible. Using 4700 MHz*km MMF (OM4), up to 400m link lengths are possible

The Cisco 10GBASE-LRM Module supports link lengths of 220m on standard Fiber Distributed Data Interface (FDDI) grade multimode fiber (MMF). To ensure that specifications are met over FDDI-grade, OM1 and OM2 fibers, the transmitter should be coupled through a mode conditioning patch cord.

New Member

Also noticed that XENPAK and X2 of the same type (for example, XENPAK SR and X2 SR) can be connected to each other.

So you can use the model XENPAK-10GB-SR along with X2-10GB-SR

New Member

Hi Diego,

As per the datasheet this is showing that these modules are supported. Is there you have any strong document where it mention that the different module will not work.?

New Member

What IOS are running on this device?

Are you getting any type of error messages or logs?

I will look further for the article

Regards,

New Member

Hello Yogesh,

The problem is that the wavelength for both modules is different, 10GBASE-SR is 26m on standard FDDI grade MMF and 10GBASE-LRM is 220m on standard Fiber Distributed Data Interface (FDDI) so they are communicating in different speeds.

No matter the part number or brand, it's just that the waveleght in fiber alwways have to be the same.

Let me know if this helped you

New Member

Hi Diego,

Thanks for you reply, the system is currently running with the s72033-ipservicesk9_wan-mz.122-18.SXF10.bin image.

New Member

These modules support a minimun version of 12.2(33)SRE but I believe it's more a problem with the waveleght.

Hope this helped

New Member

similar issue here.....WS-X6704-10GE is the switch module on WS-C6509-E:

Switch:                           WS-C6509-E

Supervisor:                     WS-SUP720-3B

IOS:                               adventerprisek9_wan-mz.122-33.SXH8b.bin

Switch Module:               WS-X6704-10GE

Fiber Module:                  XENPAK-10GB-LRM

this XENPAK-10GB-LRM is not showing the laser light and not getting the status light green.. if port is shut the status light is amber...also these modules are listed in 'show inventory'

(NB: XENPAK-10GB-SR is working fine)


New Member

Not to revive a really old thread, but just wanted to give you a heads up yogesh, in case you haven't discovered this information already.

Whenever you have an optical transmission system, all signal attributes need to match on both ends of the system. This means that both transceivers need to be of the same "flavor" so-to-speak, so they can communicate with one another.

For the modules that you mentioned, the X2-10GB-LRM is a 10GBASE-LRM standard-based optical module that transmits signals at a wavelength of 1310nm, while the X2-10GB-SR is a 10GBASE-SR standard-based optical module that transmits signals at a wavelength of 850nm. This means that these two modules can't even detect/see each other, since they communicate on absolutely orthogonal wavelengths.

Even if you connect two modules that communicate over the same wavelengths (e.g. LR and LRM both at 1310nm) they still won't be able to communicate since they have different modal bandwidths, as well as different modulation schemes. I have even seen cases where two transceivers of the same standard failed to communicate, simply because they were produced by different manufacturers.

As for the fact that they are both supported modules, yes they are supported, but not together. This is a foundational premise in all optical communication systems, you always need to match the transceivers to be on the same "mode", i.e. SR, LR, LRM, etc. So as per the product documentation, the WS-X6708-10GE can support having X2-10GB-LRM installed in it, or X2-10GB-SR installed in it, but this also implies that what you have on the other end of the fiber optic cable is of the same transceiver that you installed in your WS-X6708-10GE.

I hope this information sheds some light on this whole issue for you.