cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2109
Views
5
Helpful
23
Replies

2811 Router-QOS with BT RADMUX

fathar
Level 1
Level 1

Hi Guys,

I am connecting two WAN Sites A & B via 4Mb Metro ethernet connection. On Site A, FE0/0 is connected to Site B. FE0/1 is connected to user PC and F0/2 is connected to BT RADMUX Voice system which is communicating with another BT RADMUX at Site B. Now customer want to make sure that this 4mb BW is distributed evenly b/w PC at F0/2 and BT RADMUX at F0/3. What is the best qos strategy to use to guarentee 2MB BW for each connection? ALso please let me know if there is any special settings to be required on router for BT RADMUX VOice system as I am not able to get good quality voice at the moment.

Many Thanks

23 Replies 23

pkhatri
Level 11
Level 11

Hello,

You initially mentioned that the PC was connected to Fe0/1 and the RADMUX to Fe0/2. But later you stated that the PC was connected to Fe0/2 and the RADMUX to Fe0/3. I've used the first set of ports in my config below - change them if they are not correct.

In order to distribute traffic evenly between the PC and RADMUX, you could use the following:

class-map RADMUX

match input-interface FastEthernet0/2

!

policy-map PolOut

class RADMUX

priority 2000

!

policy-map Shaper

class class-default

shape average 4000000

service-policy PolOut

!

interface FastEthernet0/0

service-policy output Shaper

You will also need to apply a similar policy to the fastethernet interface at the other end...

This policy will do the following:

- it will give priority to your RADMUX traffic and guarantee it 2Mbps of throughput

- when there is congestion, the RADMUX traffic will be limited to 2Mbps, leaving the other 2Mbps for your PC traffic.

- when there is no congestion, either of the RADMUX or PC traffic can use the excess bandwidth.

- you will find that with this setup, the latency/jitter for your voice traffic is likely to improve as well.

If you want to set a hard limit on the RADMUX traffic so that it does not exceed 2Mbps even if there is no congestion, use the following policy to replace the PolOut policy above:

policy-map PolOut

class RADMUX

police 2000000

priority 2000

!

Hope that helps - pls rate posts that help.

Regards,

Paresh

fathar
Level 1
Level 1

Thanks for the response Paresh.Sorry for making confusion in FE numbering.

I will apply the config tomorrow and will post the outcome.

Cheers

Hi ,

You mentioned to apply the same service policy at other side Router B. However problem is that on other side RADMUX is not connected to device itself. Instead RADMUX is connected to switch, which is connected to Site B Router.how should the policy be applied in such case?

Thanks

Hi,

In that case, you need to use some mechanism that will uniquely identify the RADMUX traffic. Does all traffic from the RADMUX have a specific IP address ?

If so, let me know and I can tell you how to modify the config to suit that...

Pls do rate posts that help.

Regards,

Paresh.

yeah thats right. Both Sites BT Devices have got IP addresses 10.90.1.1 and 10.80.1.1.

Thanks

Hi,

Then you can use the following:

class-map RADMUX

match access-group 10

!

policy-map PolOut

class RADMUX

priority 2000

!

policy-map Shaper

class class-default

shape average 4000000

service-policy PolOut

!

interface FastEthernet0/0

service-policy output Shaper

!

access-list 10 permit 10.90.1.1 ! use this for one of the sites

access-list 10 permit 10.80.1.1 ! use this for the other site

Hope that helps - pls rate the post if it does.

Paresh

Thanks. I have implement that but user still complaining of breaking in voice. Voice works fine alone but as soon as other data traffic comes on circuit(no matter how much) voice starts getting problem.seems to me that router is not handling Voice traffic as it should.The voice traffic is REAL time and not Streaming.

Just to reconfirm that access-list should include source IP. i.e access-list implemented at site-A shoud have the IP Address of BT system at SIte A and so on..

Just to add on that I am using 2811 ROuter. PC is connected to F0/1 which is Router FE port. However voice is connected to F0/0/0 port(4 pot wic) which is actually a switch port so I have to configure a vlan ID on that and include that vlan20 into routing.

not sure if it makes any difference ..

Is there any better alternative?

Thanks

Thanks. I have implement that but user still complaining of breaking in voice. Voice works fine alone but as soon as other data traffic comes on circuit(no matter how much) voice starts getting problem.seems to me that router is not handling Voice traffic as it should.The voice traffic is REAL time and not Streaming.

Just to reconfirm that access-list should include source IP. i.e access-list implemented at site-A shoud have the IP Address of BT system at SIte A and so on..

Just to add on that I am using 2811 ROuter. PC is connected to F0/1 which is Router FE port. However voice is connected to F0/0/0 port(4 pot wic) which is actually a switch port so I have to configure a vlan ID on that and include that vlan20 into routing.

not sure if it makes any difference ..

Is there any better alternative?

Thanks

Hi,

I believe the idea is right for you...we may just not be matching on the right traffic. Could you get me the output of 'sh policy-map interface fast0/0' with this policy in place ?

Thanks,

Paresh

#sh policy-map interface fastEthernet 0/0

FastEthernet0/0

Service-policy output: Shaper

Class-map: class-default (match-any)

2281923 packets, 1193356941 bytes

5 minute offered rate 967000 bps, drop rate 0 bps

Match: any

Traffic Shaping

Target/Average Byte Sustain Excess Interval Increment

Rate Limit bits/int bits/int (ms) (bytes)

4000000/4000000 25000 100000 100000 25 12500

Adapt Queue Packets Bytes Packets Bytes Shaping

Active Depth Delayed Delayed Active

- 0 2281925 1193357531 7 7351 no

Service-policy : PolOut

Class-map: RADMUX (match-all)

2264992 packets, 1191383732 bytes

5 minute offered rate 964000 bps, drop rate 0 bps

Match: access-group 10

Queueing

Strict Priority

Output Queue: Conversation 136

Bandwidth 2000 (kbps) Burst 50000 (Bytes)

(pkts matched/bytes matched) 2/1052

(total drops/bytes drops) 0/0

Class-map: class-default (match-any)

16932 packets, 1973209 bytes

5 minute offered rate 2000 bps, drop rate 0 bps

Match: any

Hmmm...that looks like the classifier is working. Also, were you experiencing any problems with the voice at the point in time that you took this capture ? It's just that there was no congestion happening at that point in time so the queueing wasn't doing much at all... Are you absolutely sure that the voice is working fine when there is no data traffic on the link.

Are you absolutely sure that there is no data traffic coming from those 2 IP addresses you mentioned ? If so, we might have to get a bit more granular...

Paresh

There is no data service running at the time of capture. May be I will capture the output again tomorrow when both data and voice services be used together.User confirmed no problem with voice when running alone.

Its BT Device sending VOICE only so I dnt expect any data packets. Also I beleive that we have set policy on Source IP addresses, means everything coming from this IP is prioritized so even if data is part of that communication , should it not be prioritized as well?

Should we look into further deep on port basis?

Thanks

What I meant was.. if there is data traffic coming from those addresses, that will indeed get prioritised together with the voice traffic which you do not necessarily want.

I would like to see the above output when you have data traffic on the link as well...

Paresh

Hi mate,

Here is the current output with data running.

sh policy-map interface fastEthernet 0/0

FastEthernet0/0

Service-policy output: Shaper

Class-map: class-default (match-any)

16414221 packets, 8578233312 bytes

5 minute offered rate 972000 bps, drop rate 0 bps

Match: any

Traffic Shaping

Target/Average Byte Sustain Excess Interval Increment

Rate Limit bits/int bits/int (ms) (bytes)

4000000/4000000 25000 100000 100000 25 12500

Adapt Queue Packets Bytes Packets Bytes Shaping

Active Depth Delayed Delayed Active

- 0 16414251 4283281334 121 91437 no

Service-policy : PolOut

Class-map: RADMUX (match-all)

16281810 packets, 8564230000 bytes

5 minute offered rate 964000 bps, drop rate 0 bps

Match: access-group 10

Queueing

Strict Priority

Output Queue: Conversation 136

Bandwidth 2000 (kbps) Burst 50000 (Bytes)

(pkts matched/bytes matched) 49/25774

(total drops/bytes drops) 0/0

Class-map: class-default (match-any)

132411 packets, 14002786 bytes

5 minute offered rate 7000 bps, drop rate 0 bps

Match: any