Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

2811 Router-QOS with BT RADMUX

Hi Guys,

I am connecting two WAN Sites A & B via 4Mb Metro ethernet connection. On Site A, FE0/0 is connected to Site B. FE0/1 is connected to user PC and F0/2 is connected to BT RADMUX Voice system which is communicating with another BT RADMUX at Site B. Now customer want to make sure that this 4mb BW is distributed evenly b/w PC at F0/2 and BT RADMUX at F0/3. What is the best qos strategy to use to guarentee 2MB BW for each connection? ALso please let me know if there is any special settings to be required on router for BT RADMUX VOice system as I am not able to get good quality voice at the moment.

Many Thanks

23 REPLIES
Purple

Re: 2811 Router-QOS with BT RADMUX

Hello,

You initially mentioned that the PC was connected to Fe0/1 and the RADMUX to Fe0/2. But later you stated that the PC was connected to Fe0/2 and the RADMUX to Fe0/3. I've used the first set of ports in my config below - change them if they are not correct.

In order to distribute traffic evenly between the PC and RADMUX, you could use the following:

class-map RADMUX

match input-interface FastEthernet0/2

!

policy-map PolOut

class RADMUX

priority 2000

!

policy-map Shaper

class class-default

shape average 4000000

service-policy PolOut

!

interface FastEthernet0/0

service-policy output Shaper

You will also need to apply a similar policy to the fastethernet interface at the other end...

This policy will do the following:

- it will give priority to your RADMUX traffic and guarantee it 2Mbps of throughput

- when there is congestion, the RADMUX traffic will be limited to 2Mbps, leaving the other 2Mbps for your PC traffic.

- when there is no congestion, either of the RADMUX or PC traffic can use the excess bandwidth.

- you will find that with this setup, the latency/jitter for your voice traffic is likely to improve as well.

If you want to set a hard limit on the RADMUX traffic so that it does not exceed 2Mbps even if there is no congestion, use the following policy to replace the PolOut policy above:

policy-map PolOut

class RADMUX

police 2000000

priority 2000

!

Hope that helps - pls rate posts that help.

Regards,

Paresh

New Member

Re: 2811 Router-QOS with BT RADMUX

Thanks for the response Paresh.Sorry for making confusion in FE numbering.

I will apply the config tomorrow and will post the outcome.

Cheers

New Member

Re: 2811 Router-QOS with BT RADMUX

Hi ,

You mentioned to apply the same service policy at other side Router B. However problem is that on other side RADMUX is not connected to device itself. Instead RADMUX is connected to switch, which is connected to Site B Router.how should the policy be applied in such case?

Thanks

Purple

Re: 2811 Router-QOS with BT RADMUX

Hi,

In that case, you need to use some mechanism that will uniquely identify the RADMUX traffic. Does all traffic from the RADMUX have a specific IP address ?

If so, let me know and I can tell you how to modify the config to suit that...

Pls do rate posts that help.

Regards,

Paresh.

New Member

Re: 2811 Router-QOS with BT RADMUX

yeah thats right. Both Sites BT Devices have got IP addresses 10.90.1.1 and 10.80.1.1.

Thanks

Purple

Re: 2811 Router-QOS with BT RADMUX

Hi,

Then you can use the following:

class-map RADMUX

match access-group 10

!

policy-map PolOut

class RADMUX

priority 2000

!

policy-map Shaper

class class-default

shape average 4000000

service-policy PolOut

!

interface FastEthernet0/0

service-policy output Shaper

!

access-list 10 permit 10.90.1.1 ! use this for one of the sites

access-list 10 permit 10.80.1.1 ! use this for the other site

Hope that helps - pls rate the post if it does.

Paresh

New Member

Re: 2811 Router-QOS with BT RADMUX

Thanks. I have implement that but user still complaining of breaking in voice. Voice works fine alone but as soon as other data traffic comes on circuit(no matter how much) voice starts getting problem.seems to me that router is not handling Voice traffic as it should.The voice traffic is REAL time and not Streaming.

Just to reconfirm that access-list should include source IP. i.e access-list implemented at site-A shoud have the IP Address of BT system at SIte A and so on..

Just to add on that I am using 2811 ROuter. PC is connected to F0/1 which is Router FE port. However voice is connected to F0/0/0 port(4 pot wic) which is actually a switch port so I have to configure a vlan ID on that and include that vlan20 into routing.

not sure if it makes any difference ..

Is there any better alternative?

Thanks

New Member

Re: 2811 Router-QOS with BT RADMUX

Thanks. I have implement that but user still complaining of breaking in voice. Voice works fine alone but as soon as other data traffic comes on circuit(no matter how much) voice starts getting problem.seems to me that router is not handling Voice traffic as it should.The voice traffic is REAL time and not Streaming.

Just to reconfirm that access-list should include source IP. i.e access-list implemented at site-A shoud have the IP Address of BT system at SIte A and so on..

Just to add on that I am using 2811 ROuter. PC is connected to F0/1 which is Router FE port. However voice is connected to F0/0/0 port(4 pot wic) which is actually a switch port so I have to configure a vlan ID on that and include that vlan20 into routing.

not sure if it makes any difference ..

Is there any better alternative?

Thanks

Purple

Re: 2811 Router-QOS with BT RADMUX

Hi,

I believe the idea is right for you...we may just not be matching on the right traffic. Could you get me the output of 'sh policy-map interface fast0/0' with this policy in place ?

Thanks,

Paresh

New Member

Re: 2811 Router-QOS with BT RADMUX

#sh policy-map interface fastEthernet 0/0

FastEthernet0/0

Service-policy output: Shaper

Class-map: class-default (match-any)

2281923 packets, 1193356941 bytes

5 minute offered rate 967000 bps, drop rate 0 bps

Match: any

Traffic Shaping

Target/Average Byte Sustain Excess Interval Increment

Rate Limit bits/int bits/int (ms) (bytes)

4000000/4000000 25000 100000 100000 25 12500

Adapt Queue Packets Bytes Packets Bytes Shaping

Active Depth Delayed Delayed Active

- 0 2281925 1193357531 7 7351 no

Service-policy : PolOut

Class-map: RADMUX (match-all)

2264992 packets, 1191383732 bytes

5 minute offered rate 964000 bps, drop rate 0 bps

Match: access-group 10

Queueing

Strict Priority

Output Queue: Conversation 136

Bandwidth 2000 (kbps) Burst 50000 (Bytes)

(pkts matched/bytes matched) 2/1052

(total drops/bytes drops) 0/0

Class-map: class-default (match-any)

16932 packets, 1973209 bytes

5 minute offered rate 2000 bps, drop rate 0 bps

Match: any

Purple

Re: 2811 Router-QOS with BT RADMUX

Hmmm...that looks like the classifier is working. Also, were you experiencing any problems with the voice at the point in time that you took this capture ? It's just that there was no congestion happening at that point in time so the queueing wasn't doing much at all... Are you absolutely sure that the voice is working fine when there is no data traffic on the link.

Are you absolutely sure that there is no data traffic coming from those 2 IP addresses you mentioned ? If so, we might have to get a bit more granular...

Paresh

New Member

Re: 2811 Router-QOS with BT RADMUX

There is no data service running at the time of capture. May be I will capture the output again tomorrow when both data and voice services be used together.User confirmed no problem with voice when running alone.

Its BT Device sending VOICE only so I dnt expect any data packets. Also I beleive that we have set policy on Source IP addresses, means everything coming from this IP is prioritized so even if data is part of that communication , should it not be prioritized as well?

Should we look into further deep on port basis?

Thanks

Purple

Re: 2811 Router-QOS with BT RADMUX

What I meant was.. if there is data traffic coming from those addresses, that will indeed get prioritised together with the voice traffic which you do not necessarily want.

I would like to see the above output when you have data traffic on the link as well...

Paresh

New Member

Re: 2811 Router-QOS with BT RADMUX

Hi mate,

Here is the current output with data running.

sh policy-map interface fastEthernet 0/0

FastEthernet0/0

Service-policy output: Shaper

Class-map: class-default (match-any)

16414221 packets, 8578233312 bytes

5 minute offered rate 972000 bps, drop rate 0 bps

Match: any

Traffic Shaping

Target/Average Byte Sustain Excess Interval Increment

Rate Limit bits/int bits/int (ms) (bytes)

4000000/4000000 25000 100000 100000 25 12500

Adapt Queue Packets Bytes Packets Bytes Shaping

Active Depth Delayed Delayed Active

- 0 16414251 4283281334 121 91437 no

Service-policy : PolOut

Class-map: RADMUX (match-all)

16281810 packets, 8564230000 bytes

5 minute offered rate 964000 bps, drop rate 0 bps

Match: access-group 10

Queueing

Strict Priority

Output Queue: Conversation 136

Bandwidth 2000 (kbps) Burst 50000 (Bytes)

(pkts matched/bytes matched) 49/25774

(total drops/bytes drops) 0/0

Class-map: class-default (match-any)

132411 packets, 14002786 bytes

5 minute offered rate 7000 bps, drop rate 0 bps

Match: any

Purple

Re: 2811 Router-QOS with BT RADMUX

Good morning...

So are you experiencing poor voice comms at the moment ? From what I can see, there is no congestion on the link as such...

Paresh

Purple

Re: 2811 Router-QOS with BT RADMUX

Hi,

It appears as if the router is not the issue here. You mentioned that there was a switch at the second site. There is a possibility that the switch is the issue here. What sort of switch is it ?

Paresh

New Member

Re: 2811 Router-QOS with BT RADMUX

Yeah Site B is using Cisco Swith 4506. BT Voice system is connected to one of FE port on this switch. The switch connects with SIte B Router, which is connected with SIte A router on F0/0 interface.

Cheers

Purple

Re: 2811 Router-QOS with BT RADMUX

Is there any chance you could post the switch config for those 2 ports ?

Also, is the voice perfectly clean with no data present ?

Paresh.

New Member

Re: 2811 Router-QOS with BT RADMUX

Hi Paresh,

Configs below as requested.Yes user claim that voice is clear when use alone.

Many thanks for your support.

Cheers

SITE B ROUTER:

interface GigabitEthernet0/3

desc 4 mb Metro ethernet to Site A

ip address..

no ip redirects

ip pim sparse-mode

duplex full

speed auto

service-policy output shaper

#sh policy-map interface gigabitEthernet 0/3

GigabitEthernet0/3

Service-policy output: Shaper

Class-map: class-default (match-any)

21498828 packets, 10955737425 bytes

5 minute offered rate 1173000 bps, drop rate 0 bps

Match: any

Traffic Shaping

Target/Average Byte Sustain Excess Interval Increment

Rate Limit bits/int bits/int (ms) (bytes)

4000000/4000000 25000 100000 100000 25 12500

Adapt Queue Packets Bytes Packets Bytes Shaping

Active Depth Delayed Delayed Active

- 0 21432631 2317875901 184786 127267321 no

Service-policy : PolOut

Class-map: RADMUX (match-all)

19689385 packets, 10356614450 bytes

5 minute offered rate 1036000 bps, drop rate 0 bps

Match: access-group 10

Queueing

Strict Priority

Output Queue: Conversation 136

Bandwidth 2000 (kbps) Burst 50000 (Bytes)

(pkts matched/bytes matched) 58682/30866732

(total drops/bytes drops) 0/0

Class-map: class-default (match-any)

1809443 packets, 599122975 bytes

5 minute offered rate 136000 bps, drop rate 0 bps

Match: any

SITE B SWITCH:

interface GigabitEthernet3/29

description **BT-RADMUX**

switchport access vlan 25

switchport mode access

speed 100

duplex full

spanning-tree portfast

spanning-tree bpduguard enable

!

sh int g3/29

GigabitEthernet3/29 is up, line protocol is up (connected)

Hardware is Gigabit Ethernet Port, address is 0013.7fe8.f3ac (bia 0013.7fe8.f3

ac)

Description: **BT-RADMUX**

MTU 1500 bytes, BW 100000 Kbit, DLY 10 usec,

reliability 255/255, txload 2/255, rxload 2/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 100Mb/s, link type is auto, media type is 10/100/1000-TX

input flow-control is off, output flow-control is off

ARP type: ARPA, ARP Timeout 04:00:00

Last input 5w5d, output never, output hang never

Last clearing of "show interface" counters 00:26:38

Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 1040000 bits/sec, 237 packets/sec

5 minute output rate 1045000 bits/sec, 240 packets/sec

394336 packets input, 208927714 bytes, 0 no buffer

Received 25 broadcasts (0 multicast)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 input packets with dribble condition detected

399665 packets output, 209390771 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier

0 output buffer failures, 0 output buffers swapped out

New Member

Re: 2811 Router-QOS with BT RADMUX

SITE A Router :

interface FastEthernet0/0

desc 4 Mb Metro ethernet

ip address

ip pim sparse-mode

duplex full

speed auto

service-policy output Shaper

interface FastEthernet0/1

description **Data Lan **

ip address

ip pim sparse-mode

ip cgmp

duplex full

speed 100

!

interface FastEthernet0/0/0

desc **BT RADMUX*

switchport access vlan 25

duplex full

speed 100

!

interface Vlan25

ip address ...

# sh policy-map interface fastEthernet 0/0

FastEthernet0/0

Service-policy output: Shaper

Class-map: class-default (match-any)

18557222 packets, 9689119807 bytes

5 minute offered rate 1042000 bps, drop rate 0 bps

Match: any

Traffic Shaping

Target/Average Byte Sustain Excess Interval Increment

Rate Limit bits/int bits/int (ms) (bytes)

4000000/4000000 25000 100000 100000 25 12500

Adapt Queue Packets Bytes Packets Bytes Shaping

Active Depth Delayed Delayed Active

- 0 18557258 1099202372 121 91437 no

Service-policy : PolOut

Class-map: RADMUX (match-all)

18387110 packets, 9671617800 bytes

5 minute offered rate 1036000 bps, drop rate 0 bps

Match: access-group 10

Queueing

Strict Priority

Output Queue: Conversation 136

Bandwidth 2000 (kbps) Burst 50000 (Bytes)

(pkts matched/bytes matched) 49/25774

(total drops/bytes drops) 0/0

Class-map: class-default (match-any)

170112 packets, 17501481 bytes

5 minute offered rate 6000 bps, drop rate 0 bps

Match: any

Purple

Re: 2811 Router-QOS with BT RADMUX

Could you try changing the Shaper policy so that it looks like:

policy-map Shaper

class class-default

shape average 4000000 16000

service-policy PolOut

Thanks,

Paresh.

New Member

Re: 2811 Router-QOS with BT RADMUX

Its seems that everything is working fine with existing policy..ther was some problem in BT equipmetn which was causing noice problem and has been resolved..Thanks for all your help..you Deserved 5 :)

Purple

Re: 2811 Router-QOS with BT RADMUX

I'm happy to see that your problem has been resolved.

Regards,

Paresh

548
Views
5
Helpful
23
Replies
CreatePlease to create content