Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

6509 not viewable in CiscoView

Hello,

I am currently running CiscoWorks LMS 2.6 which contains CiscoView 6.1.5. (Build Id :NT_CVW6_1_5_INCR_UPDATE_20060901_0601)


CiscoView works fine for all my nodes apart from my 6509s. When I try to access them i get the following error message:


Message
Can't find applicable device package for <ip address>.


Cause
Device package for this device type is not installed or device support for this device type might not be available or you are attempting to open a component inside a device.


Action
Please install a device package for the device type or open the parent device to manage the component.


I have updated the available device packages, and any software updates available. Can anyone help?

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: 6509 not viewable in CiscoView

You're missing the CVGenericPackage.  You should have a CVGenericPackage.zip file in both of the previously mentioned directories.  You should be able to find this package on Cisco.com or from Common Services > Software Center > Device Update.

16 REPLIES
Cisco Employee

Re: 6509 not viewable in CiscoView

What version of the Cat6000IOS package do you have installed?  What is the sysObjectID of this 6500?

New Member

Re: 6509 not viewable in CiscoView

Thanks for the quick response.

sysObjectID is: enterprises.cisco.ciscoProducts.cat6509

How do find the version of Cat6000IOS package?

When I try Common Services/Device Update/Cisco View I get an HTTP Status 500 - Internal Server Error:

java.util.NoSuchElementException

Cisco Employee

Re: 6509 not viewable in CiscoView

It sounds like you may have some map file corruption.  Post the cvw map files under NMSROOT/www/classpath/com/cisco/nm/xms/psu/maps.

New Member

Re: 6509 not viewable in CiscoView

Here they are:

Cisco Employee

Re: 6509 not viewable in CiscoView

These files are corrupt.  This was most likely triggered by CSCsj58812.  While the bug is fixed in Common Services 3.0.6, once the map files are corrupt, they need to be recovered.  The bug workaround lists the steps to do this.

Once the maps are recovered, you should be able to upgrade your installed Cat6000IOS package to 30.2 (along with the related packages).  That should allow you to view your 6500.

New Member

Re: 6509 not viewable in CiscoView

I have tried the workaround in bug CSCsj58812, unfortunately I get the following error when I run the commands:

log4j:ERROR No appenders could be found for category (com.cisco.nm.xms.psu.util.PackageUtils).
log4j:ERROR Please initialize the log4j system properly.

I have tried this with the CW Deamons running and stopped. I still get the java.util.NoSuchElementExceptionerror when I try to access the device packages.

Cisco Employee

Re: 6509 not viewable in CiscoView

This error is normal.  Make sure you delete the two cvw map files before running the command.  If, after doing that, you still get the error in the UI, post all of the map files.

New Member

Re: 6509 not viewable in CiscoView

First of all many thanks for your help so far

The commands have recovered the map files, and I can now see the package information, but the fault still occurs.

I am using the following packages:

Cat6000IOS30.2Cat6000IOS Device Package

I have even deleted this package and downloaded it again, but I still get the error on all four of my 6509s

I have attached the latest map files.

Cisco Employee

Re: 6509 not viewable in CiscoView

Post the list of contents in NMSROOT/MDC/tomcat/webapps/CVng/WEB-INF/classes/com/cisco/nm/cvw/devpkgs and NMSROOT/www/classpath/com/cisco/nm/xms/psu/pkgs/cvw.

New Member

Re: 6509 not viewable in CiscoView

Here they are:

Cisco Employee

Re: 6509 not viewable in CiscoView

To be clear, you are still seeing the error about not finding an applicable package for the device?  If so, post the cv.log.

New Member

Re: 6509 not viewable in CiscoView

Unfortunately the error still occurs whenever I select a 6509. All my other switches are fine:

Message
Can't find applicable device package for p_address>

Cause
Device package for this device type is not  installed or device support for this device type might not be available or you  are attempting to open a component inside a  device.

Action
Please install a device package for the device  type or open the parent device to manage the component.

I have attached the cv.log

Thanks

Cisco Employee

Re: 6509 not viewable in CiscoView

Post the output of "cacls *" from the devpkgs directory as well as the NMSROOT/MDC/tomcat/logs/stdout.log and stderr.log.

New Member

Re: 6509 not viewable in CiscoView

Here you go:

Cisco Employee

Re: 6509 not viewable in CiscoView

You're missing the CVGenericPackage.  You should have a CVGenericPackage.zip file in both of the previously mentioned directories.  You should be able to find this package on Cisco.com or from Common Services > Software Center > Device Update.

New Member

Re: 6509 not viewable in CiscoView

Thats got it working. All my 6509s now display correctly.

Many Thanks

1124
Views
0
Helpful
16
Replies