Cisco Support Community
Community Member

Aironet 350, 1100 IOS Upgrade Error

I have converted Aironet 350 access point from VXWorks to IOS. The current image is 12.2(13)JA1

I am trying to upgrade the IOS image to "c350-k9w7-tar.123-8.JA.tar" thru web browser. But during upgrade I get the error message "The software upgrade was interrupted and was not able to be completed" and on the serial console the error message is "HTTP: error reading file c350-k9w7-tar.123-8.JA.tar

Cisco Employee

Re: Aironet 350, 1100 IOS Upgrade Error

This issue has been seen previously when the IOS image being pushed to the AP has been corrupted. Please download another copy of the code and try again.

Let me know how it goes.


Re: Aironet 350, 1100 IOS Upgrade Error

Hi Avil,

just use the Release notes:

- - - snipp - - -

Note Software upgrades fail when you use the web-browser interface to install Cisco IOS Release 12.3(8)JA on 1200 series access points. The image size exceeds the access point's 4-MB restriction for software upgrades. Use TFTP to upgrade your access point to this release. For complete instructions on using TFTP to upgrade access point software, see the "Working with Software Images" section in the Cisco IOS Software Configuration Guide for Cisco Aironet Access Points. Click this link to browse to that document:

- - - snapp - - -

I hope that helps.

Best regards,


Community Member

Re: Aironet 350, 1100 IOS Upgrade Error

Thank You for the reply, but none of them worked. I tried FTP, TFTP, HTTP ,methods also. Fnally I downloaded Cisco Network Assistant and upgraded the image in a single click. Cisco Network Assistant deleted the old image and loaded new image. I tried this method in desparation but worked.

CreatePlease to create content