Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

ANI Server doesn't start

I have problem with ANIServer. I cannot start this service manually or automatic.

I have a message:

"ANIServer failed to start"

and in Ani-log:

"Informational: ANIServer starting Cisco Process Manager communication thread

ani ERROR AniLoadConfiguration: Failed to load mibs during initialization: java.lang.NullPointerException"

Additional: When I'm trying use UTUtility - all aplication in LMS Server hang up .

I solve this problem by restart server...until next using...

Marek

5 REPLIES
Cisco Employee

Re: ANI Server doesn't start

Please post your NMSROOT/campus/etc/cwsi/ANIServer.properties file.

Community Member

Re: ANI Server doesn't start

Hi

My ANIServer.properties file :

EnablePurgeArchives=ON

PurgeArchivesOlderThan=180

EnablePurgeJobs=ON

PurgeJobsOlderThan=180

Cisco Employee

Re: ANI Server doesn't start

That's the whole file? Then it's very corrupt. First, shutdown Daemon Manager. Then, copy ANIServer.properties.orig to ANIServer.properties, then edit ANIServer.properties, and replace the line:

DEVICESROOT=.

With, for example:

DEVICESROOT=C:\\PROGRA~1\\CSCOpx\\campus\\lib\\classpath

Or, on Solaris:

DEVICESROOT=/opt/CSCOpx/campus/lib/classpath

Then, restart Daemon Manager. You will need to go back into the Campus Manager GUI, and reconfigure Data Collection, but ANIServer should now be started.

Community Member

Re: ANI Server doesn't start

Thanks a lot

That was it:)

Community Member

ANI Server doesn't start

Hello

I did all what you mentioned but the ANIServer is still not working

Process= ANIServer

State  = Failed to run

Pid    = 0

RC     = -2

Signo  = 1073741822

Start  = N/A

Stop   = 3/8/2011 1:12:00 PM

Core   = Not applicable

Info   = Application failed or was registered incorrectly.

How can I solve this issue ?

700
Views
0
Helpful
5
Replies
CreatePlease to create content