Cisco Support Community
Community Member

ANI server problem - busy flag set

I have LMS2.5, with 1000+ devices.

I am experiencing problems launching the Topoloy Manager in campus services. When it tries to connect to ANI server, it exits giving the following message:

Cannot connect to ANIserver


Unknown error

Verify that ANIserver5.0.3 is running and restart campus manager.

I went to the Process Management in common services, it says that ANI server is running with busy flag set.

I tried to restart ANI from the process management window in common services, and tried to restart it from the WIndows services, nothing seems to make it work, and i still get the "busy flag set" in process management.

i took a look at the log files (ani.log and aniserver.log) nothing seemed to ring a bell.

I restarted the whole box, when ANI server starts, its ProcessState changes to "running with busy fag set" again. Even after stopping and starting the daemon manager.

How can I solve this and get Topology manager to run again?

Thanks for your time,




Re: ANI server problem - busy flag set

"Running with busy flag set" is the proper state of the ANIServer.

Try enabling the java plug-in console and see if there are any error messages in there.

Cisco Employee

Re: ANI server problem - busy flag set

ANIServer is running just fine. The problem is with your client/server connection. If the server is multi-homed, verify that you have properly configured Gatekeeper according to the the documentation (

Also, if you have a firewall or access list between the server and the client, make sure you are allowing through all the required ports (

If you can, try running a web browser on the server, and see if you can connect to ANIServer then. That will rule out network issues.

Finally, make sure that if you are using a proxy, that you disable proxying for the hostname and IP address of the CiscoWorks server.

CreatePlease to create content