Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 
Community Member

ANIServer 6.0 Error on Windows server


I got problem viewing the topology services. I have Campus Manager 5.1 and always get this error:

Cannot connect to ANI server: ANIServer6.0-hostname

Probable Cause

Unknown Error...

Recommended Action

Verify that ANIServer6.0-hostname is running and restart Campus Manager.

Firstly I installed Windows Server 2003 R2 Enterprise Edition and on that LMS3.1. The first time I started CiscoWorks

Device Discovery didn't work because DCR was down. I found solution for that problem - patch CSCSg90927-0.

After that devices were discovered and reports were generated but the problem was Topology Service. The first time I started I got the message that Java is incompatible,

I removed all Java files from my computer and put the new Java (I downloaded from the link that CiscoWorks offered).

After that all the time I'm getting the ANIServer error.

I checked and it's running, I even tried to stop it and start it manually but that didn't help.

On forum I found some posts where it was suggested to put IP address and host name in:


but that didn't help also. I can telnet to ports 42342 and 43242.

I also tried to manually stop and start ANIServer, to reinitialize campus DB and after no success to restore it back.

In attachment I'm sending java log from

...\Application Data\Sun\Java\Deployment\log

after unsuccessful starting topology Service

Do you have any idea why it is not working and what should I do to be able to start Topology Service successful?



Cisco Employee

Re: ANIServer 6.0 Error on Windows server

The error points to a connection problem from the client to tcp/42342 on the server. What do you see when you telnet to tcp/42342 on the server from your client?


I should say, what happens when you telnet to the host "ciscoworks" on tcp/42342? This could also be a hostname issue.

Community Member

Re: ANIServer 6.0 Error on Windows server


I tried to ping IP address and it went ok, but when I ping hostname it didn't pass.

Then I tried to telnet to tcp/42342 with IP address - I got blinking cursor, but when I tried with hostname I got following message:

Connecting to ciscoworks...Could not open connection to the host, on port 42342:Connect failed.

It's obvious hostname issue, but can you explain me where to put hostname?

I tried in WIN file hosts but it didn't help. should I put it somewhere else. Also, server is not on domain, it is in workgroup.

I would appreciate any help!



Cisco Employee

Re: ANIServer 6.0 Error on Windows server

If you put an entry for ciscoworks pointing to the server's correct IP address in the hosts file on the client, it should work. The alternative is to add the server's hostname to DNS.

CreatePlease to create content