Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

ANIServer issue - LMS 2.5.1 Solaris

Hi,

I have just completed an upgrade (upto LMS 2.5.1) of Ciscoworks and I'm unable to access services under Campus Manager as it reports that the "ANI service is initialising". I have checked that the service is running (with pdshow) and it all looks okay.

Was wondering if anyone else has experienced this issue.

Many Thanks.

Dave

12 REPLIES
Silver

Re: ANIServer issue - LMS 2.5.1 Solaris

This can due to be a lot of things

Did you restart the deamonmanager?

Anything you see now and didn't have before in the CampusOGSServer.log, ani.log or ANIServer.log?

This is a ciscolink for troubleshooting connection problems to older versions of ANI

http://www.cisco.com/en/US/products/sw/cscowork/ps563/products_tech_note09186a0080094ec0.shtml

Since Cisco seems reluctant to create a version for Campus 4.x we should assume nothing much has changed.

Cheers,

Michel

Cisco Employee

Re: ANIServer issue - LMS 2.5.1 Solaris

Are you seeing any messages like java.lang.OutOfMemoryError in the ani.log?

if you just upgraded to SP4 it might be due to bug

CSCsd79426

the workaround is:

Shutdown CiscoWorks Daemon Management, then edit

NMSROOT/campus/etc/cwsi/ANIServer.properties, and change LogMsg.logfile to point to a valid file

to which casuser can write.

(Note: NMSROOT is the path to where CiscoWorks was installed. By default, this is /opt/CSCOpx

on Solaris and C:\PROGRA~1\CSCOpx on Windows.)

New Member

Re: ANIServer issue - LMS 2.5.1 Solaris

This has solved the problem. Many thanks guy's.

Dave

New Member

Re: ANIServer issue - LMS 2.5.1 Solaris

Hi Davistan

I have the same from with campus manager 4.0.3 as dave above. when i run topology services it says it cant connect to the ANIServer. i have tried the same solution as you posted above but i still have the same problem. Any other workaround on this ?

below is what i see un the log when i run topology services

log4j:ERROR No appenders could be found for category (CTM.common).

log4j:ERROR Please initialize the log4j system properly.

new instance of Ptdm create

new appId created

new instance of Ptdm create

new appId created

Common trust user is: admin

User name in Security context is: admin

thanks in advance

Kezza

Cisco Employee

Re: ANIServer issue - LMS 2.5.1 Solaris

Are there any other errors in the ani.log?

What is the process status for ANIServer? have you tried stopping this process itself by pdterm/pdexec?

Also, have you done a reinit of the ani database and still seeing the same problem?

You might want to check the format of your discoverysnmp.conf file to make sure it looks ok.

New Member

Re: ANIServer issue - LMS 2.5.1 Solaris

Hi all

the process status was ''Running with busy flag set '', yes i did reinit the ani database, i think i did all the workaround that i could find on any forum abt this problem.

But i found a solution, i hope it will save alot of time for any other pple having the same problem after trying all the workaround. I was using firefox to browse cisco works, it didnt matter what version i was using , i still got the same problem. When i tried Microsoft Internet explorer 6.0, it worked. yes it was as simple as that after spending a whole day troubleshooting.

hope this helps someone out there not to waste alot of time .

Thanks in advance

Kezza

Cisco Employee

Re: ANIServer issue - LMS 2.5.1 Solaris

Firefox would be an important issue as its not a supported client browser version

IE is the only supported browser

glad its working now though!

New Member

Re: ANIServer issue - LMS 2.5.1 Solaris

Hi,

I have the same problem with LMS 2.5.1 on Windows. The ani.log containes

"DBConnecton-Reaper ani MESSAGE DBConnection: Closed Database connection [hashCode = 6529824]

java.lang.OutOfMemoryError".

The versions are:

CiscoWorks Common Services 3.0.4

Campus Manager 4.0.5

The causer has write-permissions to ani.log

The ANIServer.properties containes:

"LogMsg.logfile=F:/PROGRA~1/CSCOpx/log\\ani.log"

The used browser-version is IE 6.0 SP2. The complete restart was done.

Cisco Employee

Re: ANIServer issue - LMS 2.5.1 Solaris

How many devices are you managing in Topology Services? How many end users in User Tracking? How reproducible is this error? That is, if you restart ANIServer, do you encounter the error again in a predictable amount of time? What is the output for the following command:

pdreg -l ANIServer

New Member

Re: ANIServer issue - LMS 2.5.1 Solaris

Hi,

the system is located at a customer, and the customer has canceled yesterday the the ticket with us, because he wants not pay any money for service. Unbeleavable!

For information:

There are 170 devices dicovered, one user uses usertracking. If the customer restarts the ani-server the error occures again.

Thank you for your trouble.

Kind Regards.

Volker

Cisco Employee

Re: ANIServer issue - LMS 2.5.1 Solaris

I would recommend you open a TAC Service Request, then. We have been tracking some OutOfMemoryErrors with Campus Manager, and there is more debugging we need to do to track down the cause.

New Member

Re: ANIServer issue - LMS 2.5.1 Solaris

We will open a tac-case, if the customer does reopen the ticket.

Kind Regards

193
Views
34
Helpful
12
Replies