Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

ANIserver not running

We are facing problem with ANI Server which status is showing down. If we manualy restart then its coming up but after few minutes again getting down

the Properties files are attached . Kindly suggest.

ANI .LOg-backup is as follows--

2010/10/27 16:21:27 main ani ERROR ServiceModule: Failed to instantiate com.cisco.nm.ani.server.dfmpoller.NoServiceModule

2010/10/27 16:21:27 main ani MESSAGE DBConnection: Created new Database connection [hashCode = 21514757]

2010/10/27 16:21:27 main ani MESSAGE PartialSMFCommit: Partial Commit is enabled for DataCollection

2010/10/27 16:21:27 main ani ERROR SMFFactoryLoader: java.lang.NullPointerException

2010/10/27 16:21:27 main ani ERROR AniLoadConfiguration: AniStaticConfigException: Error accessing devices--root path null, packageName com.cisco.nm.ani.server.devices

1 ACCEPTED SOLUTION

Accepted Solutions

Re: ANIserver not running

as it seems the first ANIServer.properties file you posted was the .orig one, the second has commented out line 193 where the DEVICESROOT parameter is set. Stop dmgtd (in a DOS box enter "net stop crmdmgtd" ) when it is stopped, make a backup of the current ANIServer.properties file, then uncomment this line (remove the #) and restart dmgtd (net start crmdmgtd). Wait for 30 mins and see if it is working.

I have attached your file with this change.

3 REPLIES
New Member

Re: ANIserver not running

THE PROPERTIES FILE

Re: ANIserver not running

as it seems the first ANIServer.properties file you posted was the .orig one, the second has commented out line 193 where the DEVICESROOT parameter is set. Stop dmgtd (in a DOS box enter "net stop crmdmgtd" ) when it is stopped, make a backup of the current ANIServer.properties file, then uncomment this line (remove the #) and restart dmgtd (net start crmdmgtd). Wait for 30 mins and see if it is working.

I have attached your file with this change.

New Member

Re: ANIserver not running

Thanks A lot its working now

554
Views
0
Helpful
3
Replies