Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

API data discrepancy

When doing an api dump of data for several 2950 devices, it shows the number of ports defined on a device. The number of ports that have an associated IfIndex is 0. Why would a physical port not have an associated IfIndex?

7 REPLIES
Cisco Employee

Re: API data discrepancy

Please post some sample data as well as the command you're running to get the data.

New Member

Re: API data discrepancy

Here is the command:

cwcli export inventory -u XXX -p XXX -view ""/RME@sa26esoccisco04 - All Devices

Here is a sample of the output, notice that PortNumber 5 and 6 have Cisco_Port entries have a IfInstanceID after that there are no IfInstanceID's until PortNumber 15.

-

3

3

cevModuleCat3750Ge12Sfp

WS-C3750G-12S - Fixed Module 0

13

-

4

cevPortUnknown

InstanceName>StackPort1

-

5

cevPortBaseTEther

GigabitEthernet1/0/1

10101

-

6

cevPortBaseTEther

GigabitEthernet1/0/2

10102

-

7

cevPortGigBaseSX

GigabitEthernet1/0/3

-

8

cevPortGigBaseSX

GigabitEthernet1/0/4

-

9

cevPortBaseTEther

GigabitEthernet1/0/5

-

10

cevPortBaseTEther

GigabitEthernet1/0/6

-

11

cevPortGigBaseSX

GigabitEthernet1/0/7

-

12

cevPortGigBaseSX

GigabitEthernet1/0/8

-

13

cevPortGigBaseSX

GigabitEthernet1/0/9

-

14

cevPortBaseTEther

GigabitEthernet1/0/10

-

15

cevPortBaseTEther

GigabitEthernet1/0/11

10111

-

16

cevPortGigBaseSX

GigabitEthernet1/0/12

Cisco Employee

Re: API data discrepancy

I can't reproduce. What does the Detailed Device Report look like for this switch?

New Member

Re: API data discrepancy

See attached.

Cisco Employee

Re: API data discrepancy

If you run the cwcli output for this one device alone, do the results contain all of the IfInstanceIDs?

New Member

Re: API data discrepancy

No, same results as above.

Cisco Employee

Re: API data discrepancy

I don't see any problems, and since I believe you're running RME 4.0.6, all known data discrepancy bugs of this nature should be fixed. I recommend you open a TAC service request so some database analysis can be done.

179
Views
0
Helpful
7
Replies