Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

ASA configuration

I've tried setting up the ASA 5505 multiple times. I am able to access the server from a client but cannot access the internet. As of right now, I have no need to set up a dmz, only inside and outside interfaces. I've also tried different cables but was under the impression that the ASA had auto-sensing capabilities. What I have noticed is that the ASDM "forces" you to set up a dmz. Any ideas on getting re-started? I'm not sure if this a problem but the ASA will be the only device configured between the internal network and the "outside".

1 ACCEPTED SOLUTION

Accepted Solutions

Re: ASA configuration

Here is a basic setup example from console

1. remove the existing config with command " write erase" and reboot

2. you will have a fresh box now... configure as per below example

Suppose your internal LAN is 10.0.0.0/24 and outside public IP is A.B.C.D1/24 and the default GW going towards internet is A.B.C.D2,

int f0/0

no shut

nameif Outside

security-level 0

ip address A.B.C.D1 255.255.255.0

int f0/1

no shut

nameif Inside

security-level 100

ip address 10.0.0.1 255.255.255.0

route outside 0 0 A.B.C.D2

nat(Inside) 5 0 0

global(Outside) 5 interface

3 REPLIES

Re: ASA configuration

Here is a basic setup example from console

1. remove the existing config with command " write erase" and reboot

2. you will have a fresh box now... configure as per below example

Suppose your internal LAN is 10.0.0.0/24 and outside public IP is A.B.C.D1/24 and the default GW going towards internet is A.B.C.D2,

int f0/0

no shut

nameif Outside

security-level 0

ip address A.B.C.D1 255.255.255.0

int f0/1

no shut

nameif Inside

security-level 100

ip address 10.0.0.1 255.255.255.0

route outside 0 0 A.B.C.D2

nat(Inside) 5 0 0

global(Outside) 5 interface

New Member

Re: ASA configuration

I can't believe how easy that was. Many thanks. One question I have is why would I use "nat(Inside) 5 0 0" and "global(Outside) 5 interface" as opposed to "nat(Inside) 1 0 0" and "global(Outside) 1 interface? "

Re: ASA configuration

You can use any number you like, it's a map from a NAT source to an IP(s). You can use more than one too. I typically use one for NATing all internal users to the outside interface IP. I then use another (2 for example) for a specific mapping, like an email server.

nat (inside) 1 0 0

global (outside) 1 interface

nat (inside) 2 10.10.1.5 255.255.255.255

global (outside) 2 [public IP & mask]

Hope that helps.

107
Views
0
Helpful
3
Replies
CreatePlease to create content