Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Assistance with QOS on Router

policy-map wan-edge

class priority-class

bandwidth percent 75

class gold-class

bandwidth percent 10

class silver-class

bandwidth percent 5

class class-default

bandwidth percent 10

policy-map wan-edge

class priority-class

bandwidth percent 75

class gold-class

bandwidth percent 10

random-detect dscp-based

class silver-class

bandwidth percent 5

random-detect dscp-based

class class-default

fair-queue

random-detect dscp-based

random-detect dscp 0 10 15 2

ip access-list extended gold-data

remark *** ssh and terminal services traffic ***

permit tcp any any eq 22

permit tcp any any eq 3389

remark *** generic telnet traffic ***

permit tcp any any eq telnet

ip access-list extended priority-data

permit tcp any host 192.168.1.30 eq 5432

permit tcp any host 192.168.1.9

permit icmp any any

ip access-list extended silver-data

remark *** http traffic ***

permit tcp any any eq www

getting an error when i try to apply to an interface:

I/f FastEthernet0/0 class gold-class requested bandwidth 10%, available only 0%

i'm not sure what i am doing wrong if you could please take a look that would be very helpful

2 REPLIES

Re: Assistance with QOS on Router

Hi,

By default ,router will allow only 75% of the bandwidth to be used for all the classes configured . 25% would be taken for default class where other traffic that doesnt match the traffic in other classes defined and other headers used by router itself.

So since you have defined 75% for the first class , so available is now 0% thats the error .If you want to override the behaviour

then "max-reserved-bandwidth 90 " as per ur config . But take care that only 10% is allowed for your other traffic.

ref : http://www.cisco.com/en/US/tech/tk39/tk48/technologies_tech_note09186a00800fe2c1.shtml#understand

Pls rate all posts

regards

vanesh k

New Member

Re: Assistance with QOS on Router

Thank you, I'd forgotten about that. works fine now.

499
Views
0
Helpful
2
Replies