Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Authentication failure for SNMP

Dear Sirs,

We have 2 identically configured Cisco Works installations. Recently we were directed by the security group to change the public and private community strings on our Cisco Works servers. We executed the change on both servers identically.

After the change, one of the Cisco Works Server is causing hundreds of daily messages in the syslog.

The message is the following, “ SNMP 3 AUTHFAIL Authentication failure for SNMP req from host 10.8.29.234”

The other server, which we thought was configured identically to this server is not causing any error messages. We have sat with both servers and gone through every application and re – entered the community string on both servers. We still get error messages from only the one server!

Can you help us to isolate “where” in Cisco Works (which application) is generating this message? Is there a list of every place that this community string might be defined?

4 REPLIES
Silver

Re: Authentication failure for SNMP

On both servers get the file

\CSCOpx\campus\etc\cwsi\discoverysnmp.conf

Compare these files and also if you discovery tries multiple community string make sure the 'public' community string is last one in the file.

Regards,

Michel

Re: Authentication failure for SNMP

have you solved the problem?

If not I assume that DFM is the cause of the problem. In DFM select this device ( 10.8.29.234) for relearning.

this should solve it, if not delete the device from DFM and add it again.

Community Member

Re: Authentication failure for SNMP

Yesterday I had compared the below files, \CSCOpx\campus\etc\cwsi\discoverysnmp.conf

and changed according to the working server, still there is an error, today I'll try to use second option.

Thanks a lot for your help

Community Member

Re: Authentication failure for SNMP

Hi,

We have around 60 "6509" IOS devices, all this devices are not generating any SNMP authontication failure on server one.

but on 2nd server only 4 devices are generating this SNMP authontication failure massage, more over if we shut down this server or, if we delete this four devices from credential dtabase, the massage is not appearing.

166
Views
3
Helpful
4
Replies
CreatePlease to create content