Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Backup IPS2 forces to primary link over primary IPS1 on IP SLA.

I am faced with some challenges trying to solve IP SLA configured for a client, though working but the backup link drags with primary and primary link times out from time to time.  I have configured this solutuion severally, though the ISPs  are usually pointing to the next hop addresses but in thise case, one of the ISPs has the default route statement  configured pointing to DHCP. I need help.

See below as configured on the router:

!

hostname INTERNET_ROUTER

!

boot-start-marker

boot-end-marker

!

!

!

no aaa new-model

!

no ipv6 cef

ip source-route

ip cef

!

!

!

ip dhcp excluded-address 192.168.1.1 192.168.1.21

!

ip dhcp pool NECONDE_DHCP_POOL

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

dns-server 217.117.0.38 217.117.15.106 172.30.184.130

!        

track 1 ip sla 1 reachability

!

!

!

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

description Connection to Back_up Cool_link IS2

ip address dhcp

ip nat outside

ip virtual-reassembly in

duplex auto

speed auto

!

interface GigabitEthernet0/1

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/1.5

description Connection to Neconde_LAN

encapsulation dot1Q 5

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

!

interface GigabitEthernet0/2

no ip address

ip virtual-reassembly in

duplex auto

speed auto

!

interface GigabitEthernet0/2.798

description Connection to Vodacom VPN

encapsulation dot1Q 798

ip address 10.35.204.58 255.255.255.252

!

interface GigabitEthernet0/2.985

description connection to Primary_ Vodacom_Internet_ISP1

encapsulation dot1Q 985

ip address 41.75.205.66 255.255.255.248

ip nat outside

ip virtual-reassembly in

!        

!

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

ip nat inside source route-map ROUTE-MAP1 interface GigabitEthernet0/2.985 overload

ip nat inside source route-map ROUTE-MAP2 interface GigabitEthernet0/0 overload

ip route 0.0.0.0 0.0.0.0 41.75.205.65 track 1

ip route 0.0.0.0 0.0.0.0 dhcp

!

ip access-list extended NAT

permit ip 192.168.1.0 0.0.0.255 any

!

ip sla responder

ip sla 1

icmp-echo 4.2.2.2

timeout 250

threshold 250

ip sla schedule 1 life forever start-time now

!

!

!

!

route-map ROUTE-MAP1 permit 10

match ip address NAT

match interface GigabitEthernet0/2.985

!

route-map ROUTE-MAP2 permit 10

match ip address NAT

match interface GigabitEthernet0/0

  • Network Management
132
Views
0
Helpful
0
Replies
This widget could not be displayed.