Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Baseline template parameter files

I use baseline templates to deploy initial configurations to new switches before installation (RME 4.0.5). I have been trying to use parameter files, but I keep getting an error "The job could not be created since some of the devices are invalid". I finally discovered through trial and error that the device that RME doesn't like in the XML parameter file is the "Hostname="Default"" that is generated by RME when you generate the parameter file. If I take the "Default" device out, the deploy is successful. Is this a bug or am I doing something wrong? Being unable to supply default values makes using parameter files a bit messy.

4 REPLIES
Cisco Employee

Re: Baseline template parameter files

No, default parameters do work. Please post a parameter file that is giving you a problem.

New Member

Re: Baseline template parameter files

Here it is

Cisco Employee

Re: Baseline template parameter files

You have at least one device explicitly listed here. It should use the specific parameter, "hostname" for that one device, and the default parameters where it doesn't find a specific match. Is this not happening? Note: you cannot have a template with JUST Default as RME will not know to which devices it applies.

New Member

Re: Baseline template parameter files

RME will not even submit the job as long as the is in the parameter file. If I remove the default section and explicitly declare each parameter for each device, it will run. The error message that I am getting is attached.

137
Views
0
Helpful
4
Replies
CreatePlease to create content