Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Best Practices Deviation Error

I am trying to use the Best Practices Deviation Report to implement all Recommended fixes but when I click onto Fix i get the following error

INFO - Devices to be attempted in the job:

172.16.251.34

INFO - The job 1193 is created

Waiting for the job results ...

..!

- Job Status: Job Failed

Failed Devices:

172.16.251.34

ERROR - CM0078 Error during job execution Cause:

SUMMARY

========

Failed: import

Any ideas anyone?

11 REPLIES
Cisco Employee

Re: Best Practices Deviation Error

RME will use the Archive Mgmt deploy protocol order to deploy the config changes (i.e. not Netconfig). Go to RME > Admin > Config Mgmt > Transport Settings, and make sure the protocol order in the lower pane is sufficient. You can also check the dcmaservice.log and job log in the 1193 directory (where this is depends on OS) for more details.

Community Member

Re: Best Practices Deviation Error

ok i have added in all protocols and was going to test but i have also upgraded Campus Manager to version 5.0 and all my devices have disappeared, i tried to run data collection again which reports back that it is starting but instantly go to Idle and updates the last collection time to the current but still no devices have been discovered?

Cisco Employee

Re: Best Practices Deviation Error

Please start a new thread for this issue.

Community Member

Re: Best Practices Deviation Error

ok

I have all my devices in place in Campus Manager, when i select fix on the best practices it runs but returns the first error again, i have added in all the protocols as suggested in a previous response. The "Fix" button worked once for me this morning but now keeps returning the previous error. I have attached the dcmaservice.log

Community Member

Re: Best Practices Deviation Error

dcmaservice.log attached

Cisco Employee

Re: Best Practices Deviation Error

Sorry, I missed this response. What device did you try to fix?

Community Member

Re: Best Practices Deviation Error

The device above is a 2950T, but i am trying this a multiple different devices such as

4006

4510

2950

2960

3550

3750

and so far they all return the same error.

Cisco Employee

Re: Best Practices Deviation Error

I meant what was the IP address and hostname. There are quite a few errors in this log. It would also be helpful to see the log from the job. This can be found under NMSROOT\files\rme\jobs\CwConfig\JOBID where JOBID is the ID of the failing job.

Cisco Employee

Re: Best Practices Deviation Error

Nevermind of the IP. I found it in the first post.

There appears to be serious problems fetching all configurations from 172.16.251.34. Unfortunately, there is no debugging enabled in this log, so I cannot see exactly why. Make sure the DCR credentials are correct for this device. In particular, the username/password and enable credentials need to be correct so that the very least, the vlan.dat can be archived.

If you enable ConfigCLI and ArchiveMgmt Service debugging under RME > Admin > System Preferences > Application Loglevel Settings, then reproduce the error, the new dcmaservice.log and job log (see previous post) will be useful.

Community Member

Re: Best Practices Deviation Error

Hi Joe

The error has been reproduced and both logs are attached via .zip

Cisco Employee

Re: Best Practices Deviation Error

I'm not seeing any references to this particular device in the dcmaservice.log. However, I am seeing a lot of failed login attempts. This points to bad username/password credentials in DCR for your devices. I'm also seeing a permissions issue on C:\PROGRA~1\CISCOS~1\UPGRAD~1. It looks like you changed your tftpboot directory to this value. If that's the case, this directory needs to allow Full Control to the casusers group.

210
Views
0
Helpful
11
Replies
CreatePlease to create content