Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

BGP SNMP Traps - Unknown #

Folks,

I have a 3745 running IOS 12.3(14)T3, and configured with SNMP v1, I am getting following BGP Messages:

BGP Peer Connection Idle (BGP Peer x.x.x.x)

BGP Peer Connection Status Unknown, 1 (BGP Peer x.x.x.x)

BGP Peer Connection Status Unknown, 6(BGP Peer x.x.x.x)

BGP Peer Connection Status Unknown, 5 (BGP Peer x.x.x.x)

BGP Peer Connection Status Unknown, 4 (BGP Peer x.x.x.x)

BGP Peer Connection Status Unknown, 3 (BGP Peer x.x.x.x)

Please help me in understanding what are and why am I getting these "Unknown" Traps. (I assume them to be BGP State messages like Active, Connect, OpenSent etc...)

I got across this extract from one of Cisco.com's pages:

--------------------------------------------------------------------------------

Note: You may notice incorrect BGP trap OID output when using the SNMP version 1 BGP4-MIB that is available for download at ftp://ftp.cisco.com/pub/mibs/v1/BGP4-MIB-V1SMI.my. When a router sends out BGP traps (notifications) about state changes on an SNMP version 1 monitored BGP peer, the enterprise OID is incorrectly displayed as .1.3.6.1.2.1.15 (bgp) instead of .1.3.6.1.2.1.15.7 (bgpTraps). The problem is not due to any error with Cisco IOS software. This problem occurs because the BGP4-MIB does not follow RFC 1908 rules regarding version 1 and version 2 trap compliance. This MIB is controlled by IANA under the guidance of the IETF, and work is currently in progress by the IETF to replace this MIB with a new version that represents the current state of the BGP protocol. In the meantime, we recommend that you use the SNMP version 2 BGP4-MIB or the CISCO-BGP4-MIB to avoid an incorrect trap OID.

--------------------------------------------------------------------------------

This is the link:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/ffun_r/ffrprt3/frf014.htm#wp1154422

I haven't yet tried the v2c option as it says above and was hoping that CISCO-BGP4-MIB should do the trick, also stated above, but still it is not helping to sort this out...

Also, are there any limitations w.r.t. VRF interfaces, I had some IOS issues with overall SNMP messages before, i.e: no SNMP Traps were transmitted to Trap receiver, but upgrade of IOS solved it.

But this new problem popped up :-(

Thanks

~sultan

2 REPLIES
Silver

Re: BGP SNMP Traps - Unknown #

The issue is due to misconfiguration of the Autonomous system number on the neighbor BGP peer.

check with the following command in the neighboring router.

router#sh ip bgp summary

New Member

Re: BGP SNMP Traps - Unknown #

Folks,

This issue has been solved, there were some implementation issues on the NMS side... has been resolved....

Thanks

sultan

1162
Views
0
Helpful
2
Replies
CreatePlease to create content