Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

brand new cisco 1721 and SDM cd.

how do i setup SDM on a new 1721 correctly? i tftp'd the 4 SDM files to flash, enabled http server and setup a usr/pwd with priv 15. i get the login prompt in IE error 401 unauthorised. dunno what is messed up? i really need help here someone please reply soon.

6 REPLIES
New Member

Re: brand new cisco 1721 and SDM cd.

this is for personal home lab only guys not for work stuff. but i do still need help.

router#sh ver

Cisco Internetwork Operating System Software

IOS (tm) C1700 Software (C1700-BK9NO3R2SY7-M), Version 12.3(12a), RELEASE SOFTWA

RE (fc2)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2005 by cisco Systems, Inc.

Compiled Thu 13-Jan-05 23:22 by kellythw

Image text-base: 0x8000816C, data-base: 0x812B0DD0

ROM: System Bootstrap, Version 12.2(7r)XM2, RELEASE SOFTWARE (fc1)

ROM: C1700 Software (C1700-BK9NO3R2SY7-M), Version 12.3(12a), RELEASE SOFTWARE (

fc2)

router uptime is 1 hour, 47 minutes

System returned to ROM by reload at 16:56:38 UTC Tue Dec 27 2005

System restarted at 16:33:23 UTC Tue Dec 27 2005

System image file is "flash:c1700-bk9no3r2sy7-mz.123-12a.bin"

This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:

http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to

export@cisco.com.

cisco 1721 (MPC860P) processor (revision 0x400) with 58252K/7284K bytes of memor

y.

Processor board ID FOC08321HKB (3144010872), with hardware revision 0000

MPC860P processor: part number 5, mask 2

Bridging software.

X.25 software, Version 3.0.0.

1 Ethernet/IEEE 802.3 interface(s)

1 FastEthernet/IEEE 802.3 interface(s)

1 ATM network interface(s)

32K bytes of non-volatile configuration memory.

32768K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

could it be the IOS doesn't support SDM?

New Member

Re: brand new cisco 1721 and SDM cd.

i sort of getting there now guys. ios was fine. i added the following lines

: http authentication local

: line vty 0 4

: privilege level 15

: login local ; remove login & password lines

:transport input telnet

: transport input telnet ssh

:logging buffered 51200 warning

authentication worked and this window was ok'd to close, now second window says "SDM express for 10.10.10.1 will open in another window. do not close this window until you exit SDM express" but the second window hasnt launched after 5mins... probably the SDM ver is old, i have v2.1.1 from the cd.

New Member

Re: brand new cisco 1721 and SDM cd.

router#sh flash

System flash directory:

File Length Name/status

1 11030560 c1700-bk9no3r2sy7-mz.123-12a.bin

2 763392 es.tar

3 113152 home.tar

4 1038 home.shtml

5 820224 common.tar

[12728688 bytes used, 20563596 available, 33292284 total]

32768K bytes of processor board System flash (Read/Write)

router#

New Member

Re: brand new cisco 1721 and SDM cd.

ok, i opened up java manager and i got this error hostname router and url 10.10.10.1 don't match. i clicked continue anyway and now the fatal error has occured :

ES Startup Error

Application ES has not been granted with the necessary privileges in order to startup successfully, or another unknown error occurred during startup. Please close all involved browser windows and try again by granting all requested privileges.

i am really stuck now...

New Member

Re: brand new cisco 1721 and SDM cd.

ok guys, i have lift off now with URL https://10.10.10.1 and thanks to another post title 1811 & SDM i.e go to IE options/advanced.. place tick beside "allow active content to run in files in My Computer". to get to the final working SDM express screen however i encounter two popup prompt screens:

*********************

HTTPS - warning ( th

Hostname Mismatch

The hostname in the server security certificate does not match the name of the server.

hostname of the url : 10.10.10.1

hostname from the certificate : router.

do you want to proceed... yes

*******************

then second popup

*********************

Warning - Security

Do you want to accept the certificate from web site "router". for the purpose of exchanging encrypted information?

publisher authenticity verified by "unknow issuer"

! the security certificate was issued by a company that is not trusted

i the security certificate has not expired and is still valid

************************

Caution : router asserts that this content is safe. you should always accept this content if you trust "router" to make that assertion....click on always and voila, i finally get the SDM express screen with all the workings, to prove it works i set the router clock to sync with my PCtime and it worked indeed.

i think the second prompt screen is normal but the first screen prompt can be tidied up so that it doesn't popup everytime.

can someone agree this is fixable or is this just normal prompts in the way SDM express is accessed via IE?

do i need to change the hostname of the router or adjust the router config ?

New Member

Re: brand new cisco 1721 and SDM cd.

ok guys, when i use http://10.10.10.1, i dont get the two popup prompts mentioned in the last thread and secondly when i use https://10.10.10.1 , these two popup prompts are i suspect just normal IE security and certificate prompts. so, now I think i have SDM fully operational with either http or https. thanks for tuning in and hope this helps someone else in the future. now i am off to secure my 1721 with SDM express. after securing my 1721 router with SDM express, i will post further updates if http or https access falls over again via IE.

342
Views
0
Helpful
6
Replies
CreatePlease to create content