Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Campus User Tracking Issue

Hi All,

Ciscoworks LMS 2.5.1 (with all the latest updates) - FRESH INSTALLATION

While I am see my host details form campus user tracking -> Report -> Report Generator -> End Hosts & All Host Entries, I am not able to see Hostnames, IP address and subnetmask of my users. But when I am seeing Acquisition I am finding the following details :

Acquisition status Idle

Last acquisition type Major

Acquisition start time 19 Dec 2006, 11:15:10 GMT+03:00

Acquisition end time 19 Dec 2006, 11:17:02 GMT+03:00

Number of major acquisitions 2

Number of host entries 685

Number of duplicate MAC 120

Number of duplicate IP 2

Number of CCM hosts 0

Number of IP phone entries 0

Last campus data collection completed at 19 Dec 2006, 08:01:37 GMT+03:00

Campus data collection status Idle

Attached is the screen shot of the same.

Any Help highly appreciated.

Thanks in Advance.

13 REPLIES
Cisco Employee

Re: Campus User Tracking Issue

When IP information is missing from User Tracking, there is a problem with the router (or routers) that is responsible for cataloging ARP data for a given subnet or subnets. First, make sure that there is at least one Cisco router on the affected subnets that is properly managed by Campus Manager, and shows up green with the correct icon on the Topology Map.

If there is, then enable vmpsadmin debugging for Campus Data Collection, run a new UT acquisition, then look through the ut.log for any errors related to the routers in question.

New Member

Re: Campus User Tracking Issue

Hi jclarke,

Your are perfectly right, I am not able to see one of my MSFC2 Card in topologe view as router icon, We are having 6509 switch with dual supervisor engine and upon that MSFC2 daughter Cards installed. As you can see below the text of show module command on 6509 switch (Cat-OS).

The first supervisor engine which upon that the first card installed, I am not able to see in the topology view is having the status of OK in the show module command and the one which I am able to see in the topology view as router icon is having status as standby on its supervisor engine module.

Any clue how I can resolve this.

Dnet-Core-SW-6509> (enable) sh module

Mod Slot Ports Module-Type Model Sub Status

--- ---- ----- ------------------------- ------------------- --- --------

1 1 2 1000BaseX Supervisor WS-X6K-SUP2-2GE yes ok

15 1 1 Multilayer Switch Feature WS-F6K-MSFC2 no ok

2 2 2 1000BaseX Supervisor WS-X6K-SUP2-2GE yes standby

16 2 1 Multilayer Switch Feature WS-F6K-MSFC2 no ok

5 5 0 Switch Fabric Module WS-C6500-SFM no ok

6 6 16 1000BaseX Ethernet WS-X6516-GBIC no ok

7 7 16 1000BaseX Ethernet WS-X6516-GBIC no ok

8 8 48 10/100BaseTX Ethernet WS-X6348-RJ-45 no ok

9 9 48 10/100BaseTX Ethernet WS-X6348-RJ-45 no ok

Cisco Employee

Re: Campus User Tracking Issue

You must first verify CDP is working between the MSFC and the Sup, then check your SNMP settings on the MSFC, and make sure DCR has the correct credential information. Then check your Campus Data Collection settings to make sure you're not filtering this device out. If LMS is integrated with ACS, make sure the MSFC is a TACACS+ client of that same ACS server.

Finally, if you still can't figure it out, enable core and corex Data Collection debugging, and search the ani.log for errors pertaining to your MSFC.

New Member

Re: Campus User Tracking Issue

Hi jclarke,

I think the problem what I am seeing is I am not finding my first MSFC2 card in the "Common services -> device management -> campus@dnetmgmt" list. I tried several things like I created by selecting CS@dnetmgmt, campus@dnetmgmt, DFM@dnetmgmt and RME@dnetmgmt boxes and clicking add and giving displan name -> IP address and so on, when I recheck in the campus@dnetmgmt again I am not able to see the entry where as when I see in CS@dnetmgmt and RME@dnetmgmt I can see that. Any clue whats going on here, why it is not listing this object in the campus@dnetmgmt.

Note : Again I am not finding my first MSFC2 in Topology Services -> Topology Groups -> CAMPUS@dnetmgmt -> All Devices.

Regards,

Arif

Cisco Employee

Re: Campus User Tracking Issue

See my previous post. You will not see your MSFC in the Campus device list until Campus Manager properly data collects it.

Check all of the things I mentioned previously.

New Member

Re: Campus User Tracking Issue

hi jclarke,

Thanks for all of your help, the problem is solved as you said my msfc2 was not visable in topology group, as I added cluster IP address of MSFC2 in the DCR (We have configured HSRP between this two msfc2's for redundancy). Now I can see the cluster IP address router icon on my topology view and sucessfully reteried all the Hostname and IP address.

Once Again, thanks for your help.

Best Regards,

Arif

New Member

Re: Campus User Tracking Issue

Hi JClarke,

I just have another question related to my previous question. Now I can see all my hostnames and IP address in User Tracking End Host Report which includes all IP Phones IP and MAC address, but when I want to see User Tracking -> All IP Phones, I am getting a message of no IP Phone availabe.

Acquisition status Idle

Last acquisition type Major

Acquisition start time 19 Dec 2006, 11:15:10 GMT+03:00

Acquisition end time 19 Dec 2006, 11:17:02 GMT+03:00

Number of major acquisitions 2

Number of host entries 685

Number of duplicate MAC 120

Number of duplicate IP 2

Number of CCM hosts 0

Number of IP phone entries 0

Last campus data collection completed at 19 Dec 2006, 08:01:37 GMT+03:00

Campus data collection status Idle

Attached is the screen shot of the same.

Any Help highly appreciated.

Cisco Employee

Re: Campus User Tracking Issue

The reason you're missing your phones is that you do not have any Call Managers data collected. Check your data collection and DCR settings, and make sure your CCMs show up green with the proper icon on the topology map. When that happens, UT will poll the CCMs for phone information.

New Member

Re: Campus User Tracking Issue

I saw exactly the same behavior in our LAB. We have CCM 5.1 with CM 4.0.8 (LMS 2.6). SNMPwalk through CCM works well. Everything is in one VLAN, IP-Phones and CCM. Usertracking detect only the MAC-Address and IP's of the phones, but only as end hosts. No IP Phones are detected.

Thanks a lot for any hint to solve this problem.

New Member

Re: Campus User Tracking Issue

Hi,

my user tracking application (LMS 2.5, CM 4.0, solaris 9) has stopped working again this same week. For the time being I have been unable to find out why it keeps on working well 2 or 3 months (after reseting the database) and suddenly a certain day it stops working. After that it continues reporting successful user data collection but it doesn't anymore add or delete any record. Just like it happened the last time. It has stopped exactly at 6000 host and 150 discoverings. Maybe it has to do with some change in the network because I haven't touched anything in Ciscoworks in the last months. It's really weird.

I have a couple of questions:

- Is it possible to export all the host records at the same time in an excel file or whatever? When I try it just exports 500 records corresponding to one screen. I need to backup all of them before resetting again.

-I'd need to know which file may contain the date of my last reset.

Thanks

Blue

Re: Campus User Tracking Issue

You can export the UT data with "/opt/CSCOpx/campus/bin/ut -cli -query all -export filename.csv -u username -p passwd". Although I got the following error, it exported fine.

log4j:ERROR No appenders could be found for category (com.cisco.nm.ani.clients.utng.application.UTDataManager).

log4j:ERROR Please initialize the log4j system properly.

Operation has been completed successfully

Cisco Employee

Re: Campus User Tracking Issue

This error is typical, and does not indicate a problem. Everyone should see it.

New Member

Re: Campus User Tracking Issue

In the command "/opt/CSCOpx/campus/bin/ut -cli -query all -export filename.csv -u username -p passwd" the username/pass should correspond to the administrator? Is there a way to import later this info?

On the other hand I think my UT stops not because it's not properly discovering but because for some reason the db gets locked and UT is unable to write or delete recors. I wonder whether there's some flag/variable somewhere that I may check/uncheck to let UT again to write the new records in the db?

307
Views
5
Helpful
13
Replies
CreatePlease login to create content