Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Can't upgrade from LMS 3.0.1 to LMS 3.1 : backup fails

I want to upgrade LMS but backup fails at the beginning of the upgrade with this message in the backup.log file :

Starting database engine dfmFhEng

ERROR(951): Fatal error: Database engine 'dfmFhEng' could not be started on database 'dfmFhDb' in Bulk mode..

Backup failed: 2009/02/11 11:43:07

!!!!!!!!!!!!!!!!!

Who can help me?

Thanks

3 REPLIES
Cisco Employee

Re: Can't upgrade from LMS 3.0.1 to LMS 3.1 : backup fails

Either your DFM fault history database is corrupt, or the transaction log is corrupt. With Daemon Manager shut down, post the list of contents of NMSROOT/databases/dfmFh as well as the OS on which LMS is running.

New Member

Re: Can't upgrade from LMS 3.0.1 to LMS 3.1 : backup fails

My OS is Windows 2003 Server Enterprise Edition (Upgrade SP2)

The content of dfmFh is :

2 files : dfmFh.log (8KB)and dfmFh.db (140 980KB) and a directory "orig" with 3 files :dfmFh.dborig (796KB) odbc.tmpl (1KB)and odbc.tmplorig (1KB).

If It's possible to erase the Dfm database I can do it (But How?).

Cisco Employee

Re: Can't upgrade from LMS 3.0.1 to LMS 3.1 : backup fails

Do this, shutdown the Daemon Manager service. Delete the dfmFh.log. Run the following command:

NMSROOT\objects\win32\dbsrv9 -f NMSROOT\databases\dfmFh\dfmFh.db

Then you should be able to perform your backup.

183
Views
0
Helpful
3
Replies
CreatePlease to create content