Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cannot connect to LMS 2.6 (Solaris)

Hi all,

We got the following error message on Ciscoworks LMS 2.6 on Solaris 5.9:

{diskWatcher} - Avialable space in /var of server xxx is less than 10 percent.

We stopped the Daemon Manager and delete some log files. After restarting the Daemon Manager it took about 45 min to came up but unfortunately when we tried to connect to the sever by IE we got "Internet Explorer cannot display the webpage" the pdshow shows that:

        Process= Apache

        State  = Never started

        Pid    = 0

        RC     = 0

        Signo  = 0

        Start  = N/A

        Stop   = Not applicable

        Core   = Not applicable

        Info   = Not applicable,

We tried to start the Apatche server with no luck.

We tried to change the port and the ssl configurations as follows:

/opt/CSCOpx/MDC/Apache/bin/changeport 1744

/opt/CSCOpx/bin/perl /opt/CSCOpx/MDC/Apache/bin/ConfigSSL.pl -enable

/opt/CSCOpx/bin/perl /opt/CSCOpx/MDC/Apache/bin/ConfigSSL.pl -disable

Now the Daemon Manager does not start at all (pdshow shows nothing for a longer time).

I will appreciate any help.

Everyone's tags (7)
6 REPLIES
Cisco Employee

Cannot connect to LMS 2.6 (Solaris)

Mostly in these old LMS installations, i have seen issue with expired certificates. Please check the certificate state via :

NMSROOT/bin/perl   NMSROOT/MDC/Apache/bin/SSLUtil.pl and select option 1.

pdshow usually will never respond till the time Daemon manager is busy stop/start the services. You can see  NMSROOT/objects/dmgt/ready/ if there is any file/process lock. pdshow will work once this directory is empty or atlease dmgtd.lock is not there.

-Thanks

-Thanks Vinod **Rating Encourages contributors, and its really free. **
New Member

Cannot connect to LMS 2.6 (Solaris)

Thanks for the reply.

I checked the certificate and it is valid. Still cannot access LMS through the browser.

New Member

Cannot connect to LMS 2.6 (Solaris)

After further investigations I found from the /opt/CSCOpx/MDC/Apache/logs/error_log that the Apache shuts down during the Daemon Manager startup:

"[Tue May 22 09:23:41 2012] [notice] caught SIGTERM, shutting down"

So how can I start Apache again? And why it keeps shutting down like this?

New Member

Cannot connect to LMS 2.6 (Solaris)

I Also checked the Apache configuration syntax and the validity of the server certificate as described in:

http://www.cisco.com/en/US/docs/net_mgmt/ciscoworks_common_services_software/3.0.3/user/guide/diagnos.html#wp1134636

and everything is OK. The problem still exists.

Cisco Employee

Re: Cannot connect to LMS 2.6 (Solaris)

Please share more details from error_log (upload error_log). Also, please share the dmgtd.log as well.

They should shed more light on the error details.

-Thanks

-Thanks Vinod **Rating Encourages contributors, and its really free. **
New Member

Re: Cannot connect to LMS 2.6 (Solaris)

Here you are.

718
Views
0
Helpful
6
Replies