Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Cannot connect to NAM

Hi, I've configured the NAM with the following basic configuration.

Problem: I cannot connect to the NAM from outside the local subnet. It's installed in a 6509 and all the networks are configured on the device.

1. I can ping all the router interfaces on the 6509 but nothing after that (i.e. a device connected to vlan).

2. If I put a pc on the same subnet, I can connect to the NAM.

3. I can ping the default-gateway from the NAM.

4. I can pin the NAM from the 6509.

I'm sure that I'm overlooking something simple, but I just can't figure it out. Thanks for your help.

7 REPLIES
Cisco Employee

Re: Cannot connect to NAM

What version of code is running on the switch. You might be hitting CSCee10005. The workaround is to use a default-gateway on the same subnet, but on a different device (i.e. not an interface on the 6509).

Community Member

Re: Cannot connect to NAM

I'm running 12.2(18)SXF9. It's not possible for me to use a default-gateway on a different device. The 6509 is the VTP server and the devices on the other end are clients. I'll just have to schedule downtime to upgrade. Thanks.

Cisco Employee

Re: Cannot connect to NAM

12.2(18)SXF code already has the fix. The problem must be elsewhere. Seeing the config on the switch would be helpful.

at
Community Member

Re: Cannot connect to NAM

hi,

you fixed the problem ?

please can you tell more about the solution ?

alex

Cisco Employee

Re: Cannot connect to NAM

If you are hitting this bug, CSCee10005, then you need to be running a fixed version of code, then you need to configure the command:

fabric switching-mode force bus-mode

This will force the NAM to use bus-mode switching instead of fabric switching, and should resolve the connectivity problems. The workaround is configure an external default gateway on the NAM (i.e. not the switch in which the NAM is located).

at
Community Member

Re: Cannot connect to NAM

hi,

thanks - this helps !

I looked to the bugtool notes - specially to the known affected versions - and find out that 12.2.18SXF11 is affected !

after configuration

fabric switching-mode force bus-mode

the nam could be administrate as expected.

http://tools.cisco.com/Support/BugToolKit/search/knownAffectedVersions.do?method=fetchKnownAffectedVersions&bugId=CSCee10005

regards

alex

Community Member

Re: Cannot connect to NAM

You're already doing better than I am. I inherited a NAM that was never configured, I spent a few minutes on it and could never get to the point I could even ping it.

the fact that the box is a catos/ios hybrid with the msfc, was enough for me not want to mess with it very much. So I lost interest, thanks for the example though- I might take another whack at it.

214
Views
10
Helpful
7
Replies
CreatePlease to create content