Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cannot Create Custom Report Templates in LMS 2.6

Any help will be Highly Appreciated.

I am getting the following error when creating a Custom Reports(RME>Reports>Custom Report Templates)

"INVREP0007: Template creation failed because query building has failed. Check the invreports.log for more details."

When I look at the Logs I get the Following:

DEBUG,<DATE> <TIMESTAMP>,Datagenerator class name is class com.cisco.nm.rmeng.inventory.reports.datagenerators.SoftwareRDG

DEBUG,<DATE> <TIMESTAMP>,246,Datagenerator class instance is com.cisco.nm.rmeng.inventory.reports.datagenerators.SoftwareRDG@12a85ed

INFO ,<DATE> <TIMESTAMP>,export device list from request [Lcom.cisco.nm.rmeng.util.datastructures.DeviceID;XXXXXX

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: Cannot Create Custom Report Templates in LMS 2.6

This is CSCsm80635. It is fixed in LMS 3.1, and a patch is available for 4.0.6 from the TAC.

7 REPLIES
Cisco Employee

Re: Cannot Create Custom Report Templates in LMS 2.6

What is the ruleset you are using to create the custom report? Please post the entire invreports.log.

New Member

Re: Cannot Create Custom Report Templates in LMS 2.6

Thanks for the reponse.

You mean the AND and OR conditions?

I have tried both, its giving the Error.

Please find attached the reports file

Cisco Employee

Re: Cannot Create Custom Report Templates in LMS 2.6

I mean exactly what attributes were you trying to put in the report? What was the report definition? What version of RME?

New Member

Re: Cannot Create Custom Report Templates in LMS 2.6

RME version is 4.0.6

Template Rules: Flash File:Path Name:equals:All

AND:Device Type:Model:equals:All

AND:Image:Image Version:equals:All

New Member

Re: Cannot Create Custom Report Templates in LMS 2.6

I am seeing this exact same issue. Was there a resolution?

Cisco Employee

Re: Cannot Create Custom Report Templates in LMS 2.6

Hmmm, I missed this post, sorry. I can reproduce, and I'm looking into it.

Cisco Employee

Re: Cannot Create Custom Report Templates in LMS 2.6

This is CSCsm80635. It is fixed in LMS 3.1, and a patch is available for 4.0.6 from the TAC.

210
Views
13
Helpful
7
Replies