Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Cannot sync Cisco 1941 router in RME 4.2.0

We just replaced some older routers with 1941's running the K9 of 15.0(1)M3 and "Sync on Device" no longer works in RME 4.2.0 and throws the following error:

CM0100 Copy PRIMARY Running Config to PRIMARY Startup Config on device failed Cause: MgmtOperation RUNNING2STARTUP is not supported on automatically supported.

However doing this manually on the router works just fine.

#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]

The cause for the "out of sync" is shown below:

Startup config:

Using 5116 out of 262136 bytes


Running config:

Building configuration...
Current configuration : 5116 bytes

The "out of sync" errors persist even after manually doing a 'copy running-config startup-config`. Any help would be appreciated. Also, is there a list of exclude commands?

Thanks...!!!

= Uwe =

Everyone's tags (6)
1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: Cannot sync Cisco 1941 router in RME 4.2.0

The packages look consistent with my server.  However, I don't have a 1941 with which to test.  Can you try removing this device from RME and re-adding it?

6 REPLIES
Cisco Employee

Re: Cannot sync Cisco 1941 router in RME 4.2.0

Make sure you have the Rtr1900 package loaded in RME.  Go to Common Services > Software Center > Device Update to confirm this.  The latest version of this package is 2.3.  Once you do, you should be able to do copy start2running.

The list of exclude commands can be found under RME > Admin > Config Mgmt > Exclude Commands.

New Member

Re: Cannot sync Cisco 1941 router in RME 4.2.0

All device packages are up to date.

Cisco Employee

Re: Cannot sync Cisco 1941 router in RME 4.2.0

It doesn't look like you have the Rtr1900 package properly loaded as it appears the generic code is being used to manage this device.  Post the list of contents under NMSROOT/MDC/tomcat/webapps/rme/WEB-INF/lib/pkgs and NMSROOT/www/classpath/com/cisco/nm/xms/psu/pkgs/rme.

New Member

Re: Cannot sync Cisco 1941 router in RME 4.2.0

NMSROOT/MDC/tomcat/webapps/rme/WEB-INF/lib/pkgs are shown in attached file LMS_packages.txt

NMSROOT/www/classpath/com/cisco/nm/xms/psu/pkgs/rme are shown in attached file RME_packages.txt

Cisco Employee

Re: Cannot sync Cisco 1941 router in RME 4.2.0

The packages look consistent with my server.  However, I don't have a 1941 with which to test.  Can you try removing this device from RME and re-adding it?

New Member

Re: Cannot sync Cisco 1941 router in RME 4.2.0

We wanted to see if there were any other solutions because we didn't want to lose the historical data but eventually deleted it and then let auto-discovery re-add it. That seems to have taken care of the problem. Thanks, Joseph!

857
Views
0
Helpful
6
Replies
CreatePlease to create content