Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Catalyst 6500 snmp linkup/linkdown trap not sent

Hi all,

<br />

<br />I configured my catalyst 6500 switch to send snmp V1 traps. The switch is sending all other traps, e.g. OSPF related traps, but it is not sending the Linkstatus traps (linkup/linkdown). Does anyone have a suggestion how to fix this problem?

<br />

<br />I included the relevant part of the config and the debug information

<br />

<br />Regards,

<br />

<br />Theo Wiersma

<br />

<br />

<br />

<br />1) Cat6500.log

<br />

9 REPLIES
Cisco Employee

Re: Catalyst 6500 snmp linkup/linkdown trap not sent

The link isn't actual transitioning state. the linkDown trap tracks ifOperStatus, not ifAdminStatus. If you want an accurate test, you will need to shutdown an interface which is up.

New Member

Re: Catalyst 6500 snmp linkup/linkdown trap not sent

I did the same test on a Catalyst 3560 and this platform was sending the trap messages. Tomorrow I will test it with a live port.

Thanks for the reply and I will let you know the results tomorrow!

New Member

Re: Catalyst 6500 snmp linkup/linkdown trap not sent

I tested on a live interface and also added

SWBB0103(config)# snmp-server host 10.1.3.12 public chassis ospf hsrp bridge vtp vlancreate vlandelete envmon snmp config

so a trap is sent, when the config is changed, see the example below

SWBB0103#conf t

Enter configuration commands, one per line. End with CNTL/Z.

SWBB0103(config)#

Feb 5 15:19:13: SNMP: Queuing packet to 10.1.3.12

Feb 5 15:19:13: SNMP: V1 Trap, ent ciscoConfigManMIB.2, addr 10.1.2.4, gentrap 6, spectrap 1

ccmHistoryEventEntry.3.409 = 1

ccmHistoryEventEntry.4.409 = 2

ccmHistoryEventEntry.5.409 = 3

Feb 5 15:19:14: SNMP: Packet sent via UDP to 10.1.3.12

SWBB0103(config)#int gi2/17

SWBB0103(config-if)#

SWBB0103(config-if)#

SWBB0103(config-if)#shut

SWBB0103(config-if)#

SWBB0103(config-if)#

SWBB0103(config-if)#

SWBB0103(config-if)#

Feb 5 15:19:28: %LINK-5-CHANGED: Interface GigabitEthernet2/17, changed state to administratively down

Feb 5 15:19:28: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet2/17, changed state to down

SWBB0103(config-if)#

SWBB0103(config-if)#no shut

SWBB0103(config-if)#

SWBB0103(config-if)#

Feb 5 15:19:35: %LINK-3-UPDOWN: Interface GigabitEthernet2/17, changed state to down

SWBB0103(config-if)#

Feb 5 15:19:35: %LINK-SP-3-UPDOWN: Interface GigabitEthernet2/17, changed state to down

SWBB0103(config-if)#

SWBB0103(config-if)#

SWBB0103(config-if)#

Feb 5 15:19:40: %LINK-3-UPDOWN: Interface GigabitEthernet2/17, changed state to up

Feb 5 15:19:40: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet2/17, changed state to up

SWBB0103(config-if)#

Feb 5 15:19:40: %LINK-SP-3-UPDOWN: Interface GigabitEthernet2/17, changed state to up

SWBB0103(config-if)#

Feb 5 15:19:40: %LINEPROTO-SP-5-UPDOWN: Line protocol on Interface GigabitEthernet2/17, changed state to up

SWBB0103(config-if)#

SWBB0103(config-if)#

SWBB0103(config-if)#

SWBB0103(config-if)#

SWBB0103#

SWBB0103#

SWBB0103#

Feb 5 15:19:52: %SYS-5-CONFIG_I: Configured from console by vty0 (10.1.15.165)

SWBB0103#

SWBB0103#u all

All possible debugging has been turned off

SWBB0103#

The Catalyst 6509 didn't a trap when the interface went up and down.

Any other hints or tips?

Regards,

Theo

Cisco Employee

Re: Catalyst 6500 snmp linkup/linkdown trap not sent

I can't reproduce this. Can you post the entire config from this switch?

New Member

Re: Catalyst 6500 snmp linkup/linkdown trap not sent

Hi Joe,

I'd rather not publish the complete configuration of our live switch to the forum. Can I send it to you by a (private) E-mail?

Regards,

Theo

Cisco Employee

Re: Catalyst 6500 snmp linkup/linkdown trap not sent

If you can't post it hear, please open a TAC service request with this information.

New Member

Re: Catalyst 6500 snmp linkup/linkdown trap not sent

Hi Joe,

Here's the config, I removed the passwords and other irrelevant settings.

I hope you are able to reproduce the problem!

Regards,

Theo

Cisco Employee

Re: Catalyst 6500 snmp linkup/linkdown trap not sent

I still cannot reproduce. The config looks okay, and I can't find any relevant bugs. You should probably open a TAC service request so more analysis can be done.

New Member

Re: Catalyst 6500 snmp linkup/linkdown trap not sent

Hi Joe,

Thanks for the support.

I will open a TAC case to solve this issue.

Regards,

Theo

826
Views
0
Helpful
9
Replies
CreatePlease to create content