Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Cisco archive config backup problems

Hi,

I' am trying to achieve that when I do a "wr" a backup config is copied to my TFTP server.


My archive config looks like this:

archive
path tftp:172.23.106.30/$h
write-memory

When I do a "wr" I get this debug output:

3550_poe#wr
Building configuration...
[OK]
3550_poe#
Apr  5 14:06:33.899: backup_running_config
Apr  5 14:06:33.899: Current = 1
Apr  5 14:06:33.899: Writing backup file tftp:172.23.106.30/3550_poe-1
Apr  5 14:06:35.731:  backup failed

3550_poe#sh archive
The next archive file will be named tftp:172.23.106.30/3550_poe-1
Archive #  Name
   0       
   1       :Error - Bad file number
   2       
   3       

I don't know why this is not working. I tried FTP too, without luck.

The TFTP server is working, I tested it:

3550_poe#copy running-config tftp:
Address or name of remote host []? 172.23.106.30           
Destination filename [3550_poe-confg]?
!!
7196 bytes copied in 0.948 secs (7591 bytes/sec)

I tried this config too, with the root folder of the TFTP server and it is still not working:

archive
path tftp:172.23.106.30/TFTP-Root/$h
write-memory

Do you guys have an idea why this is not working?

PS. I tried it on a 3550 SW, 2960 SW and 2811 Router and it is always the same error.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Cisco archive config backup problems

Try this....

archive

path tftp://172.23.106.30/h$

write-memory

Mike

4 REPLIES
New Member

Re: Cisco archive config backup problems

Check if you have enough rights/permissions on the destination host to create a new file

Re: Cisco archive config backup problems

Try this....

archive

path tftp://172.23.106.30/h$

write-memory

Mike

New Member

Re: Cisco archive config backup problems

Thank you very much.

It was the //, I really did not thought about that.

You typed h$ but it should be $h, it is probably a type-o.

Thank you again.

Re: Cisco archive config backup problems

Glad it worked...yep..I typed it wrong sorry about that.

Remember to rate posts that help and if it solved your problem note that as well. It will help other if they have the same issue.

Mike

4089
Views
0
Helpful
4
Replies
CreatePlease to create content