Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cisco Configuration Professional with Windows 7

Has anyone attempted to use CCP with Windows 7?  I am running the following on my system:

Windows 7 Professional 32 bit

Java 1.6.10

IE8

UAC is at it's lowest setting.

I know that the minium requirements call for IE7 and, at the latest, Vista, but I was curious if there is a way to trick CCP into running on Win7.  The program installs without a problem, but when I run CCP, I get a random error that just says "Please correct the following error" - "error", with no explanation.

I am trying CCP because I cannot get SDM to run either...

Any ideas??

Thanks in advance!!

27 REPLIES
Bronze

Re: Cisco Configuration Professional with Windows 7

Hi Brian,

I'm using CCP on Windows 7 64-bit and haven't run into any problems yet.   The only thing I can think of is to try adjusting your compatibility settings and/or make sure you install CCP as Administrator. 

Good luck! I know getting these things to work can be a beast sometimes.

--Brandon

New Member

Re: Cisco Configuration Professional with Windows 7

Thanks for the reply Brandon.  Since I initially posted, I have uninstalled CCP and re-installed "As Administrator" (via the right click) option.  Still I have the same issue.  I have tried to run the program in compatibility mode (xp sp3) and chosen to always run "As Administrator", and forced IE8 into IE7 mode via the developer tools, but still I have the same problem.  Attached is a screenshot.  Would you (or anyone else) mind taking a look and perhaps posting your system specs (java version, browser settings, etc.)?  Also - I am running CCP v2.0 - I believe it was the latest download from Cisco's site.  I haven't tried an older version yet - that's my next test....

Thanks again!!

New Member

Re: Cisco Configuration Professional with Windows 7

Thanks for the reply Brandon.  Since I initially posted, I have uninstalled CCP and re-installed "As Administrator" (via the right click) option.  Still I have the same issue.  I have tried to run the program in compatibility mode (xp sp3) and chosen to always run "As Administrator", and forced IE8 into IE7 mode via the developer tools, but still I have the same problem.  Attached is a screenshot.  Would you (or anyone else) mind taking a look and perhaps posting your system specs (java version, browser settings, etc.)?  Also - I am running CCP v2.0 - I believe it was the latest download from Cisco's site.  I haven't tried an older version yet - that's my next test....

Thanks again!!

New Member

Re: Cisco Configuration Professional with Windows 7

Sorry - can't attach a file for some reason....

Bronze

Re: Cisco Configuration Professional with Windows 7

Brian,

I tried installing this at home on a Windows 7 VM (64-bit) and it worked first try -- I was hoping to be able to recreate the error you were receiving to see if I could see what it's all about. When I installed it I didn't do anything special -- I didn't even right-click and install as Administrator.

There are a bunch of log files in C:\Program Files\Cisco Systems\CiscoCP\logs\ that should have information from the last time you tried to run the app. Can you attach those logs so we can look at them?

Thanks,

Brandon

New Member

Re: Cisco Configuration Professional with Windows 7

Brandon,

Thanks for your help.  My log files are empty except for the Catalina log file...i attached both of them.  I wondered initially if my firewall was blocking something so I disabled it as well...no luck.  I guess I just don't have the touch like you do.  The files are attached...

Bronze

Re: Cisco Configuration Professional with Windows 7

Brian,

I'm unable to download the attachments -- can you try uploading again?

Thanks,

Brandon

Edit:  Nevermind... they finally showed up. They were marked as "queued" for over an hour

Bronze

Re: Cisco Configuration Professional with Windows 7

Well, those logs don't contain much information. In fact, they match mine exactly.

Can you run the _ccpshowtech.bat and attach results?  It's located in the C:\Program Files\Cisco Systems\CiscoCP\bin\ directory.

Also, what Java version do you have installed?

New Member

Re: Cisco Configuration Professional with Windows 7

I started out with Java v1.6.15, then tried Java v1.6.10, now I am trying to use v1.6.0 with CCP v2.0.  The show tech files are attached - or in the process of attaching.

 

Bronze

Re: Cisco Configuration Professional with Windows 7

You might also try 1.6.0_07 -- I know that with the Cisco ASDM I have to manually set it to 1.6.0_07 or it doesn't work.

New Member

Re: Cisco Configuration Professional with Windows 7

I just tried using version 5.0.11 but i get the same error...there is a yellow bar with a red x that says correct the following errors...but it doesn't list any errors to correct.  this yellow bar appears where the RSS feed would normally appear.

I will try 6 update 7 to see how it functions...thanks again.

New Member

Re: Cisco Configuration Professional with Windows 7

Well i just realized that Lotus Notes v 8.5 (yes we run lotus notes) doesn't run with Java Version 5...back to

6 i go...

New Member

Re: Cisco Configuration Professional with Windows 7

6 update 7 isn't gonna work either...same error.

New Member

Re: Cisco Configuration Professional with Windows 7

Hello,

Does anyone already found a solution? I'm having the same issue here.

New Member

Re: Cisco Configuration Professional with Windows 7

I am having the same problem. I had CCP 2.0 installed on Vista 32 bit with IE 8 and it was working fine. After I upgraded to 32 bit Windows 7, and tried to launch CCP I get the same error with no explaination. I have tried updating Java, uninstalling 2.0 and installing 1.4, adding localhost:8600 to default to compatibly mode in IE 8, all to no avail. Any help would be greatly appreciated as i do not know CLI, and I am dead in the water with out CCP.

Thanks!

New Member

Re: Cisco Configuration Professional with Windows 7

Hi

Adobe Flash Player is required to run Cisco Configuration Professional. If you do not have Adobe Flash Player installed in your system. Exit Cisco Configuration Professional, install the Adobe Flash Player, and then start Cisco Configuration Professional.

New Member

Re: Cisco Configuration Professional with Windows 7

Hey all...

I have been using CP v 2.4 for a few weeks now with Java version 1.6.17 with the following runtime parameters...

-Xmx256m -Dsun.java2d.d3d=false

Also - there is a security setting that needs to be disabled in the Java Control Panel as well

Advanced - Java Plug In - uncheck the 'Enable next generation Java plug-in' and restart the browser.

It is working great on Windows 7-64bit with IE8.

Hope this helps!!

New Member

Cisco Configuration Professional with Windows 7

The box to uncheck "enable next generation Java plug-in" is greyed out for me.

New Member

Re: Cisco Configuration Professional with Windows 7

Hi there!

I also try to use CCP with windows 7 and iexplorer 9.

Im able to discover the router and press confiqure, but every time i press something that starts java i get a forever loading screen like this :

http://i47.tinypic.com/1qhoye.jpg

Any suggestions?

New Member

Re: Cisco Configuration Professional with Windows 7

What version of Java are you running?  I am running CCP v2.5 on Win7 32-bit (and 64-bit) with Java 1.6.0.17 - also - did you set your runtime paramaters in the java control panel as stated above?

These settings have worked for me since my last post. 

New Member

Re: Cisco Configuration Professional with Windows 7

I tried CCP 2.5 and 2.6 and im runinng 1.6.0.17 right now. I also tried 1.6.0.16.

Running parameter -Xmx256m -Dsun.java2d.d3d=false and Java next generation plugin unckecked....

New Member

Cisco Configuration Professional with Windows 7

Update...

Problem solved when i used different ios version with GNS3.

New Member

Cisco Configuration Professional with Windows 7

what is the IOS version that worked?

New Member

Hello Guys,the solution is

Hello Guys,

the solution is simple, just disable active-X filter on IE.  from tools uncheck active-x filter

 

Wishes,

Maher

New Member

My pc also not opening CCP

My pc also not opening CCP after Change the port setting from com1 to com5 and com2 to com10 port is working now fixed.

ok, it's a 6 years ago

ok, it's a 6 years ago conversation....but...

i also have problem with ccp and windows 7 64bit.

see the attachment please :'(

New Member

Francesco,I haven't used CCP

Francesco,

I haven't used CCP in a good while - since then I have converted to the command line for all of my configurations.  However, The last release i used was version 2.x if I remember correctly.  

 

Have you tried these settings from my post from 4 years ago??

 

Hey all...

I have been using CP v 2.4 for a few weeks now with Java version 1.6.17 with the following runtime parameters...

-Xmx256m -Dsun.java2d.d3d=false

 

Also - there is a security setting that needs to be disabled in the Java Control Panel as well

Advanced - Java Plug In - uncheck the 'Enable next generation Java plug-in' and restart the browser.

 

It is working great on Windows 7-64bit with IE8.

 

Hope this helps!!

32108
Views
5
Helpful
27
Replies