Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Cisco Prime Infrastructure 2.1 Image Distribution Problem

 

Hey Guys,

Trying to upgrade a switch using Prime. The switch Sync's fine with Prime, SNMP and Telnet/SSH credentials seem to work. However when trying to push an Image I get the following errors in the job description:

Distributing image c3560-ipbasek9-tar.150-2.SE6.tar using protocol TFTP      FAILURE
Distributing image c3560-ipbasek9-tar.150-2.SE6.tar using protocol SCP        FAILURE

How can I find out more details as to what exactly the failure is?

Thanks!

7 REPLIES
Community Member

Hello, Check your flash size,

Hello, 

Check your flash size, 

Community Member

Thanks, there's enough free

Thanks, there's enough free Flash. I also tried with a smaller image just in case, with same result.

Does anyone know where I could find the detailed logs?

Community Member

Hi,On your switch try to

Hi,

On your switch try to "debug tftp packets" or "debug ip scp" it will give you a clue about the problem.  

Community Member

Thanks,There is no debug ip

Thanks,

There is no debug ip scp option on the switch.

I did turn on debugging for tftp packets and term mon, but no activity at all before the job fails.

Community Member

Interesting note:I found that

Interesting note:

I found that when using the "Software Deployment" instead of the "Image" tab under a device in the "Device Work Center" to do upgrades, I encounter this problem less often.

However the problem still does occur at times and an additional problem I'm facing is that at times the upgrade jobs succeed fine, but the devices never get rebooted (in spite of having the snmp-server system-shutdown string in the config). In that case the job will never finish and shows as 'running' 10 days later. The Job also can't be cancelled or aborted successfully.

Community Member

I can confirm that using

I can confirm that using Software Deployment works better. I have no firewall between my CPI and switches so the problem must be in CPI. Can't speak for the reboot problem though as I never reboot the devices from CPI.
Community Member

I am really tired of this -

I am really tired of this - Cisco upgrades their software products and breaks half of the features in the process.  Please, somebody tell me how/where to properly configure FTP and HTTP as an option for software distribution in Prime 2.1.  I see where I should be able to select them as options, but alas - they are not listed at all.  TFTP is an awful protocol to perform upgrades over WAN links.  Distribution was bullet proof in LMS 4.x...

825
Views
15
Helpful
7
Replies
CreatePlease to create content