Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Cisco Prime LMS 4.1 ANIDbEngine process may be down

I'm having an issue with LMS 4.1 soft appliance. After weeks of use the following error is displayed on inventory/monitor dashboard:

User Tracking Summary

Unable to connect to Data base.

Probable Cause: ANIDbEngine process may be down

I have verified status of processes and is the following:

ANIDbEngine    Program started - No mgt msgs received

I'm able to run UT acquisition manually, also generate UT report for example.

The only error I'm able to find but not sure if it connected with described syptom is when I run self-test:

network.pl

FAIL    nslookup failed

I have manually checked nslookup from console and shell, server gets correct responses. Also things that are normally very sensitive to correct domain name setting (Topology plugin for example) work without any issues.

Is there a way to find out more about ANIDbEngine status? I would also like to understand what is preventing network.pl test from succeeding.

Everyone's tags (2)
6 REPLIES
New Member

Cisco Prime LMS 4.1 ANIDbEngine process may be down

In case somebody is experiencing similar issues with soft appliance selftest... I have realized why selftest network.pl fails.

There is a bug in /opt/CSCOpx/selftest/network.pl script. Line calling nslookup contains wrong path (/usr/sbin/nslookup).

If /usr/sbin/ is removed in front of nslookup command, script starts working as it should.

With main issue - User Tracking Summary portlet I still have issues - it simply doesn't start. It displaying only the following error no matter what i do.

New Member

Re: Cisco Prime LMS 4.1 ANIDbEngine process may be down

Hello,

have you found a solution for this problem?

greetings,

David

New Member

Re: Cisco Prime LMS 4.1 ANIDbEngine process may be down

I have found only the cause for false self-test report. Network.pl script includes mistake (paths within script are wrongly specified) which causes self-test to fail everytime.

So far I was was not able to resolve the issue with UT portlet. I plan to perform an upgrade in the near future to version 4.2. I hope an inline upgrade will correct this issue.

New Member

Re: Cisco Prime LMS 4.1 ANIDbEngine process may be down

My self-test report works without any troubles. I only have the problem with the UT and I'm on version 4.2.

New Member

Re: Cisco Prime LMS 4.1 ANIDbEngine process may be down

I am also seeing the "Unable to connect to Data base. Probable Cause: ANIDbEngine process may be down" message on my main portal. This was working fine until I installed a Windows Server update, which I suspect broke my process. Now. the ANIDbEngine process seems to work fine for a few days, then inexplicably stops. The solution I have found is to stop then start the "crmdmgtd" service, with:

net stop crmdmgtd

Wait for all services to stop, then run:

net start crmdmgtd

This startup process takes about 10-15 minutes to finish. I've tried stopping and starting the service via the LMS GUI, as well as using Windows Server process manager, but no luck.

I'm using LMS 4.2.3 on Windows Server 2008.


Is there a way to manually restart just the ANIDbEngine process?

New Member

Re: Cisco Prime LMS 4.1 ANIDbEngine process may be down

I solved the problem by doing a manuall re-initialize of the ani.db.

How it works:

Stop CiscoWorks, move the original file to some other location:

$NMSROOT\databases\ani\ani.db (and ani.log if it exists) file.

Copy the ..\orig\ani.dborig, to $NMSROOT\databases\ani, rename it to: ani.db,

verify the file permissions, and then start CiscoWorks again.

greetings,

David

1913
Views
0
Helpful
6
Replies
СоздатьДля создания публикации, пожалуйста в систему