Cisco Support Community
Community Member

Cisco Works configuration archive


I have a problem with Cisco Works. I set up a new server with Cisco Works Small Network Management Solution 1.5.

The monitoring is ok. My Problem is that no switch configurations are stored. If I have a look at CiscoWorks Desktop tab Admin > Essentials > Configuration Management > Archive Status, then at all points there is a “0”. In the General Setup of the Configuration Management I set up a directory and chose “older than 1 day”, “maximum versions to keep 5”, “don't purge labelled files”.

ICMP, Telnet and SNMP of the registered devices (Catalyst 2960, 2960G) are right.

If I try to update the Config Archive by hand there is an error message: “Change Audit process not running”. So I started this process by hand but it seems to be only for a short time. After starting the process I tried again to update the Config Archive but same error message appeared. And if I have a look at the status of the Change Audit process, it shows “shut down” again.

Has anybody an idea what is wrong? What are the essential settings to store the configurations automatically?


Cisco Employee

Re: Cisco Works configuration archive

You'll need snmp RO and RW to archive your configurations. If ChangeAudit is down I would like to see if any of the processes it depends on are down. Can you post the output of pdshow?

Community Member

Re: Cisco Works configuration archive


thanks for your answer.

I compared the process status table of this machine with another one (on which storing the configs is running!) and there were a lot of differences.

There were two processes with the status "Failed to run":



Some other processes have the status "Admin has shut down":







I read that the EssentialsDbMonitor (Failed to run) is the assumption for ChangeAudit.

I tried to start it per hand and this error message appeared: could not start because DBENCRYPT.DLL was not found.

But this file is there. It's in the same folder like on the working machine (program files > cscopx > bin).

So I don't know what to do. Do you have an idea?

Community Member

Re: Cisco Works configuration archive

It's been a while since I've worked with Ciscoworks but how much memory are you running.

When I had an issue like this had to upgrade the memory from 1GB to 2GB on the test server and then it would run a collection with no problem.

CreatePlease to create content