Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Cisco Support Community site will be in read only mode on Dec14, 2017 from 12:01am PST to 11:30am for standard maintenance. Sorry for the inconvenience.

New Member

CiscoWorks LMS 2.5 not sending Traps (email notification) to our email's

Dear Friends,

I am in very urgent need of your Help.

We have Cisco LMS configured in our Network, which used to send Traps ( Notification) before 4 months, we have stopped the service before 4 months, as we were shifting our office premises, but today when we need it back, its not sending any more traps to our email id's

I have already configured " Notification services " in DFM.

Please help in urgent.

20 REPLIES
Cisco Employee

Re: CiscoWorks LMS 2.5 not sending Traps (email notification) to

SNMP traps do not go to email IDs. SNMP traps go to SNMP trap receivers. You have posted two screenshots, so I am confused as to what is not working. Is it that email notifications are not being sent, or is it that SNMP trap notifications are not being sent, or both? What version of DFM are you using?

New Member

Re: CiscoWorks LMS 2.5 not sending Traps (email notification) to

Both are not being sent....

for example, previously whenever any of our link go down, we used to receive an email notification (traps). Presently we are not receiving any traps....

DFM:

Version & Patch Level:

2.0.5

Cisco Employee

Re: CiscoWorks LMS 2.5 not sending Traps (email notification) to

When the link goes down, do you see an event in the DFM Alerts and Activities Display?

New Member

Re: CiscoWorks LMS 2.5 not sending Traps (email notification) to

Hi there,

Yes i am able to see an event in the DFM Alerts and Activities, but no email notification is forwarded ...

pls advise.

Cisco Employee

Re: CiscoWorks LMS 2.5 not sending Traps (email notification) to

Please post the output of the command pshow as well as the output of pdreg -l NOSServer.

New Member

Re: CiscoWorks LMS 2.5 not sending Traps (email notification) to

I am not getting output for Pshow.

I am getting output for pdreg-l NOSServer :

C:\Documents and Settings\Administrator>pdreg -l NOSServer

Process = NOSServer

Path = C:\PROGRA~1\CSCOpx\bin\cwjava.exe

Flags = -server -cp:p MDC\tomcat\webapps\triveni\WEB-INF\lib\lo

g4j.jar,MDC\tomcat\webapps\triveni\WEB-INF\lib\nos.jar,MDC\tomcat\webapps\triven

i\WEB-INF\lib\ctm.jar,MDC\tomcat\webapps\triveni\WEB-INF\lib\ogs-client.jar,MDC\

tomcat\webapps\triveni\WEB-INF\lib\cogs.jar,MDC\tomcat\webapps\triveni\WEB-INF\l

ib\ogs-kc1.0.jar,MDC\tomcat\webapps\triveni\WEB-INF\lib\ogs-kilnervirtualasa1.0.

jar,MDC\tomcat\webapps\triveni\WEB-INF\lib\activation.jar,MDC\tomcat\webapps\tri

veni\WEB-INF\lib\mail.jar,MDC\tomcat\webapps\triveni\WEB-INF\lib\tis-client.jar,

MDC\tomcat\webapps\triveni\WEB-INF\lib\pm.jar,lib\classpath\jconn2.jar,lib\class

path\epm-v0-5-0.jar,lib\classpath\cesar-v0-5-0b.jar,MDC\tomcat\shared\lib\NATIVE

.jar,MDC\tomcat\shared\lib\MICE.jar,MDC\bin,objects\nos\config,MDC\tomcat\webapp

s\triveni\WEB-INF\classes, -cw:jre C:\PROGRA~1\CSCOpx\MDC\jre -cw:xrs -Djava.co

mpiler=NONE com.cisco.nm.trx.nos.server.NOSServer

Startup = Started automatically at boot.

Dependencies = EPMDbEngine EPMServer INVDbEngine PMServer DFMOGSServer

Thanks,

Sumit AGarwal

Cisco Employee

Re: CiscoWorks LMS 2.5 not sending Traps (email notification) to

Sorry, I mistyped. The command is pdshow.

New Member

Re: CiscoWorks LMS 2.5 not sending Traps (email notification) to

here is the output :-

RC = 0

Signo = 0

Start = 7/26/2008 11:10:47 AM

Stop = Not applicable

Core = Not applicable

Info = DFM broker Running

Process= DfmServer

State = Running normally

Pid = 4884

RC = 0

Signo = 0

Start = 7/26/2008 11:10:51 AM

Stop = Not applicable

Core = Not applicable

Info = DFM server Running

Process= DeviceDiscovery

State = Transient terminated

Pid = 0

RC = 0

Signo = 0

Start = 7/29/2008 3:00:00 PM

Stop = 7/29/2008 3:01:59 PM

Core = Not applicable

Info = Server started by admin request

Process= CSRegistryServer

State = Running normally

Pid = 4896

RC = 0

Signo = 0

Start = 7/26/2008 11:10:51 AM

Stop = Not applicable

Core = Not applicable

Info = CSRegistryServer is running

Process= CmfDbEngine

State = Program started - No mgt msgs received

Pid = 4568

RC = 0

Signo = 0

Start = 7/26/2008 11:10:55 AM

Stop = Not applicable

Core = Not applicable

Info = Application started by administrator request.

Process= CmfDbMonitor

State = Running normally

Pid = 6404

RC = 0

Signo = 0

Start = 7/26/2008 11:10:59 AM

Stop = Not applicable

Core = Not applicable

Info = DbMonitor Running Normally.

Process= DCRServer

State = Running normally

Pid = 6432

RC = 0

Signo = 0

Start = 7/26/2008 11:11:00 AM

Stop = Not applicable

Core = Not applicable

Info = DCRServer is up and running

Process= CampusOGSServer

State = Program started - No mgt msgs received

Pid = 6688

RC = 0

Signo = 0

Start = 7/26/2008 11:11:12 AM

Stop = Not applicable

Core = Not applicable

Info = Server started by admin request

Process= CMFOGSServer

State = Program started - No mgt msgs received

Pid = 6832

RC = 0

Signo = 0

Start = 7/26/2008 11:11:12 AM

Stop = Not applicable

Core = Not applicable

Info = Server started by admin request

Process= ConfigMgmtServer

State = Program started - No mgt msgs received

Pid = 6824

RC = 0

Signo = 0

Start = 7/26/2008 11:11:12 AM

Stop = Not applicable

Core = Not applicable

Info = Server started by admin request

Process= EssentialsDM

State = Running normally

Pid = 6856

RC = 0

Signo = 0

Start = 7/26/2008 11:11:12 AM

Stop = Not applicable

Core = Not applicable

Info = RME Device Management started.

Process= NCTemplateMgr

State = Running normally

Pid = 6716

RC = 0

Signo = 0

Start = 7/26/2008 11:11:16 AM

Stop = Not applicable

Core = Not applicable

Info = NCTemplateMgr started.

Process= NetShowMgr

State = Running normally

Pid = 7560

RC = 0

Signo = 0

Start = 7/26/2008 11:11:16 AM

Stop = Not applicable

Core = Not applicable

Info = NetShowMgr started.

New Member

Re: CiscoWorks LMS 2.5 not sending Traps (email notification) to

Process= RMEOGSServer

State = Program started - No mgt msgs received

Pid = 7396

RC = 0

Signo = 0

Start = 7/26/2008 11:11:16 AM

Stop = Not applicable

Core = Not applicable

Info = Server started by admin request

Process= TISServer

State = Program started - No mgt msgs received

Pid = 6104

RC = 0

Signo = 0

Start = 7/26/2008 11:11:16 AM

Stop = Not applicable

Core = Not applicable

Info = Server started by admin request

Process= DFMOGSServer

State = Program started - No mgt msgs received

Pid = 884

RC = 0

Signo = 0

Start = 7/26/2008 11:11:20 AM

Stop = Not applicable

Core = Not applicable

Info = Server started by admin request

Process= InventoryCollector

State = Running normally

Pid = 1300

RC = 0

Signo = 0

Start = 7/26/2008 11:11:24 AM

Stop = Not applicable

Core = Not applicable

Info = InventoryCollector is up and running

Process= Interactor

State = Program started - No mgt msgs received

Pid = 8576

RC = 0

Signo = 0

Start = 7/26/2008 11:11:29 AM

Stop = Not applicable

Core = Not applicable

Info = Server started by admin request

Process= NOSServer

State = Running normally

Pid = 8592

RC = 0

Signo = 0

Start = 7/26/2008 11:11:29 AM

Stop = Not applicable

Core = Not applicable

Info = NOSServer is up and running

Process= PTMServer

State = Running normally

Pid = 8604

RC = 0

Signo = 0

Start = 7/26/2008 11:11:29 AM

Stop = Not applicable

Core = Not applicable

Info = Started Successfully

Process= EDS-GCF

State = Running normally

Pid = 8652

RC = 0

Signo = 0

Start = 7/26/2008 11:11:29 AM

Stop = Not applicable

Core = Not applicable

Info = GCF Initialization complete at Sat Jul 26 11:11:43 IST 2008

Process= jrm

State = Running normally

Pid = 8720

RC = 0

Signo = 0

Start = 7/26/2008 11:11:30 AM

Stop = Not applicable

Core = Not applicable

Info = Server started by admin request

Process= CTMJrmServer

State = Running normally

Pid = 9844

RC = 0

Signo = 0

Start = 7/26/2008 11:11:45 AM

Stop = Not applicable

Core = Not applicable

Info = CTMJrmServer started.

Process= ChangeAudit

State = Program started - No mgt msgs received

Pid = 10124

RC = 0

Signo = 0

Start = 7/26/2008 11:11:51 AM

Stop = Not applicable

Core = Not applicable

Info = Server started by admin request

Process= SyslogAnalyzer

State = Program started - No mgt msgs received

Pid = 10132

RC = 0

Signo = 0

Start = 7/26/2008 11:11:51 AM

Stop = Not applicable

Core = Not applicable

Info = Server started by admin request

New Member

Re: CiscoWorks LMS 2.5 not sending Traps (email notification) to

Process= DataPurge

State = Administrator has shut down this server

Pid = 0

RC = 0

Signo = 0

Start = 7/26/2008 11:11:51 AM

Stop = 7/26/2008 12:00:00 PM

Core = Not applicable

Info = DataPurge initialization completed at Sat Jul 26 11:12:25 IST 2

008.

Process= ANIDbEngine

State = Program started - No mgt msgs received

Pid = 10148

RC = 0

Signo = 0

Start = 7/26/2008 11:11:53 AM

Stop = Not applicable

Core = Not applicable

Info = Application started by administrator request.

Process= ANIServer

State = Running with busy flag set

Pid = 8308

RC = 0

Signo = 0

Start = 7/26/2008 11:11:57 AM

Stop = Not applicable

Core = Not applicable

Info = ANIServer started.

Process= UTMajorAcquisition

State = Transient terminated

Pid = 0

RC = 0

Signo = 0

Start = 7/29/2008 2:00:00 PM

Stop = 7/29/2008 2:08:54 PM

Core = Not applicable

Info = Server started by admin request

Process= AdapterServer

State = Program started - No mgt msgs received

Pid = 8756

RC = 0

Signo = 0

Start = 7/26/2008 11:12:01 AM

Stop = Not applicable

Core = Not applicable

Info = Server started by admin request

Cisco Employee

Re: CiscoWorks LMS 2.5 not sending Traps (email notification) to

Please post your NOSServer.log as well as the log\dfmLogs\NOS\nos.log. Also post the details of an event seen in AAD which did not generate a notification.

New Member

Re: CiscoWorks LMS 2.5 not sending Traps (email notification) to

NOSServer log is as below :-

Process = NOSServer

Path = C:\PROGRA~1\CSCOpx\bin\cwjava.exe

Flags = -server -cp:p MDC\tomcat\webapps\triveni\WEB-INF\lib\lo

g4j.jar,MDC\tomcat\webapps\triveni\WEB-INF\lib\nos.jar,MDC\tomcat\webapps\triven

i\WEB-INF\lib\ctm.jar,MDC\tomcat\webapps\triveni\WEB-INF\lib\ogs-client.jar,MDC\

tomcat\webapps\triveni\WEB-INF\lib\cogs.jar,MDC\tomcat\webapps\triveni\WEB-INF\l

ib\ogs-kc1.0.jar,MDC\tomcat\webapps\triveni\WEB-INF\lib\ogs-kilnervirtualasa1.0.

jar,MDC\tomcat\webapps\triveni\WEB-INF\lib\activation.jar,MDC\tomcat\webapps\tri

veni\WEB-INF\lib\mail.jar,MDC\tomcat\webapps\triveni\WEB-INF\lib\tis-client.jar,

MDC\tomcat\webapps\triveni\WEB-INF\lib\pm.jar,lib\classpath\jconn2.jar,lib\class

path\epm-v0-5-0.jar,lib\classpath\cesar-v0-5-0b.jar,MDC\tomcat\shared\lib\NATIVE

.jar,MDC\tomcat\shared\lib\MICE.jar,MDC\bin,objects\nos\config,MDC\tomcat\webapp

s\triveni\WEB-INF\classes, -cw:jre C:\PROGRA~1\CSCOpx\MDC\jre -cw:xrs -Djava.co

mpiler=NONE com.cisco.nm.trx.nos.server.NOSServer

Startup = Started automatically at boot.

Dependencies = EPMDbEngine EPMServer INVDbEngine PMServer DFMOGSServer

Cisco Employee

Re: CiscoWorks LMS 2.5 not sending Traps (email notification) to

When I say NOSServer.log, I mean the file named NOSServer.log under NMSROOT\log.

Cisco Employee

Re: CiscoWorks LMS 2.5 not sending Traps (email notification) to

I see that these two events were generated before this nos.log began. Therefore, it is not very useful. It would be helpful to see a nos.log and event details which cover the same time period.

New Member

Re: CiscoWorks LMS 2.5 not sending Traps (email notification) to

I am waiting for your reply...(solution)

Silver

Re: CiscoWorks LMS 2.5 not sending Traps (email notification) to

Its usually an issue with the host operating system that prevents the mail from within the application from functioning.

On the operating system can you perform the following ? :

nslookup at the "nslookup>" prompt enter in "set q=mx" ad hit return , this limits your query to only MailExchange (mx) results.

Enter in the name of your mail server and hit return. Copy down the information that results.

Telnet to that address port 25 (unix SMTP) or 123 (windows IMAP) and see if you get a connection, if you do its most likely a mail credentials issue you'll need to work out with the mail administrator. If you dont get a connection, ping the IP address of the mail server from the application server.

Are there any ACLs or firewalls in between the LMS installation and mail server ?

New Member

Re: CiscoWorks LMS 2.5 not sending Traps (email notification) to

I have the same problem on 2.6. It was working but I am no longer getting email notifications. I still get the traps. I can telnet to my email server via port 25, so smtp is listening. There are no ACL's blocking traffic so I know that it is an application issue with lms... somewhere.

Cisco Employee

Re: CiscoWorks LMS 2.5 not sending Traps (email notification) to

DFM 2.0.10 is affected by a bug where notifications are no longer sent. If you upgrade to 2.0.11, this problem is fixed.

New Member

Re: CiscoWorks LMS 2.5 not sending Traps (email notification) to

I did that last week, but have not seen the desired results.

Cisco Employee

Re: CiscoWorks LMS 2.5 not sending Traps (email notification) to

Please start a new thread for this as the troubleshooting steps required will be different that with the issue in this thread.

415
Views
0
Helpful
20
Replies
CreatePlease to create content