Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

ciscoworks - lms3.2 issue /rme ng db not starting

Hi Team,

I am experiencing the below error while accessing the lms application, in the below scenarios. Server is running in VMWARE workstation.

In LMS server
no 'cmd' paameter received.

From a local machine, while accessing the application.
LMS 3.2 You don't have permission to access /cwhp/LiaisonServlet on this servlet.

Below are the trobleshooting i have done.

-Tried causer reset.
-services are in proper order
-no displaying output for pdshow
-tried rebooting the services & server.
-Disabled and excluded the lms folder in symantec av.
-No other 3rd party s/ws are installed.

pls find the attachement. some of those services do not start automatically, but when we do right click and start it, it does...but we can not access the application... In the lms server, when we access it, we get the logon page and, as soon as we enter, it will throw the error...

---sec-IT

11 REPLIES
Cisco Employee

ciscoworks - lms3.2 issue /rme ng db not starting

You should give more time to start the processes unless they throw an error. Try disabling AV and I recommend to permanently  exclude the CSCOpx directory from Active Scan.

Check the NMSROOT/Objects/dmgt/ready directory if it shows the dmgtd.lock file which indicates the Daemon Manager is busy starting the the registered processes.

See if there is any error in Syslog.log for any process not starting or if there is any error in Windows Event Viewer.

-Thanks

Vinod

-Thanks Vinod **Rating Encourages contributors, and its really free. **
New Member

ciscoworks - lms3.2 issue /rme ng db not starting

Hi vinod,

AV was already disabled & syslog.log file is empty. Did see the dmgtd.lock file with 0 size.I do not see anything related to application/security in eventviewer.

i did disable the ssl using the cmd  "perl configssl.pl -disable", and then i was able to access it thru http:1741, but inside modules were throwing error stating that daemons are no running.

Cisco Employee

ciscoworks - lms3.2 issue /rme ng db not starting

Please try the following steps:

1. Stop the daemon manager

2. Regenerate the SSL certificate (Dont forget to start you shell/command prompt session as Administrator):

     *Remove server.*  files under NMSROOT\MDC\Apache\conf\ssl (take backup of all 4 files before deleting).

     *NMSROOT\bin\perl NMSROOT\MDC\Apache\ConfigSSL.pl -disable

     *NMSROOT\bin\perl NMSROOT\MDC\Apache\ConfigSSL.pl -enable

     *Fill all the details it request for.

     *Ensure that the following files are created under NMSROOT\MDC\Apache\conf\ssl :

server.crt

server.csr

server.key

server.pk8

3. Do a trasaction log recovery for all Db's :

     * Goto NMSROOT/databases/* and remove *.log file. (* is teh db name for all different DB flders there)

     * on command prompt run following command :

dbsrv10 -f *.db

Example:

C:\Program Files (x86)\CSCOpx\databases\rmeng>dir *.log

Volume in drive C has no label.

Volume Serial Number is E492-A3AB

  Directory of C:\Program Files (x86)\CSCOpx\databases\rmeng

03/27/2012  07:01 AM           196,608 rmeng.log

               1 File(s)        196,608 bytes

               0 Dir(s)  27,119,108,096 bytes free


C:\Program Files (x86)\CSCOpx\databases\rmeng>del rmeng.log (you have to delete if from GUI, cli mostly doesnt work)

C:\Program Files (x86)\CSCOpx\databases\rmeng>dbsrv10 -f rmeng.db

4. Repeat this for all the DB's like cmf, ani, dfm*, ipm etx. Though tedious, but often bvring good results.

5. Reset casuser:

NMSROOT/setup/support/resetcasuser.exe

6. Start the daemon manager :

Net start crmdmgtd

Please give the full time unless it give error in syslog.log. keep on checking if NMSROOT/Objects/dmgt/ready if it shows dmgtd.lock there and see if the task manager is showing increasing processes.

Also just to check I would suggest to make casuser a member of administrators group.

-Thanks

Vinod

-Thanks Vinod **Rating Encourages contributors, and its really free. **
New Member

ciscoworks - lms3.2 issue /rme ng db not starting

hey Vindod, thanks a lot for the detailed info & steps.. One clarificatio, will the db go away if we do the dbsrv10 -f *.db ?? pls confirm, will there be any dataloss in these steps.

Cisco Employee

ciscoworks - lms3.2 issue /rme ng db not starting

Hi Rajesh,

No this will not remove anything. This utility does a Transactinal log recovery, which ideally reindexes the DB and removes any error in indexing from Sybase DB.

No -ve impact. It is comparable to windows as revert to lsat good known configuraiton. But wont miss on any data/devices etx.

-Thanks

Vinod

-Thanks Vinod **Rating Encourages contributors, and its really free. **
New Member

ciscoworks - lms3.2 issue /rme ng db not starting

Yep, thanks vinod.. i was referring the below link as well.

https://supportforums.cisco.com/docs/DOC-8796

i will update the status in 10 mins., i have almost finished the task.

New Member

Re: ciscoworks - lms3.2 issue /rme ng db not starting

--i will update.

New Member

Re: ciscoworks - lms3.2 issue /rme ng db not starting

Hi,

Now all the services have come up automatically, but I am still getting the same error.pls help.

Cisco Employee

ciscoworks - lms3.2 issue /rme ng db not starting

What erorrs do you see? Check the process status from : pdshow from command prompt.

Use pdshow -brief. As there is so many issues, i would like to know if this server has worked fine ever? Is this a new install? If yes please share the install Log from c:\.

-Thanks

-Thanks Vinod **Rating Encourages contributors, and its really free. **
New Member

ciscoworks - lms3.2 issue /rme ng db not starting

Actually pdshow does not work at all... I am not getting any outout.

This was a working device, and i have just taken the db backup.

Could you tell, what logs are reqd from which location pls..

New Member

ciscoworks - lms3.2 issue /rme ng db not starting

Hi vinod, i have disabled ssl (perl configssl -disable), now the portal has got displayed, but the internal modules in CS shows, DCR is down... I am not able to open process window inside the CS, as it takes too much of time to open and in the end it gives a white scren..

787
Views
10
Helpful
11
Replies
CreatePlease to create content