Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CiscoWorks RME Daily Archive Poller Failure

I'm running LMS 2.6 with RME 4.0.6.

The current situation is that the job simply fails, and doesn't appear to have polled anything.

Because I'm not aware of the exact service at fault, I stop and restart the CW daemon. This fixes the issue for a single daily run. All jobs after the first run fail.

I get a single email:

Hello,

The following is the status of your Change Poller based Collection job:

Job ID : 1015

Status : Job Failed

Description : System config polling job

Details : https://nms.ArkansasElectric.com:443/rme/DcmaJobDetails.do?jobid=1015.192

Start Date and Time : Thu Sep 04 17:00:21 CDT 2008

End Date and Time : Thu Sep 04 17:00:21 CDT 2008

RME Server Name/IP : nms.ArkansasElectric.com

Execution Summary

Pending : 0

NotAttempted : 0

Successfull : 0

Failed : 0

Partial Success : 0

I'm pretty sure this all began after we had a disaster in our data center. I know the server CW runs on went down without being properly shut down, so that probably has something to do with it.

Does anyone have any advice, or knowledge about how to remedy the situation?

Thanks,

Daniel

17 REPLIES
Cisco Employee

Re: CiscoWorks RME Daily Archive Poller Failure

Please post the output of the pdshow command when the polling fails.

New Member

Re: CiscoWorks RME Daily Archive Poller Failure

I've attached the output of the pdshow.

The image I've attached is an error message that I receive when I access "Archive Management". Access is fine for several attempts to access at a time, then I receive this message. After I receive this message I am unable to access any part of Cisco Works except the home page. This is also the point that scheduled jobs fail.

Cisco Employee

Re: CiscoWorks RME Daily Archive Poller Failure

Is this installed on Windows or Solaris?

New Member

Re: CiscoWorks RME Daily Archive Poller Failure

Windows Server 2003 Standard

Cisco Employee

Re: CiscoWorks RME Daily Archive Poller Failure

It appears there may be a problem with your RME database. It may be corrupt in some way which is triggering a failure, or there may be a connection exhaustion. Please post your RMEDbMonitor.log, and the contents of the Windows Application Event Viewer.

New Member

Re: CiscoWorks RME Daily Archive Poller Failure

That would not suprise me. From what I saw that does appear to be a fair assumption. I filtered the event viewer for the RMEDbEngine instead of showing everything, but if you'd like to see something else specific please let me know.

Cisco Employee

Re: CiscoWorks RME Daily Archive Poller Failure

It does appear your database is corrupt. If you have a known good backup of LMS, you should restore it. If not, you will need to reinitialize the RME database with the command:

NMSROOT\bin\perl NMSROOT\bin\dbRestoreOrig.pl dsn=rmeng dmprefix=RME

New Member

Re: CiscoWorks RME Daily Archive Poller Failure

I don't know if my last couple backups are any good. What will that command do to everything I currently have in RME? Will it all be lost?

Cisco Employee

Re: CiscoWorks RME Daily Archive Poller Failure

Yes, all your RME data will be lost.

New Member

Re: CiscoWorks RME Daily Archive Poller Failure

I restored to a backup and it all went fine. It's running fine now, only the scheduled daily poll seems to fail before it starts. Before when it would fail it would say

Pending : 0

NotAttempted : 0

Successfull : 0

Failed : 0

Partial Success : 0

I guess because of the databse problem, but now it says all the devices are Pending, but the process just fails. I noticed that manually running syncs would complete successfully, but I had run a job that just kept running and would not stop - and it won't. It just says "Stop Initiated". Now all REM jobs fail. Any logs that show this info?

Cisco Employee

Re: CiscoWorks RME Daily Archive Poller Failure

The dcmaservice.log would show any errors. Howeber, if you have a wedged job, you will need to restart ConfigMgmtServer at the very least for new config jobs to run again.

New Member

Re: CiscoWorks RME Daily Archive Poller Failure

Thanks that finally killed that job. I just noticed another problem though. ANIServer Fails to run. If I start it says

Program started - No mgt msgs received

Then

Running with busy flag set

Then

Failed to run

Any ideas?

Cisco Employee

Re: CiscoWorks RME Daily Archive Poller Failure

Please start a new thread for the problem with ANIServer.

New Member

Re: CiscoWorks RME Daily Archive Poller Failure

I restarted the Daemon and so far it looks fine. I'll start a new thread if I continue to have problems with it. Thank you for your help.

New Member

Re: CiscoWorks RME Daily Archive Poller Failure

What Daemon did you have to restart?

New Member

Re: CiscoWorks RME Daily Archive Poller Failure

This was a while back, but I'm pretty sure I was referring to crmdmgtd.

New Member

Re: CiscoWorks RME Daily Archive Poller Failure

Thank you. I have a little bat file for this. However, I will have to wait until after hours to run this since it shuts everything down and restarts it. I find it takes about 1/2 hour before the system is usable again.

631
Views
0
Helpful
17
Replies