Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k

CM N-Hop View not working

Hi everyone,

I'm experiencing some problems with my Campus Manager 5.2. It is unable to view any topology for any device in N-Hop View portlet. There is following Error message in portlet:

Unable to load N-Hop View.
Probable cause :
     No neighbors found for the specified device

The message appears anytime, for any device I select.

I've found in campusportal.log:

21/Oct/2010 15:06:29:183 DEBUG  com.cisco.nm.portalapi.qtopo.QTopoQuery getData  - Setting N-Hop view client is active
21/Oct/2010 15:06:29:198 ERROR  com.cisco.nm.portalapi.qtopo.ds.QTopoData extractDevices  - Device with dbid:9480314 is not found, so returning NULL

There is no helpful debug in ani.log file as far as I can recognize. If anyone solved familiar problem, please help.

Best regards,

Przemek

Everyone's tags (5)
1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: CM N-Hop View not working

This looks like a problem with the ANI database.  I have seen this before if a VSS device is used as the root in N-Hop view.  A reinitialization of the ANI database may solve this:

NMSROOT/bin/perl NMSROOT/campus/bin/reinitdb.pl

4 REPLIES
Cisco Employee

Re: CM N-Hop View not working

This looks like a problem with the ANI database.  I have seen this before if a VSS device is used as the root in N-Hop view.  A reinitialization of the ANI database may solve this:

NMSROOT/bin/perl NMSROOT/campus/bin/reinitdb.pl

Re: CM N-Hop View not working

The reinitialization of ANI database worked, but some historical data was lost as result (witch was quite obvious to happen). It worked even there was no VSS device as far as I know.

Thank you for your help.

Is there any guide how to use perl scripts delivered with LMS?

Thank you for your answer in advance.

PP

Cisco Employee

Re: CM N-Hop View not working

Not for scripts like this as they are designed to be used with TAC or support guidance.  However, I wrote a general LMS database troubleshooting guide at https://supportforums.cisco.com/docs/DOC-8796, which describes a method to reinitialize all LMS databases.

Re: CM N-Hop View not working

I've seen and used this document. It is piece of candy . Reinitialization of databases are very effective, but sometimes we can't loose of of the data :/. I wish there was a better way.

Thank you very much for your help!

Best Regards,

Przemysław Przytuła

886
Views
0
Helpful
4
Replies
CreatePlease to create content