Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CNA 5.8.8 doesn't show my topology?

Hi,

Yesterday I've downloaded and installed the brand new 5.8.8 Network Assitant.

I must say it looks promissing cause it now supports our AP's.

However it seems that it's not showing the topology?

I re-booted, checked my logging, checked JAVA version, Updated JAVA version etc. but so far no luck.

Does anybody have a clue why this happens?

My feeling says it has something to do with JAVA but I still haven't found the root cause.

Any help is more then  welcome.

Thanks in advance,

B@rt

Everyone's tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: CNA 5.8.8 doesn't show my topology?

We will be posting a patch that addresses topology view in a day or two. Thank you for the patience.

Thanks

Kishan

31 REPLIES
New Member

CNA 5.8.8 doesn't show my topology?

Hi,

I must say I have the same issue. After the update to 5.8.8 the CNA Topology screen remains black without info.

I see that it discovers but no results.

Sure hope somebody nows how to solve this.

Cisco Employee

CNA 5.8.8 doesn't show my topology?

Hello,

We are investigating the issue and get back to you on it shortly.

Thanks,

Efrat

Cisco Employee

CNA 5.8.8 doesn't show my topology?

Hello,

Can one of you please tell me the platform (MAC or Windows) that you are using to run CNA 5.8.8? I am trying to reproduce this issue in MAC and have not been successful. Can you send me your application log file?

Thanks

Kishan

Hall of Fame Super Silver

Re: CNA 5.8.8 doesn't show my topology?

I just ran the 5.8.8 update and mine also fails to display topology (after about 30 minutes of "discovering topology" in the status bar).

The inventory appears to be fine and all devices are reachable via http, https, ssh and SNMP. The community topology displayed fine from the same PC (and same Java) with CNA 5.8.7 as recently as 2 weeks ago.

I am using Windows 7 client with the latest Java. I can send the application log if you PM me your address.

Hint - the log has lots of errors like this:

Exception e: Received fatal alert: handshake_failure

javax.net.ssl.SSLHandshakeException: Received fatal alert: handshake_failure

Cisco Employee

Re: CNA 5.8.8 doesn't show my topology?

Hi Marvin,

CNA uses its own JRE and should not use other JRE installed on your machine. Can you please go to your CNA installation directory/packages/runtime-1.54/bin and type "java -version" and post the output. I want to take a look at the application log but don't wan to publish my email. Exception you are seeing is harmless but should not happen, that is why I am asking for JRE version in runtime-1.54/bin directory.

Thanks

Kishan

New Member

CNA 5.8.8 doesn't show my topology?

C:\Program Files (x86)\Cisco Systems\Cisco Network Assistant\packages\runtime-1.

54\bin>java -version

java version "1.6.0_43"

Java(TM) SE Runtime Environment (build 1.6.0_43-b01)

Java HotSpot(TM) Client VM (build 20.14-b01, mixed mode)

C:\Program Files (x86)\Cisco Systems\Cisco Network Assistant\packages\runtime-1.

54\bin>java -version

java version "1.6.0_43"

Java(TM) SE Runtime Environment (build 1.6.0_43-b01)

Java HotSpot(TM) Client VM (build 20.14-b01, mixed mode)

Hall of Fame Super Silver

Re: CNA 5.8.8 doesn't show my topology?

Here is my output:

C:\Program Files (x86)\Cisco Systems\Cisco Network Assistant\packages\runtime-1.54>java -version

java version "1.7.0_40"

Java(TM) SE Runtime Environment (build 1.7.0_40-b43)

Java HotSpot(TM) 64-Bit Server VM (build 24.0-b56, mixed mode)

C:\Program Files (x86)\Cisco Systems\Cisco Network Assistant\packages\runtime-1.54>

Cisco Employee

CNA 5.8.8 doesn't show my topology?

Hi Marvin,

Can you please try

C:\Program Files (x86)\Cisco Systems\Cisco Network Assistant\packages\runtime-1.54\bin\java -version

In your earlier try you left out bin directory. Do you still see "SSLHandshakeException" that you had reported in your earlier mail? Please close CNA and relaunch and it should go away.

Thanks

Kishan

Hall of Fame Super Silver

Re: CNA 5.8.8 doesn't show my topology?

Sorry about that.

Here is the output from \bin:

C:\Program Files (x86)\Cisco Systems\Cisco Network Assistant\packages\runtime-1.54\bin>java -version

java version "1.6.0_43"

Java(TM) SE Runtime Environment (build 1.6.0_43-b01)

Java HotSpot(TM) Client VM (build 20.14-b01, mixed mode)

C:\Program Files (x86)\Cisco Systems\Cisco Network Assistant\packages\runtime-1.54\bin>

I just verified a machine running CNA 5.8.7 discovers and displays topology on the same commuinity just fine. (takes about 30 seconds). It's a pretty simple community - a pair of 4507 and 11 each 3750X, some in 2-3 switch stacks.

My 5.8.8 machine continues to have the same lack of success (even after a cold boot).

New Member

CNA 5.8.8 doesn't show my topology?

This is from my machine:

C:\>java -version

java version "1.7.0_40"

Java(TM) SE Runtime Environment (build 1.7.0_40-b43)

Java HotSpot(TM) 64-Bit Server VM (build 24.0-b56, mixed mode)

C:\>java -version

java version "1.7.0_40"

Java(TM) SE Runtime Environment (build 1.7.0_40-b43)

Java HotSpot(TM) 64-Bit Server VM (build 24.0-b56, mixed mode)

New Member

CNA 5.8.8 doesn't show my topology?

Hi Marvin,

Excectly the same here.

Also tried JAVA i586 and x64 latest version etc. but no luck.

B@rt

New Member

CNA 5.8.8 doesn't show my topology?

Hi Padumane Kishan,

I have Windows 7 Pro.

Will provide a log overview.

B@rt

New Member

CNA 5.8.8 doesn't show my topology?

Same here on windows platform.  Topology view is blank and unresponsive.  No right click or anything.  Seems like a Java issue.

Cisco Employee

Re: CNA 5.8.8 doesn't show my topology?

Thank you all for your feedback and help on this!

We are not able to reproduce this issue in our environments, so could I kindly ask for some volunteers to help us debug the issue live?

If you are willing to help us - please send an cs-cna@cisco.com

Thank you very much!

Efrat

New Member

CNA 5.8.8 doesn't show my topology?

Greetings,

I've just attempted to reply witheeee my willingness to help debug, but my email to cs-cna@cisco.com just got bounced:

rcdn-inbound-d.cisco.com #550 #5.1.0 Address rejected. ##

Any advice?

Best regards,

Cisco Employee

CNA 5.8.8 doesn't show my topology?

Hello,

Just now I tried cs-cna@cisco.com and it is working fine. Can you please try again and send Application log?

Thanks

Kishan

Hall of Fame Super Silver

Re: CNA 5.8.8 doesn't show my topology?

I too was unable to send along my application log via e-mail. I suspect your external mail server is rejecting it since 72.163.0.0 is at Cisco.

Delivery has failed to these recipients or groups:

cs-cna@cisco.com
A problem occurred during the delivery of this message to this e-mail address. Try sending this message again. If the problem continues, please contact your helpdesk.

The following organization rejected your message: [72.163.7.166].

FYI Inventory and front panel views work perfectly - it's only topology that fails. Status shows "Discovering Topology" for about 30 minutes and then finally displays a black screen in Topology view.

Cisco Employee

CNA 5.8.8 doesn't show my topology?

Hi Marvin,

cs-cna@cisco.com is working, I tried in the morning. Can you please send your application log when you see black screen in Topology View.

Thanks

Kishan

Hall of Fame Super Silver

CNA 5.8.8 doesn't show my topology?

Kishan,

I re-sent the application log just now. It seems to have not bounced this time.

New Member

CNA 5.8.8 doesn't show my topology?

Hello,

where can i download the new version ?

Is the new 2960X supported ?

Thks

Steffen

Hall of Fame Super Silver

CNA 5.8.8 doesn't show my topology?

There's a link to the software download area on the product support page here.

The 2960-X is not yet supported by CNA. It's not even showing up in the Prime LMS supported devices just yet.

New Member

CNA 5.8.8 doesn't show my topology?

I am getting a bounce when trying to email that address as well.

New Member

CNA 5.8.8 doesn't show my topology?

Afternoon all

As soon as I ran the 5.8.8, I too lost the topology view. I had two communities open at the time of the upgrade. One still works and the other doesnt. The critical one I need however, doesnt work. When I try and recreate a new community, I am told that the DNS entry is invalid??? and that I should try using an IP address, which is what I was trying to do in the first place.

This has never been an issue with the previous versions until now. So from the other responses, there is obvioulsy an issue with this latest release. How do I send the debug information from CNA, as mentioned above??

Regards

Stefan

Cisco Employee

CNA 5.8.8 doesn't show my topology?

Thank you all for your help in debugging this issue.

We were able to reproduce it here, and have found the root cause.

We'll be releasing a patch release along with this fix, titled 5.8.8.1, on October 11th.

Thank you for your patience until this corrected version is released.

Thanks,

Efrat

Hall of Fame Super Silver

Re: CNA 5.8.8 doesn't show my topology?

It looks like 5.8.8. has been withdrawn - it no longer shows up on the CNA download page.

New Member

CNA 5.8.8 doesn't show my topology?

I do not see a link to the patch that was to be release on the download page, has the release been pushed back?

New Member

Re: CNA 5.8.8 doesn't show my topology?

Was looking forward to finally getting this issue fixed, as i use this all the time. Am hoping that CIsco will come back to us shortly with the patch.

Cisco Employee

Re: CNA 5.8.8 doesn't show my topology?

We will be posting a patch that addresses topology view in a day or two. Thank you for the patience.

Thanks

Kishan

New Member

Re: CNA 5.8.8 doesn't show my topology?

Morning all,

I have just loaded the lastest update 5.8.8.1, a few minutes ago, and I can confirm the topology view has been restored.

Cheers

2184
Views
5
Helpful
31
Replies
CreatePlease to create content